X2Go Bug report logs - #710
Error connecting to CentOS 5 Server: Connection Failed "Undefined subroutine &X2Go::Server::DB::PostgreSQL::LOG_UPTO

version graph

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Michael DePaulo <mikedep333@gmail.com>

Date: Mon, 22 Dec 2014 01:20:02 UTC

Severity: normal

Found in version 4.1.0.0-preview

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#710; Package x2goserver. (Mon, 22 Dec 2014 01:20:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael DePaulo <mikedep333@gmail.com>:
New Bug report received and forwarded. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Mon, 22 Dec 2014 01:20:02 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.x2go.org (full text, mbox):

From: Michael DePaulo <mikedep333@gmail.com>
To: submit@bugs.x2go.org
Subject: Error connecting to CentOS 5 Server: Connection Failed "Undefined subroutine &X2Go::Server::DB::PostgreSQL::LOG_UPTO
Date: Sun, 21 Dec 2014 20:19:10 -0500
[Message part 1 (text/plain, inline)]
Package: x2goserver
Version: 4.1.0.0-preview

Server: CentOS 5.11 64-bit with latest updates
[batmin@centos-5 ~]$ x2goversion
Undefined subroutine &main::LOG_UPTO called at /usr/lib64/x2go/x2gosyslog
line 28.
x2goagent: 3.5.0.29
x2goserver: 4.1.0.0-preview
x2goserver-common: 4.1.0.0-preview
x2goserver-extensions: 4.1.0.0-preview
x2goserver-xsession: 4.1.0.0-preview

X2go Client for Windows: 4.0.3.1-20141214-debug

After fixing bug #699, when I attempt to connect to the CentOS 5 server
with X2Go Client, I get this "Connection Failed" error pop-up window:

x2go-DEBUG-onmainwindow.cpp:3382> "Undefined subroutine
&X2Go::Server::DB::PostgreSQL::LOG_UPTO called at
/usr/lib/perl5/vendor_perl/5.8.8/X2Go/Server/DB/PostgreSQL.pm line 42.
Compilation failed in require at
/usr/lib/perl5/vendor_perl/5.8.8/X2Go/Server/DB.pm line 40.
BEGIN failed--compilation aborted at
/usr/lib/perl5/vendor_perl/5.8.8/X2Go/Server/DB.pm line 40.
Compilation failed in require at /usr/bin/x2golistsessions line 27.
BEGIN failed--compilation aborted at /usr/bin/x2golistsessions line 27.

Clicking "OK" results in you not connecting.

I've attached the full log from x2goclient.exe --debug
[Message part 2 (text/html, inline)]
[x2goclient.exe --debug output.txt (text/plain, attachment)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Wed Dec 12 02:53:58 2018; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.