X2Go Bug report logs - #647
Mac client cannot find X server in OSX 10.10 (Yosemite)

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: John Eppley <jmeppley@gmail.com>

Date: Mon, 20 Oct 2014 18:30:01 UTC

Severity: normal

Done: Mihai Moldovan <ionic@ionic.de>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#647; Package x2goclient. (Mon, 20 Oct 2014 18:30:01 GMT) Full text and rfc822 format available.

Acknowledgement sent to John Eppley <jmeppley@gmail.com>:
New Bug report received and forwarded. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Mon, 20 Oct 2014 18:30:02 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.x2go.org (full text, mbox):

From: John Eppley <jmeppley@gmail.com>
To: submit <submit@bugs.x2go.org>
Subject: Mac client cannot find X server in OSX 10.10 (Yosemite)
Date: Mon, 20 Oct 2014 08:25:40 -1000
[Message part 1 (text/plain, inline)]
Package: x2goclient
I am running the Aug 8th version of the Mac Client on the OSX 10.10 preview
and get an error when I try to connect to a server. I've attached a screen
shot of the error and below is taken from ~/.x2go/S-jmeppley-.../sessions:

Socket: PANIC! Failed to resolve address of
'/private/tmp/com.apple.launchd.bZMPGSaE78/org.macosforge.xquartz'.
Loop: PANIC! Unknown display host
'/private/tmp/com.apple.launchd.bZMPGSaE78/org.macosforge.xquartz'.

X11 version: "XQuartz 2.7.7 (xorg-server 1.15.2)"

The x2go server is running on Ubuntu 12.04

server package versions:
x2goserver: "4.0.1.15-0~847~ubuntu12.04.1"
x2goserver-xsession: "4.0.1.18-0~949~ubuntu12.04.1"
nxagent: "2:3.5.0.27-0~446~ubuntu12.04.1"

I can connect to the same server using OSX 10.9 with no errors.
[Message part 2 (text/html, inline)]
[x2goError.png (image/png, attachment)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#647; Package x2goclient. (Tue, 28 Oct 2014 19:00:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to John Eppley <jmeppley@gmail.com>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Tue, 28 Oct 2014 19:00:02 GMT) Full text and rfc822 format available.

Message #10 received at 647@bugs.x2go.org (full text, mbox):

From: John Eppley <jmeppley@gmail.com>
To: 647@bugs.x2go.org
Subject: Works with XQartz/X11 2.7.8 beta and x2go server update
Date: Tue, 28 Oct 2014 08:58:19 -1000
[Message part 1 (text/plain, inline)]
I upgraded the x2go server to 4.0.1.18-0~949~ubuntu12.04.1 and X11 on the
client to the Beta release. The connection works now.

It still works if I roll back to X11 2.7.7.
[Message part 2 (text/html, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#647; Package x2goclient. (Wed, 15 Nov 2017 00:55:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mihai Moldovan <ionic@ionic.de>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Wed, 15 Nov 2017 00:55:02 GMT) Full text and rfc822 format available.

Message #15 received at 647@bugs.x2go.org (full text, mbox):

From: Mihai Moldovan <ionic@ionic.de>
To: John Eppley <jmeppley@gmail.com>, 647@bugs.x2go.org
Subject: Re: [X2Go-Dev] Works with XQartz/X11 2.7.8 beta and x2go server update
Date: Wed, 15 Nov 2017 01:50:55 +0100
[Message part 1 (text/plain, inline)]
Control: close -1

On 10/28/2014 07:58 PM, John Eppley wrote:
> I upgraded the x2go server to 4.0.1.18-0~949~ubuntu12.04.1 and X11 on the client
> to the Beta release. The connection works now. 
> 
> It still works if I roll back to X11 2.7.7. 

Either the X server crashed for some random reason, or you probably just forgot
to log out and back in after installing xorg-server(-devel) via MacPorts.

Closing.


Mihai

[signature.asc (application/pgp-signature, attachment)]

Marked Bug as done Request was from Mihai Moldovan <ionic@ionic.de> to 647-submit@bugs.x2go.org. (Wed, 15 Nov 2017 00:55:02 GMT) Full text and rfc822 format available.

Notification sent to John Eppley <jmeppley@gmail.com>:
Bug acknowledged by developer. (Wed, 15 Nov 2017 00:55:02 GMT) Full text and rfc822 format available.

Bug archived. Request was from Debbugs Internal Request <owner@bugs.x2go.org> to internal_control@bugs.x2go.org. (Wed, 13 Dec 2017 06:24:02 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Sat Apr 20 14:26:14 2019; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.