X2Go Bug report logs - #614
x2goserver fedora 20 x86_64 install broken but Ok if using F18 repo

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Diego COSTE <diego.coste@st.com>

Date: Thu, 18 Sep 2014 15:05:02 UTC

Severity: normal

Tags: not-a-bug

Done: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#614; Package x2goserver. (Thu, 18 Sep 2014 15:05:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Diego COSTE <diego.coste@st.com>:
New Bug report received and forwarded. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>.

Your message had a Version: pseudo-header with an invalid package version:

4.0.1.15-2.el7.x86_64

please either use found or fixed to the control server with a correct version, or reply to this report indicating the correct version so the maintainer (or someone else) can correct it for you.

(Thu, 18 Sep 2014 15:05:02 GMT) Full text and rfc822 format available.


Message #5 received at submit@bugs.x2go.org (full text, mbox):

From: Diego COSTE <diego.coste@st.com>
To: "submit@bugs.x2go.org" <submit@bugs.x2go.org>
Subject: x2goserver fedora 20 x86_64 install broken but Ok if using F18 repo
Date: Thu, 18 Sep 2014 16:46:23 +0200
[Message part 1 (text/plain, inline)]
Package: x2goserver
Version: 4.0.1.15-2.el7.x86_64
OS: Fedora core 20 KDE x86_64 yum-updated on Sept 17th 2014
Summary: trying to install with the 'legitimate' fedora 20 repos fails while it is Ok with the Fedora 18 repo

First tried with the repo in
http://download.opensuse.org/repositories/X11:/RemoteDesktop:/x2go/fedora_20/X11:RemoteDesktop:x2go.repo
=> Failure

Then with Fedora EPEL
http://www.mirrorservice.org/sites/dl.fedoraproject.org/pub/epel/7/x86_64/e/epel-release-7-1.noarch.rpm
=> Failure log


[root@myPC ~]# yum install x2goserver.x86_64
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * livna: ftp-stud.fht-esslingen.de
 * rpmfusion-free: download1.rpmfusion.org
 * rpmfusion-free-updates: download1.rpmfusion.org
 * rpmfusion-nonfree: download1.rpmfusion.org
 * rpmfusion-nonfree-updates: download1.rpmfusion.org
Resolving Dependencies
--> Running transaction check
---> Package x2goserver.x86_64 0:4.0.1.15-2.el7 will be installed
--> Processing Dependency: xorg-x11-fonts-misc for package: x2goserver-4.0.1.15-2.el7.x86_64
--> Processing Dependency: x2goagent for package: x2goserver-4.0.1.15-2.el7.x86_64
--> Processing Dependency: sshfs for package: x2goserver-4.0.1.15-2.el7.x86_64
--> Processing Dependency: pwgen for package: x2goserver-4.0.1.15-2.el7.x86_64
--> Processing Dependency: perl(Sys::Syslog) for package: x2goserver-4.0.1.15-2.el7.x86_64
--> Processing Dependency: perl(File::ReadBackwards) for package: x2goserver-4.0.1.15-2.el7.x86_64
--> Processing Dependency: perl(File::BaseDir) for package: x2goserver-4.0.1.15-2.el7.x86_64
--> Processing Dependency: perl(DBD::SQLite) for package: x2goserver-4.0.1.15-2.el7.x86_64
--> Processing Dependency: perl(Config::Simple) for package: x2goserver-4.0.1.15-2.el7.x86_64
--> Processing Dependency: perl(Capture::Tiny) for package: x2goserver-4.0.1.15-2.el7.x86_64
--> Processing Dependency: perl(:MODULE_COMPAT_5.16.3) for package: x2goserver-4.0.1.15-2.el7.x86_64
--> Running transaction check
---> Package fuse-sshfs.x86_64 0:2.5-1.el7 will be installed
---> Package perl-Capture-Tiny.noarch 0:0.24-1.fc20 will be installed
---> Package perl-Config-Simple.noarch 0:4.59-16.fc20 will be installed
---> Package perl-DBD-SQLite.x86_64 0:1.40-3.fc20 will be installed
---> Package perl-File-BaseDir.noarch 0:0.03-16.fc20 will be installed
---> Package perl-File-ReadBackwards.noarch 0:1.05-1.fc20 will be installed
---> Package perl-Sys-Syslog.x86_64 0:0.33-4.fc20 will be installed
---> Package pwgen.x86_64 0:2.06-10.fc20 will be installed
---> Package x2goagent.x86_64 0:3.5.0.27-1.fc20 will be installed
--> Processing Dependency: nxagent for package: x2goagent-3.5.0.27-1.fc20.x86_64
---> Package x2goserver.x86_64 0:4.0.1.15-2.el7 will be installed
--> Processing Dependency: perl(:MODULE_COMPAT_5.16.3) for package: x2goserver-4.0.1.15-2.el7.x86_64
---> Package xorg-x11-fonts-misc.noarch 0:7.5-9.fc20 will be installed
--> Running transaction check
---> Package nxagent.x86_64 0:3.5.0.27-1.fc20 will be installed
--> Processing Dependency: libXcompshad.so.3()(64bit) for package: nxagent-3.5.0.27-1.fc20.x86_64
--> Processing Dependency: libXcompext.so.3()(64bit) for package: nxagent-3.5.0.27-1.fc20.x86_64
--> Processing Dependency: libXcomp.so.3()(64bit) for package: nxagent-3.5.0.27-1.fc20.x86_64
--> Processing Dependency: libNX_Xtst.so.6()(64bit) for package: nxagent-3.5.0.27-1.fc20.x86_64
--> Processing Dependency: libNX_Xrender.so.1()(64bit) for package: nxagent-3.5.0.27-1.fc20.x86_64
--> Processing Dependency: libNX_Xrandr.so.2()(64bit) for package: nxagent-3.5.0.27-1.fc20.x86_64
--> Processing Dependency: libNX_Xpm.so.4()(64bit) for package: nxagent-3.5.0.27-1.fc20.x86_64
--> Processing Dependency: libNX_Xinerama.so.1()(64bit) for package: nxagent-3.5.0.27-1.fc20.x86_64
--> Processing Dependency: libNX_Xfixes.so.3()(64bit) for package: nxagent-3.5.0.27-1.fc20.x86_64
--> Processing Dependency: libNX_Xext.so.6()(64bit) for package: nxagent-3.5.0.27-1.fc20.x86_64
--> Processing Dependency: libNX_Xdmcp.so.6()(64bit) for package: nxagent-3.5.0.27-1.fc20.x86_64
--> Processing Dependency: libNX_Xdamage.so.1()(64bit) for package: nxagent-3.5.0.27-1.fc20.x86_64
--> Processing Dependency: libNX_Xcomposite.so.1()(64bit) for package: nxagent-3.5.0.27-1.fc20.x86_64
--> Processing Dependency: libNX_X11.so.6()(64bit) for package: nxagent-3.5.0.27-1.fc20.x86_64
---> Package x2goserver.x86_64 0:4.0.1.15-2.el7 will be installed
--> Processing Dependency: perl(:MODULE_COMPAT_5.16.3) for package: x2goserver-4.0.1.15-2.el7.x86_64
--> Running transaction check
---> Package libNX_X11.x86_64 0:3.5.0.27-1.fc20 will be installed
--> Processing Dependency: nx-libs(x86-64) = 3.5.0.27-1.fc20 for package: libNX_X11-3.5.0.27-1.fc20.x86_64
---> Package libNX_Xcomposite.x86_64 0:3.5.0.27-1.fc20 will be installed
---> Package libNX_Xdamage.x86_64 0:3.5.0.27-1.fc20 will be installed
---> Package libNX_Xdmcp.x86_64 0:3.5.0.27-1.fc20 will be installed
---> Package libNX_Xext.x86_64 0:3.5.0.27-1.fc20 will be installed
---> Package libNX_Xfixes.x86_64 0:3.5.0.27-1.fc20 will be installed
---> Package libNX_Xinerama.x86_64 0:3.5.0.27-1.fc20 will be installed
---> Package libNX_Xpm.x86_64 0:3.5.0.27-1.fc20 will be installed
---> Package libNX_Xrandr.x86_64 0:3.5.0.27-1.fc20 will be installed
---> Package libNX_Xrender.x86_64 0:3.5.0.27-1.fc20 will be installed
---> Package libNX_Xtst.x86_64 0:3.5.0.27-1.fc20 will be installed
---> Package libXcomp.x86_64 0:3.5.0.27-1.fc20 will be installed
---> Package libXcompext.x86_64 0:3.5.0.27-1.fc20 will be installed
---> Package libXcompshad.x86_64 0:3.5.0.27-1.fc20 will be installed
---> Package x2goserver.x86_64 0:4.0.1.15-2.el7 will be installed
--> Processing Dependency: perl(:MODULE_COMPAT_5.16.3) for package: x2goserver-4.0.1.15-2.el7.x86_64
--> Running transaction check
---> Package nx-libs.x86_64 0:3.5.0.27-1.fc20 will be installed
---> Package x2goserver.x86_64 0:4.0.1.15-2.el7 will be installed
--> Processing Dependency: perl(:MODULE_COMPAT_5.16.3) for package: x2goserver-4.0.1.15-2.el7.x86_64
--> Finished Dependency Resolution
Error: Package: x2goserver-4.0.1.15-2.el7.x86_64 (epel)
           Requires: perl(:MODULE_COMPAT_5.16.3)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest





Then with x2go.repo =

[X11_RemoteDesktop_x2go]
name=x2go (replaces NX) (Fedora_18)
type=rpm-md
baseurl=http://download.opensuse.org/repositories/X11:/RemoteDesktop:/x2go/Fedora_18/
gpgcheck=1
gpgkey=http://download.opensuse.org/repositories/X11:/RemoteDesktop:/x2go/Fedora_18/repodata/repomd.xml.key
enabled=1


[root@myPC ~]# yum install x2goserver
Loaded plugins: fastestmirror, langpacks
X11_RemoteDesktop_x2go                                                                          | 1.6 kB  00:00:00
Loading mirror speeds from cached hostfile
 * livna: ftp-stud.fht-esslingen.de
 * rpmfusion-free: download1.rpmfusion.org
 * rpmfusion-free-updates: download1.rpmfusion.org
 * rpmfusion-nonfree: download1.rpmfusion.org
 * rpmfusion-nonfree-updates: download1.rpmfusion.org
Resolving Dependencies
--> Running transaction check
---> Package x2goserver.x86_64 0:4.0.1.15-4.2 will be installed
--> Processing Dependency: perl(DBD::SQLite) >= 1.27 for package: x2goserver-4.0.1.15-4.2.x86_64
--> Processing Dependency: perl(Sys::Syslog) >= 0.14 for package: x2goserver-4.0.1.15-4.2.x86_64
--> Processing Dependency: perl(File::ReadBackwards) for package: x2goserver-4.0.1.15-4.2.x86_64
--> Processing Dependency: sshfs for package: x2goserver-4.0.1.15-4.2.x86_64
--> Processing Dependency: perl(Config::Simple) for package: x2goserver-4.0.1.15-4.2.x86_64
--> Processing Dependency: perl(DBD::SQLite) for package: x2goserver-4.0.1.15-4.2.x86_64
--> Processing Dependency: makepasswd for package: x2goserver-4.0.1.15-4.2.x86_64
--> Processing Dependency: perl(DBD::Pg) for package: x2goserver-4.0.1.15-4.2.x86_64
--> Processing Dependency: perl(File::BaseDir) for package: x2goserver-4.0.1.15-4.2.x86_64
--> Processing Dependency: perl(Capture::Tiny) for package: x2goserver-4.0.1.15-4.2.x86_64
--> Processing Dependency: x2goagent for package: x2goserver-4.0.1.15-4.2.x86_64
--> Processing Dependency: perl(Config::Simple) for package: x2goserver-4.0.1.15-4.2.x86_64
--> Processing Dependency: xorg-x11-fonts-misc for package: x2goserver-4.0.1.15-4.2.x86_64
--> Processing Dependency: perl(Sys::Syslog) for package: x2goserver-4.0.1.15-4.2.x86_64
--> Running transaction check
---> Package fuse-sshfs.x86_64 0:2.4-5.fc20 will be installed
---> Package makepasswd.x86_64 0:0.5.3-6.fc20 will be installed
---> Package perl-Capture-Tiny.noarch 0:0.24-1.fc20 will be installed
---> Package perl-Config-Simple.noarch 0:4.59-16.fc20 will be installed
---> Package perl-DBD-Pg.x86_64 0:2.19.3-6.fc20 will be installed
--> Processing Dependency: libpq.so.5()(64bit) for package: perl-DBD-Pg-2.19.3-6.fc20.x86_64
---> Package perl-DBD-SQLite.x86_64 0:1.40-3.fc20 will be installed
---> Package perl-File-BaseDir.noarch 0:0.03-16.fc20 will be installed
---> Package perl-File-ReadBackwards.noarch 0:1.05-1.fc20 will be installed
---> Package perl-Sys-Syslog.x86_64 0:0.33-4.fc20 will be installed
---> Package x2goagent.x86_64 0:3.5.0.27-1.1 will be installed
--> Processing Dependency: nxagent for package: x2goagent-3.5.0.27-1.1.x86_64
---> Package xorg-x11-fonts-misc.noarch 0:7.5-9.fc20 will be installed
--> Running transaction check
---> Package nxagent.x86_64 0:3.5.0.27-1.1 will be installed
--> Processing Dependency: libXcomp.so.3(X2GO)(64bit) for package: nxagent-3.5.0.27-1.1.x86_64
--> Processing Dependency: libXcompshad.so.3(X2GO)(64bit) for package: nxagent-3.5.0.27-1.1.x86_64
--> Processing Dependency: libXcompext.so.3(X2GO)(64bit) for package: nxagent-3.5.0.27-1.1.x86_64
--> Processing Dependency: libNX_Xdmcp.so.6()(64bit) for package: nxagent-3.5.0.27-1.1.x86_64
--> Processing Dependency: libNX_Xrandr.so.2()(64bit) for package: nxagent-3.5.0.27-1.1.x86_64
--> Processing Dependency: libNX_Xfixes.so.3()(64bit) for package: nxagent-3.5.0.27-1.1.x86_64
--> Processing Dependency: libNX_Xcomposite.so.1()(64bit) for package: nxagent-3.5.0.27-1.1.x86_64
--> Processing Dependency: libNX_Xrender.so.1()(64bit) for package: nxagent-3.5.0.27-1.1.x86_64
--> Processing Dependency: libXcomp.so.3()(64bit) for package: nxagent-3.5.0.27-1.1.x86_64
--> Processing Dependency: libXcompext.so.3()(64bit) for package: nxagent-3.5.0.27-1.1.x86_64
--> Processing Dependency: libNX_Xdamage.so.1()(64bit) for package: nxagent-3.5.0.27-1.1.x86_64
--> Processing Dependency: libNX_Xpm.so.4()(64bit) for package: nxagent-3.5.0.27-1.1.x86_64
--> Processing Dependency: libNX_Xinerama.so.1()(64bit) for package: nxagent-3.5.0.27-1.1.x86_64
--> Processing Dependency: libNX_Xtst.so.6()(64bit) for package: nxagent-3.5.0.27-1.1.x86_64
--> Processing Dependency: libNX_X11.so.6()(64bit) for package: nxagent-3.5.0.27-1.1.x86_64
--> Processing Dependency: libXcompshad.so.3()(64bit) for package: nxagent-3.5.0.27-1.1.x86_64
--> Processing Dependency: libNX_Xext.so.6()(64bit) for package: nxagent-3.5.0.27-1.1.x86_64
---> Package postgresql-libs.x86_64 0:9.3.5-1.fc20 will be installed
--> Running transaction check
---> Package libNX_X11-6.x86_64 0:3.5.0.27-1.1 will be installed
---> Package libNX_Xcomposite1.x86_64 0:3.5.0.27-1.1 will be installed
---> Package libNX_Xdamage1.x86_64 0:3.5.0.27-1.1 will be installed
---> Package libNX_Xdmcp6.x86_64 0:3.5.0.27-1.1 will be installed
---> Package libNX_Xext6.x86_64 0:3.5.0.27-1.1 will be installed
---> Package libNX_Xfixes3.x86_64 0:3.5.0.27-1.1 will be installed
---> Package libNX_Xinerama1.x86_64 0:3.5.0.27-1.1 will be installed
---> Package libNX_Xpm4.x86_64 0:3.5.0.27-1.1 will be installed
---> Package libNX_Xrandr2.x86_64 0:3.5.0.27-1.1 will be installed
---> Package libNX_Xrender1.x86_64 0:3.5.0.27-1.1 will be installed
---> Package libNX_Xtst6.x86_64 0:3.5.0.27-1.1 will be installed
---> Package libXcomp3.x86_64 0:3.5.0.27-1.1 will be installed
--> Processing Dependency: libpng15.so.15(PNG15_0)(64bit) for package: libXcomp3-3.5.0.27-1.1.x86_64
--> Processing Dependency: libpng15.so.15()(64bit) for package: libXcomp3-3.5.0.27-1.1.x86_64
---> Package libXcompext3.x86_64 0:3.5.0.27-1.1 will be installed
---> Package libXcompshad3.x86_64 0:3.5.0.27-1.1 will be installed
--> Running transaction check
---> Package libpng15.x86_64 0:1.5.17-2.fc20 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=======================================================================================================================
 Package                            Arch              Version                  Repository                         Size
=======================================================================================================================
Installing:
 x2goserver                         x86_64            4.0.1.15-4.2             X11_RemoteDesktop_x2go             85 k
Installing for dependencies:
 fuse-sshfs                         x86_64            2.4-5.fc20               fedora                             58 k
 libNX_X11-6                        x86_64            3.5.0.27-1.1             X11_RemoteDesktop_x2go            526 k
 libNX_Xcomposite1                  x86_64            3.5.0.27-1.1             X11_RemoteDesktop_x2go            8.9 k
 libNX_Xdamage1                     x86_64            3.5.0.27-1.1             X11_RemoteDesktop_x2go            8.9 k
 libNX_Xdmcp6                       x86_64            3.5.0.27-1.1             X11_RemoteDesktop_x2go             14 k
 libNX_Xext6                        x86_64            3.5.0.27-1.1             X11_RemoteDesktop_x2go             31 k
 libNX_Xfixes3                      x86_64            3.5.0.27-1.1             X11_RemoteDesktop_x2go             12 k
 libNX_Xinerama1                    x86_64            3.5.0.27-1.1             X11_RemoteDesktop_x2go            9.8 k
 libNX_Xpm4                         x86_64            3.5.0.27-1.1             X11_RemoteDesktop_x2go             37 k
 libNX_Xrandr2                      x86_64            3.5.0.27-1.1             X11_RemoteDesktop_x2go             11 k
 libNX_Xrender1                     x86_64            3.5.0.27-1.1             X11_RemoteDesktop_x2go             23 k
 libNX_Xtst6                        x86_64            3.5.0.27-1.1             X11_RemoteDesktop_x2go             15 k
 libXcomp3                          x86_64            3.5.0.27-1.1             X11_RemoteDesktop_x2go            306 k
 libXcompext3                       x86_64            3.5.0.27-1.1             X11_RemoteDesktop_x2go             29 k
 libXcompshad3                      x86_64            3.5.0.27-1.1             X11_RemoteDesktop_x2go             24 k
 libpng15                           x86_64            1.5.17-2.fc20            updates                            92 k
 makepasswd                         x86_64            0.5.3-6.fc20             updates                            26 k
 nxagent                            x86_64            3.5.0.27-1.1             X11_RemoteDesktop_x2go            1.9 M
 perl-Capture-Tiny                  noarch            0.24-1.fc20              updates                            31 k
 perl-Config-Simple                 noarch            4.59-16.fc20             fedora                             35 k
 perl-DBD-Pg                        x86_64            2.19.3-6.fc20            updates                           195 k
 perl-DBD-SQLite                    x86_64            1.40-3.fc20              updates                           1.3 M
 perl-File-BaseDir                  noarch            0.03-16.fc20             fedora                             14 k
 perl-File-ReadBackwards            noarch            1.05-1.fc20              fedora                             17 k
 perl-Sys-Syslog                    x86_64            0.33-4.fc20              fedora                             42 k
 postgresql-libs                    x86_64            9.3.5-1.fc20             updates                           229 k
 x2goagent                          x86_64            3.5.0.27-1.1             X11_RemoteDesktop_x2go             12 k
 xorg-x11-fonts-misc                noarch            7.5-9.fc20               fedora                            5.8 M

Transaction Summary
=======================================================================================================================
Install  1 Package (+28 Dependent packages)

Total size: 11 M
Total download size: 3.0 M
Installed size: 22 M
Is this ok [y/d/N]: y
Downloading packages:
No Presto metadata available for X11_RemoteDesktop_x2go
(1/17): libNX_Xcomposite1-3.5.0.27-1.1.x86_64.rpm                                               | 8.9 kB  00:00:05
(2/17): libNX_X11-6-3.5.0.27-1.1.x86_64.rpm                                                     | 526 kB  00:00:05
(3/17): libNX_Xdamage1-3.5.0.27-1.1.x86_64.rpm                                                  | 8.9 kB  00:00:00
(4/17): libNX_Xdmcp6-3.5.0.27-1.1.x86_64.rpm                                                    |  14 kB  00:00:00
(5/17): libNX_Xfixes3-3.5.0.27-1.1.x86_64.rpm                                                   |  12 kB  00:00:00
(6/17): libNX_Xext6-3.5.0.27-1.1.x86_64.rpm                                                     |  31 kB  00:00:00
(7/17): libNX_Xinerama1-3.5.0.27-1.1.x86_64.rpm                                                 | 9.8 kB  00:00:00
(8/17): libNX_Xpm4-3.5.0.27-1.1.x86_64.rpm                                                      |  37 kB  00:00:00
(9/17): libNX_Xrender1-3.5.0.27-1.1.x86_64.rpm                                                  |  23 kB  00:00:00
(10/17): libNX_Xrandr2-3.5.0.27-1.1.x86_64.rpm                                                  |  11 kB  00:00:00
(11/17): libNX_Xtst6-3.5.0.27-1.1.x86_64.rpm                                                    |  15 kB  00:00:00
(12/17): libXcomp3-3.5.0.27-1.1.x86_64.rpm                                                      | 306 kB  00:00:00
(13/17): libXcompshad3-3.5.0.27-1.1.x86_64.rpm                                                  |  24 kB  00:00:00
(14/17): libXcompext3-3.5.0.27-1.1.x86_64.rpm                                                   |  29 kB  00:00:00
(15/17): x2goagent-3.5.0.27-1.1.x86_64.rpm                                                      |  12 kB  00:00:00
(16/17): nxagent-3.5.0.27-1.1.x86_64.rpm                                                        | 1.9 MB  00:00:00
(17/17): x2goserver-4.0.1.15-4.2.x86_64.rpm                                                     |  85 kB  00:00:00
-----------------------------------------------------------------------------------------------------------------------
Total                                                                                  429 kB/s | 3.0 MB  00:00:07
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction (shutdown inhibited)
  Installing : libpng15-1.5.17-2.fc20.x86_64                                                                      1/29
  Installing : libXcomp3-3.5.0.27-1.1.x86_64                                                                      2/29
  Installing : libNX_X11-6-3.5.0.27-1.1.x86_64                                                                    3/29
  Installing : libNX_Xext6-3.5.0.27-1.1.x86_64                                                                    4/29
  Installing : libNX_Xtst6-3.5.0.27-1.1.x86_64                                                                    5/29
  Installing : libNX_Xrender1-3.5.0.27-1.1.x86_64                                                                 6/29
  Installing : libNX_Xrandr2-3.5.0.27-1.1.x86_64                                                                  7/29
  Installing : libNX_Xdamage1-3.5.0.27-1.1.x86_64                                                                 8/29
  Installing : libXcompshad3-3.5.0.27-1.1.x86_64                                                                  9/29
  Installing : libNX_Xpm4-3.5.0.27-1.1.x86_64                                                                    10/29
  Installing : libNX_Xinerama1-3.5.0.27-1.1.x86_64                                                               11/29
  Installing : libXcompext3-3.5.0.27-1.1.x86_64                                                                  12/29
  Installing : perl-Config-Simple-4.59-16.fc20.noarch                                                            13/29
  Installing : libNX_Xfixes3-3.5.0.27-1.1.x86_64                                                                 14/29
  Installing : perl-Sys-Syslog-0.33-4.fc20.x86_64                                                                15/29
  Installing : xorg-x11-fonts-misc-7.5-9.fc20.noarch                                                             16/29
  Installing : fuse-sshfs-2.4-5.fc20.x86_64                                                                      17/29
  Installing : libNX_Xdmcp6-3.5.0.27-1.1.x86_64                                                                  18/29
  Installing : perl-Capture-Tiny-0.24-1.fc20.noarch                                                              19/29
  Installing : postgresql-libs-9.3.5-1.fc20.x86_64                                                               20/29
  Installing : perl-DBD-Pg-2.19.3-6.fc20.x86_64                                                                  21/29
  Installing : perl-DBD-SQLite-1.40-3.fc20.x86_64                                                                22/29
  Installing : perl-File-BaseDir-0.03-16.fc20.noarch                                                             23/29
  Installing : libNX_Xcomposite1-3.5.0.27-1.1.x86_64                                                             24/29
  Installing : nxagent-3.5.0.27-1.1.x86_64                                                                       25/29
  Installing : makepasswd-0.5.3-6.fc20.x86_64                                                                    26/29
  Installing : perl-File-ReadBackwards-1.05-1.fc20.noarch                                                        27/29
  Installing : x2goagent-3.5.0.27-1.1.x86_64                                                                     28/29
  Installing : x2goserver-4.0.1.15-4.2.x86_64                                                                    29/29
  Verifying  : perl-File-ReadBackwards-1.05-1.fc20.noarch                                                         1/29
  Verifying  : nxagent-3.5.0.27-1.1.x86_64                                                                        2/29
  Verifying  : makepasswd-0.5.3-6.fc20.x86_64                                                                     3/29
  Verifying  : libXcompext3-3.5.0.27-1.1.x86_64                                                                   4/29
  Verifying  : libNX_Xcomposite1-3.5.0.27-1.1.x86_64                                                              5/29
  Verifying  : libNX_Xpm4-3.5.0.27-1.1.x86_64                                                                     6/29
  Verifying  : libNX_Xinerama1-3.5.0.27-1.1.x86_64                                                                7/29
  Verifying  : perl-DBD-Pg-2.19.3-6.fc20.x86_64                                                                   8/29
  Verifying  : perl-File-BaseDir-0.03-16.fc20.noarch                                                              9/29
  Verifying  : perl-DBD-SQLite-1.40-3.fc20.x86_64                                                                10/29
  Verifying  : libNX_Xext6-3.5.0.27-1.1.x86_64                                                                   11/29
  Verifying  : libNX_Xdamage1-3.5.0.27-1.1.x86_64                                                                12/29
  Verifying  : postgresql-libs-9.3.5-1.fc20.x86_64                                                               13/29
  Verifying  : perl-Capture-Tiny-0.24-1.fc20.noarch                                                              14/29
  Verifying  : x2goagent-3.5.0.27-1.1.x86_64                                                                     15/29
  Verifying  : libXcomp3-3.5.0.27-1.1.x86_64                                                                     16/29
  Verifying  : libXcompshad3-3.5.0.27-1.1.x86_64                                                                 17/29
  Verifying  : libNX_X11-6-3.5.0.27-1.1.x86_64                                                                   18/29
  Verifying  : libNX_Xtst6-3.5.0.27-1.1.x86_64                                                                   19/29
  Verifying  : libNX_Xrandr2-3.5.0.27-1.1.x86_64                                                                 20/29
  Verifying  : libNX_Xdmcp6-3.5.0.27-1.1.x86_64                                                                  21/29
  Verifying  : fuse-sshfs-2.4-5.fc20.x86_64                                                                      22/29
  Verifying  : xorg-x11-fonts-misc-7.5-9.fc20.noarch                                                             23/29
  Verifying  : perl-Sys-Syslog-0.33-4.fc20.x86_64                                                                24/29
  Verifying  : libNX_Xrender1-3.5.0.27-1.1.x86_64                                                                25/29
  Verifying  : libNX_Xfixes3-3.5.0.27-1.1.x86_64                                                                 26/29
  Verifying  : perl-Config-Simple-4.59-16.fc20.noarch                                                            27/29
  Verifying  : libpng15-1.5.17-2.fc20.x86_64                                                                     28/29
  Verifying  : x2goserver-4.0.1.15-4.2.x86_64                                                                    29/29

Installed:
  x2goserver.x86_64 0:4.0.1.15-4.2

Dependency Installed:
  fuse-sshfs.x86_64 0:2.4-5.fc20                          libNX_X11-6.x86_64 0:3.5.0.27-1.1
  libNX_Xcomposite1.x86_64 0:3.5.0.27-1.1                 libNX_Xdamage1.x86_64 0:3.5.0.27-1.1
  libNX_Xdmcp6.x86_64 0:3.5.0.27-1.1                      libNX_Xext6.x86_64 0:3.5.0.27-1.1
  libNX_Xfixes3.x86_64 0:3.5.0.27-1.1                     libNX_Xinerama1.x86_64 0:3.5.0.27-1.1
  libNX_Xpm4.x86_64 0:3.5.0.27-1.1                        libNX_Xrandr2.x86_64 0:3.5.0.27-1.1
  libNX_Xrender1.x86_64 0:3.5.0.27-1.1                    libNX_Xtst6.x86_64 0:3.5.0.27-1.1
  libXcomp3.x86_64 0:3.5.0.27-1.1                         libXcompext3.x86_64 0:3.5.0.27-1.1
  libXcompshad3.x86_64 0:3.5.0.27-1.1                     libpng15.x86_64 0:1.5.17-2.fc20
  makepasswd.x86_64 0:0.5.3-6.fc20                        nxagent.x86_64 0:3.5.0.27-1.1
  perl-Capture-Tiny.noarch 0:0.24-1.fc20                  perl-Config-Simple.noarch 0:4.59-16.fc20
  perl-DBD-Pg.x86_64 0:2.19.3-6.fc20                      perl-DBD-SQLite.x86_64 0:1.40-3.fc20
  perl-File-BaseDir.noarch 0:0.03-16.fc20                 perl-File-ReadBackwards.noarch 0:1.05-1.fc20
  perl-Sys-Syslog.x86_64 0:0.33-4.fc20                    postgresql-libs.x86_64 0:9.3.5-1.fc20
  x2goagent.x86_64 0:3.5.0.27-1.1                         xorg-x11-fonts-misc.noarch 0:7.5-9.fc20

Complete!


PS: Not sure if this is of any importance to you, but for the EPEL repos to work I had to comment the mirrorlist definitions and uncomment the baseurl ones instead, otherwise yum would simply stop and recommend disabling the repo. I actually have top do this for almost all fedora repos.
Ex:
[epel]
name=Extra Packages for Enterprise Linux 7 - $basearch
baseurl=http://download.fedoraproject.org/pub/epel/7/$basearch
#mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-7&arch=$basearch
failovermethod=priority
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7

[epel-debuginfo]
name=Extra Packages for Enterprise Linux 7 - $basearch - Debug
baseurl=http://download.fedoraproject.org/pub/epel/7/$basearch/debug
#mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-debug-7&arch=$basearch
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7
gpgcheck=1

[epel-source]
name=Extra Packages for Enterprise Linux 7 - $basearch - Source
baseurl=http://download.fedoraproject.org/pub/epel/7/SRPMS
#mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-source-7&arch=$basearch
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7
gpgcheck=1



[Message part 2 (text/html, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#614; Package x2goserver. (Fri, 19 Sep 2014 14:20:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Bengt Giger <bengt.giger@id.ethz.ch>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Fri, 19 Sep 2014 14:20:02 GMT) Full text and rfc822 format available.

Message #10 received at 614@bugs.x2go.org (full text, mbox):

From: Bengt Giger <bengt.giger@id.ethz.ch>
To: Diego COSTE <diego.coste@st.com>, <614@bugs.x2go.org>
Subject: Re: [X2Go-Dev] Bug#614: x2goserver fedora 20 x86_64 install broken but Ok if using F18 repo
Date: Fri, 19 Sep 2014 16:09:59 +0200
Am 18.09.2014 um 16:46 schrieb Diego COSTE:
> Package: x2goserver
> Version: 4.0.1.15-2.el7.x86_64
> OS: Fedora core 20 KDE x86_64 yum-updated on Sept 17th 2014
> Summary: trying to install with the 'legitimate' fedora 20 repos fails while it is Ok with the Fedora 18 repo
>
> First tried with the repo in
> http://download.opensuse.org/repositories/X11:/RemoteDesktop:/x2go/fedora_20/X11:RemoteDesktop:x2go.repo
> => Failure
>
> Then with Fedora EPEL
> http://www.mirrorservice.org/sites/dl.fedoraproject.org/pub/epel/7/x86_64/e/epel-release-7-1.noarch.rpm
> => Failure log

Hi

seems the documentation is quite misleading here: http://wiki.x2go.org/doku.php/doc:installation:x2goserver

It looks like "RHEL 6" and "Fedora EPEL" are on the same level, but in fact "Fedora EPEL" (and "OBS") should appear a level BELOW "RHEL 6".

And the instructions for Fedora are missing. They simply would state

  yum install x2goserver

since a clean F20 can install x2goserver 4.0.1 from the Fedora base repo. This all together tricked you into adding EPEL to Fedora. I recommend you remove all packages fetched from EPEL and remove the repo file from /etc/yum.repos.d/

Regards
Bengt


Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#614; Package x2goserver. (Sun, 21 Sep 2014 03:50:01 GMT) Full text and rfc822 format available.

Acknowledgement sent to Orion Poplawski <orion@cora.nwra.com>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Sun, 21 Sep 2014 03:50:02 GMT) Full text and rfc822 format available.

Message #15 received at 614@bugs.x2go.org (full text, mbox):

From: Orion Poplawski <orion@cora.nwra.com>
To: Diego COSTE <diego.coste@st.com>, 614@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#614: x2goserver fedora 20 x86_64 install broken but Ok if using F18 repo
Date: Sat, 20 Sep 2014 21:45:47 -0600
On 09/18/2014 08:46 AM, Diego COSTE wrote:
> Package: x2goserver
> Version: 4.0.1.15-2.el7.x86_64
> OS: Fedora core 20 KDE x86_64 yum-updated on Sept 17th 2014
> Summary: trying to install with the 'legitimate' fedora 20 repos fails
> while it is Ok with the Fedora 18 repo
>
> First tried with the repo in
> http://download.opensuse.org/repositories/X11:/RemoteDesktop:/x2go/fedora_20/X11:RemoteDesktop:x2go.repo
> => Failure
>
> Then with Fedora EPEL
> http://www.mirrorservice.org/sites/dl.fedoraproject.org/pub/epel/7/x86_64/e/epel-release-7-1.noarch.rpm
> => Failure log

Why don't you just install from the default Fedora 20 repos?  Why on 
earth are you trying to install from the Fedora EPEL EL7 repo?

- Orion


Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#614; Package x2goserver. (Mon, 22 Sep 2014 09:10:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Diego COSTE <diego.coste@st.com>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Mon, 22 Sep 2014 09:10:02 GMT) Full text and rfc822 format available.

Message #20 received at 614@bugs.x2go.org (full text, mbox):

From: Diego COSTE <diego.coste@st.com>
To: Orion Poplawski <orion@cora.nwra.com>, "614@bugs.x2go.org" <614@bugs.x2go.org>
Subject: Re: [X2Go-Dev] Bug#614: x2goserver fedora 20 x86_64 install broken but Ok if using F18 repo
Date: Mon, 22 Sep 2014 10:53:31 +0200
Hi All,

sorry, I was moving from Fedora 17 to 20, and as part of this move I
tried to replicate the repos I had installed earlier, and x2go was one
of those.
I think at that time already I had to use the Fedora 18 repo.

I have now purged all installs of x2go with the proper *yum history
undo* and x2go works out of the F20 box.

Sorry for the trouble.
Diego Coste

PS: FYI using just
   yum erase x2goserver
   rm /etc/yum.repos.d/x2go.repo
   yum clean all
   yum install x2goserver
did not work.
It seems that the dependencies (NX, perl libs, ...) installed for the
opensuse repo version of x2goserver do satisfy the install of x2goserver
through the Fedora 20 repo (the install proceeds normally), but I could
not connect to the server.
I had to de-install the dependencies with the yum history undo command
to get a fresh consistent install based solely on the F20 repo, and this
time it worked !


On 21/09/14 05:45, Orion Poplawski wrote:
> On 09/18/2014 08:46 AM, Diego COSTE wrote:
>> Package: x2goserver
>> Version: 4.0.1.15-2.el7.x86_64
>> OS: Fedora core 20 KDE x86_64 yum-updated on Sept 17th 2014
>> Summary: trying to install with the 'legitimate' fedora 20 repos fails
>> while it is Ok with the Fedora 18 repo
>>
>> First tried with the repo in
>> http://download.opensuse.org/repositories/X11:/RemoteDesktop:/x2go/fedora_20/X11:RemoteDesktop:x2go.repo
>> => Failure
>>
>> Then with Fedora EPEL
>> http://www.mirrorservice.org/sites/dl.fedoraproject.org/pub/epel/7/x86_64/e/epel-release-7-1.noarch.rpm
>> => Failure log
> Why don't you just install from the default Fedora 20 repos?  Why on 
> earth are you trying to install from the Fedora EPEL EL7 repo?
>
> - Orion
>


Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#614; Package x2goserver. (Mon, 22 Sep 2014 11:00:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mike Gabriel <mike.gabriel@das-netzwerkteam.de>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Mon, 22 Sep 2014 11:00:02 GMT) Full text and rfc822 format available.

Message #25 received at 614@bugs.x2go.org (full text, mbox):

From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
To: Diego COSTE <diego.coste@st.com>, 614@bugs.x2go.org, Orion Poplawski <orion@cora.nwra.com>
Subject: Re: [X2Go-Dev] Bug#614: Bug#614: x2goserver fedora 20 x86_64 install broken but Ok if using F18 repo
Date: Mon, 22 Sep 2014 10:55:16 +0000
[Message part 1 (text/plain, inline)]
Control: close -1
Control: tag -1 not-a-bug

Hi,

On  Mo 22 Sep 2014 10:53:31 CEST, Diego COSTE wrote:

> Hi All,
>
> sorry, I was moving from Fedora 17 to 20, and as part of this move I
> tried to replicate the repos I had installed earlier, and x2go was one
> of those.
> I think at that time already I had to use the Fedora 18 repo.
>
> I have now purged all installs of x2go with the proper *yum history
> undo* and x2go works out of the F20 box.
>
> Sorry for the trouble.
> Diego Coste

Thus, closing this issue and tagging as not-a-bug.

Mike



-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb
[Message part 2 (application/pgp-signature, inline)]

Marked Bug as done Request was from Mike Gabriel <mike.gabriel@das-netzwerkteam.de> to 614-submit@bugs.x2go.org. (Mon, 22 Sep 2014 11:00:02 GMT) Full text and rfc822 format available.

Notification sent to Diego COSTE <diego.coste@st.com>:
Bug acknowledged by developer. (Mon, 22 Sep 2014 11:00:02 GMT) Full text and rfc822 format available.

Added tag(s) not-a-bug. Request was from Mike Gabriel <mike.gabriel@das-netzwerkteam.de> to 614-submit@bugs.x2go.org. (Mon, 22 Sep 2014 11:00:02 GMT) Full text and rfc822 format available.

Bug archived. Request was from Debbugs Internal Request <owner@bugs.x2go.org> to internal_control@bugs.x2go.org. (Tue, 21 Oct 2014 05:24:02 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Sun Apr 21 04:42:28 2019; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.