X2Go Bug report logs - #549
Blinking popup window when using Ctrl+N in Intellij

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: Anton Mostovoy <anton@mostovoy.net>

Date: Tue, 15 Jul 2014 14:45:01 UTC

Severity: normal

Found in version 4.0.2.0

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#549; Package x2goclient. (Tue, 15 Jul 2014 14:45:01 GMT) Full text and rfc822 format available.

Acknowledgement sent to Anton Mostovoy <anton@mostovoy.net>:
New Bug report received and forwarded. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Tue, 15 Jul 2014 14:45:01 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.x2go.org (full text, mbox):

From: Anton Mostovoy <anton@mostovoy.net>
To: submit@bugs.x2go.org
Subject: Blinking popup window when using Ctrl+N in Intellij
Date: Tue, 15 Jul 2014 09:43:40 -0500
[Message part 1 (text/plain, inline)]
Package: x2goclient
Version: 4.0.2.0

on Centos 6.5 Server:

x2goserver-4.0.1.13-4.el6.x86_64
x2goagent-3.5.0.22-1.el6.x86_64
x2goserver-xsession-4.0.1.13-4.el6.x86_64

On Mac OS X 10.9.3, x2goclient 4.0.2.0 with XQuartz 2.7.6 (have not
tested Windows client)

When using Intellij 13.1.3 (latest) running with Java 1.7.0_45, I use
the "Navigate to File" or "Navigate to Class" feature by hitting
Ctrl+N or Ctrl+Shift+N or selecting from the menu.

Intermittently, that popup window that comes up, appears to be
"blinking" or getting repeatedly redrawn. At the same time it is not
taking any input. Hitting Escape or clicking outside of this popup,
closes it, and, if the commend is iinvoked again, the window may come
up properly or blink again.

Please let me know where i can find the logs and i will gladly provide them.


Thanks
[Message part 2 (text/html, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#549; Package x2goclient. (Tue, 15 Jul 2014 15:20:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Anton Mostovoy <anton@mostovoy.net>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Tue, 15 Jul 2014 15:20:02 GMT) Full text and rfc822 format available.

Message #10 received at 549@bugs.x2go.org (full text, mbox):

From: Anton Mostovoy <anton@mostovoy.net>
To: 549@bugs.x2go.org
Date: Tue, 15 Jul 2014 10:14:41 -0500
[Message part 1 (text/plain, inline)]
Here is the video demonstrating the correct and problematic behavior (in
order)
http://youtu.be/WL8UF2LFGXU
[Message part 2 (text/html, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#549; Package x2goclient. (Tue, 15 Jul 2014 16:10:01 GMT) Full text and rfc822 format available.

Acknowledgement sent to Anton Mostovoy <anton@mostovoy.net>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Tue, 15 Jul 2014 16:10:02 GMT) Full text and rfc822 format available.

Message #15 received at 549@bugs.x2go.org (full text, mbox):

From: Anton Mostovoy <anton@mostovoy.net>
To: 549@bugs.x2go.org
Date: Tue, 15 Jul 2014 11:06:35 -0500
[Message part 1 (text/plain, inline)]
Upon further testing, I found that the following:
1) problem happens when using NXFree with NoMachine client
2) problem happens  using plain X11-Forwarding when the app window is
dragged to a second monitor
3) problem does not happen when using windows X2GO client.

I guess this is an XQuartz bug then.  Any guidance on capturing logs to
submit to XQuartz project would be helpful.

Thanks in advance
[Message part 2 (text/html, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#549; Package x2goclient. (Tue, 15 Jul 2014 16:50:01 GMT) Full text and rfc822 format available.

Acknowledgement sent to Anton Mostovoy <anton@mostovoy.net>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Tue, 15 Jul 2014 16:50:01 GMT) Full text and rfc822 format available.

Message #20 received at 549@bugs.x2go.org (full text, mbox):

From: Anton Mostovoy <anton@mostovoy.net>
To: 549@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#549:
Date: Tue, 15 Jul 2014 11:46:51 -0500
[Message part 1 (text/plain, inline)]
opend https://xquartz.macosforge.org/trac/ticket/1705


On Tue, Jul 15, 2014 at 11:06 AM, Anton Mostovoy <anton@mostovoy.net> wrote:

> Upon further testing, I found that the following:
> 1) problem happens when using NXFree with NoMachine client
> 2) problem happens  using plain X11-Forwarding when the app window is
> dragged to a second monitor
> 3) problem does not happen when using windows X2GO client.
>
> I guess this is an XQuartz bug then.  Any guidance on capturing logs to
> submit to XQuartz project would be helpful.
>
> Thanks in advance
>
> _______________________________________________
> x2go-dev mailing list
> x2go-dev@lists.x2go.org
> http://lists.x2go.org/listinfo/x2go-dev
>
[Message part 2 (text/html, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Sat Dec 15 11:23:23 2018; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.