X2Go Bug report logs - #437
Session resume problems

version graph

Package: nxagent; Maintainer for nxagent is X2Go Developers <x2go-dev@lists.x2go.org>; Source for nxagent is src:nx-libs.

Reported by: Ondřej Pacovský <op@jikos.cz>

Date: Mon, 24 Feb 2014 12:40:01 UTC

Severity: normal

Tags: confirmed

Merged with 418, 513

Found in versions 3.5.0.22, 3.5.0.24-0x2go1+git20140508.472+jessie.main.1, 3.5.0.21

Full log


Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

Received: (at submit) by bugs.x2go.org; 24 Feb 2014 12:36:32 +0000
From charnger@gmail.com  Mon Feb 24 13:36:31 2014
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=0.0 required=5.0 tests=BAYES_40,HTML_MESSAGE,
	T_DKIM_INVALID autolearn=ham version=3.3.2
Received: from mail-wg0-f53.google.com (mail-wg0-f53.google.com [74.125.82.53])
	by ymir (Postfix) with ESMTPS id AB9465DB1C
	for <submit@bugs.x2go.org>; Mon, 24 Feb 2014 13:36:31 +0100 (CET)
Received: by mail-wg0-f53.google.com with SMTP id x12so4538746wgg.8
        for <submit@bugs.x2go.org>; Mon, 24 Feb 2014 04:36:31 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=gmail.com; s=20120113;
        h=mime-version:sender:date:message-id:subject:from:to:content-type;
        bh=ZRzXhclVmqvz8bfyfPczTmOs9/JtXs0KA1+Qak8dihc=;
        b=fFq5HGeWq+1ckpRO/IVpLB0UhiDOXSksq+iDDGdtLNO34CTooBnLBQuIHxuykqHjVP
         Ws8cpXxuzIrqgl6g+pQUlZy4DB4PH/ryzWHK3apL5jQttt8n8vM6GXF4Ji/rCkRTBKWv
         9ln+EGxDoRyeKl1o7N9MyojajE0nmMecl2DfInRZzi2deKUmQwQhWv2JFB4TVgVdjWMS
         VF7FtIYJGj8yGQJc2R0gyGTj5mSlPDIPcnCrljvicDafKN5/Xdoid1Tz5JE3WETfxLov
         MdxIigorUSKfUN/6Pvm8C7idh4STtAGEPza0ejIdumwsGso358Sn49hqCE7pQaVQNfHr
         LX4Q==
MIME-Version: 1.0
X-Received: by 10.194.189.4 with SMTP id ge4mr18538489wjc.92.1393245391376;
 Mon, 24 Feb 2014 04:36:31 -0800 (PST)
Sender: charnger@gmail.com
Received: by 10.227.244.19 with HTTP; Mon, 24 Feb 2014 04:36:31 -0800 (PST)
Date: Mon, 24 Feb 2014 13:36:31 +0100
X-Google-Sender-Auth: VHS2GiDmtqvavTR1hm07orR6_Sk
Message-ID: <CAEJhGVLChbBf-YBN1j9o_+yrMaHXhsk67wFd2_jie9=Q7F7mVw@mail.gmail.com>
Subject: Session resume problems
From: Ondřej Pacovský <op@jikos.cz>
To: submit@bugs.x2go.org
Content-Type: multipart/alternative; boundary=047d7bf0c0a0a3571104f3263873
[Message part 1 (text/plain, inline)]
Package: nxagent
Version: 3.5.0.22

I have been using x2go for many months now,

client (Debian amd64 4.0.1.1-1),
x2goserver  (Debian amd64 4.0.1.6-0)

.. is the current version, but it's been the same ever since.

I use it in the "single application" mode, starting only xfce4-terminal and
all the other windows are spawned from that terminal.

What happens is that very often (I would say 20-30% of the cases -- it's
not deterministic), I would resume a session, it is "resumed", but no
windows appear. Nothing helps, suspending and resuming does not work. The
only thing to do is to terminate the session and start anew. It's quite
annoying:)  I wonder if anyone has this issue or am I doing something wrong
/ non-standard? How can I debug this?

BTW, I use awesome wm now, but the same was happening to me on xfce, too

-- Ondrej
[Message part 2 (text/html, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Tue Jan 31 04:29:04 2023; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.