X2Go Bug report logs - #407
Sometimes mounts will remain, even after a close of the session

version graph

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Dick Kniep <dick@lindix.nl>

Date: Tue, 21 Jan 2014 16:05:02 UTC

Severity: normal

Tags: pending

Found in version 4.0.0.11-0~736~ubuntu12.04.1

Fixed in version 4.0.1.16

Done: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>

Bug is archived. No further changes may be made.

Full log


🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#407: Sometimes mounts will remain, even after a close of the session
Reply-To: Dick Kniep <dick@lindix.nl>, 407@bugs.x2go.org
Resent-From: Dick Kniep <dick@lindix.nl>
Resent-To: x2go-dev@lists.berlios.de
Resent-CC: X2Go Developers <x2go-dev@lists.berlios.de>
X-Loop: owner@bugs.x2go.org
Resent-Date: Tue, 21 Jan 2014 16:05:02 +0000
Resent-Message-ID: <handler.407.B.13903201732692@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: report 407
X-X2Go-PR-Package: x2goserver
X-X2Go-PR-Keywords: 
Received: via spool by submit@bugs.x2go.org id=B.13903201732692
          (code B); Tue, 21 Jan 2014 16:05:02 +0000
Received: (at submit) by bugs.x2go.org; 21 Jan 2014 16:02:53 +0000
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=-1.9 required=5.0 tests=BAYES_00,MIME_QP_LONG_LINE
	autolearn=ham version=3.3.2
X-Greylist: delayed 1217 seconds by postgrey-1.34 at ymir; Tue, 21 Jan 2014 17:02:52 CET
Received: from mail.lindix.nl (mail.lindix.nl [95.170.66.31])
	by ymir (Postfix) with ESMTP id A05975DB16
	for <submit@bugs.x2go.org>; Tue, 21 Jan 2014 17:02:52 +0100 (CET)
Received: from mail.int.lindix.nl (localhost [127.0.0.1])
	by mail.lindix.nl (Postfix) with ESMTP id B10B13FF6A
	for <submit@bugs.x2go.org>; Tue, 21 Jan 2014 16:42:35 +0100 (CET)
From: Dick Kniep <dick@lindix.nl>
To: submit@bugs.x2go.org <submit@bugs.x2go.org>
Date: Tue, 21 Jan 2014 16:42:35 +0100
Mime-Version: 1.0
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: quoted-printable
X-Priority: 3 (Normal)
X-Mailer: Zarafa 7.0.8-35178
Message-Id: <zarafa.52de956b.1f1a.650596cc7b426b6f@mail.int.lindix.nl>
package: x2goserver
version: 4.0.0.11-0~736~ubuntu12.04.1

Hi you nice people who maintain X2go.

Sometimes a session is not ended cleanly and most of the time this does not matter everything is cleaned up and a new session can be started. However once in a while, one or more of the sshfs mounts to the local system remain active. This means that any subsequent attempt to logon fails, because it tries to mount and the mount already exists.

Maybe the solution is as simple as adding remount to the mount statement. (I don't know if this breaks the initial mount....)

Cheers,
Dick Kniep

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Mon Jul 13 06:03:01 2020; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.