X2Go Bug report logs - #348
x2goserver 4.0.1.8: screws up keyboard for Mac users

version graph

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Anders Bruun Olsen <abo@dsl.dk>

Date: Tue, 26 Nov 2013 10:48:01 UTC

Severity: critical

Tags: pending

Merged with 481

Found in versions 4.0.1.15, 4.0.4.0, 4.0.1.8

Full log


🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#348: Bug 348
Reply-To: Peter Ploß <peter.ploss@fau.de>, 348@bugs.x2go.org
Resent-From: Peter Ploß <peter.ploss@fau.de>
Resent-To: x2go-dev@lists.berlios.de
Resent-CC: X2Go Developers <x2go-dev@lists.berlios.de>
X-Loop: owner@bugs.x2go.org
Resent-Date: Thu, 05 Dec 2013 00:03:01 +0000
Resent-Message-ID: <handler.348.B348.13862016796230@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: followup 348
X-X2Go-PR-Package: x2goserver
X-X2Go-PR-Keywords: pending
Received: via spool by 348-submit@bugs.x2go.org id=B348.13862016796230
          (code B ref 348); Thu, 05 Dec 2013 00:03:01 +0000
Received: (at 348) by bugs.x2go.org; 5 Dec 2013 00:01:19 +0000
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=-1.9 required=5.0 tests=BAYES_00,SPF_HELO_PASS,
	T_DKIM_INVALID,URIBL_BLOCKED autolearn=ham version=3.3.2
X-Greylist: delayed 542 seconds by postgrey-1.34 at ymir; Thu, 05 Dec 2013 01:01:18 CET
Received: from mx-rz-2.rrze.uni-erlangen.de (mx-rz-2.rrze.uni-erlangen.de [131.188.11.21])
	by ymir (Postfix) with ESMTPS id 8AD755DB1C
	for <348@bugs.x2go.org>; Thu,  5 Dec 2013 01:01:18 +0100 (CET)
Received: from boeck2.rrze.uni-erlangen.de (boeck2.rrze.uni-erlangen.de [131.188.11.32])
	by mx-rz-2.rrze.uni-erlangen.de (Postfix) with ESMTP id 3dZcL84P61zBnV1;
	Thu,  5 Dec 2013 00:52:16 +0100 (CET)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=fau.de; s=fau-2013;
	t=1386201136; bh=BE+dLmDFlLs3z0+B/jem7UIStewP22w2MnhhBXe9lrE=;
	h=From:Subject:Date:Cc:To:From;
	b=O96LLL7eP76AGpZd6o+inKy6VPeGsgB/kw4LhZ1YHQS9sEdAyakDlUWhYdcvrAfEO
	 dLdUuVmogQQcJW+cFfqlkCMS6+B3K46/vkys3ci148H0TF1c6PQk0PFC2UzH3LhfL1
	 +vJ8RdbK3WAlx4aAS3m3h92onU39hxFno9qpxd57hStvGrifdjgtJ/et64UComkNZN
	 DhK5Esk5gzlh66V4KCVbl4aqkX3xVj1UKVGd4gPQKW3LBrEd2oYCl+O3BmpjkHw+GL
	 AmW99y59+dDm75qebDBv7iyD58oiguHv51MQF6M84w/Ns5q/yno0IChhjfmUCoVUaO
	 QrPWGioBw8Mhw==
X-Virus-Scanned: amavisd-new at boeck2.rrze.uni-erlangen.de (RRZE)
Received: from mx-rz-2.rrze.uni-erlangen.de ([131.188.11.21])
	by boeck2.rrze.uni-erlangen.de (boeck2.rrze.uni-erlangen.de [131.188.11.32]) (amavisd-new, port 10026)
	with LMTP id zlm3zBhR6xrv; Thu,  5 Dec 2013 00:52:15 +0100 (CET)
Received: from mx-rz-smart.rrze.uni-erlangen.de (mx-rz-smart.rrze.uni-erlangen.de [IPv6:2001:638:a000:1025::1e])
	by mx-rz-2.rrze.uni-erlangen.de (Postfix) with ESMTP id 3dZcL72fdXzBnTg;
	Thu,  5 Dec 2013 00:52:15 +0100 (CET)
X-RRZE-Submit-IP: 64.134.220.154
Received: from [192.168.9.222] (ip-64-134-220-154.public.wayport.net [64.134.220.154])
	(using TLSv1 with cipher AES128-SHA (128/128 bits))
	(No client certificate requested)
	(Authenticated sender: U2FsdGVkX195VezLY9ozTlKOdl4RWtrDthZsBZSA/58=)
	by smtp-auth.uni-erlangen.de (Postfix) with ESMTPSA id 3dZcL56WDWzHdfF;
	Thu,  5 Dec 2013 00:52:13 +0100 (CET)
From: Peter Ploß <peter.ploss@fau.de>
Content-Type: text/plain; charset=windows-1252
Content-Transfer-Encoding: quoted-printable
Date: Wed, 4 Dec 2013 15:52:08 -0800
Message-Id: <80CF72E0-D4F2-42D7-86E6-80FEC0C5BD3E@fau.de>
Cc: x2go-devs@lists.berlios.de
To: 348@bugs.x2go.org
Mime-Version: 1.0 (Mac OS X Mail 7.0 \(1822\))
X-Mailer: Apple Mail (2.1822)
Hello everybody,

I am running the x2goserver (x2goserver/precise 4.0.1.9-0~751~ubuntu12.04.1) on a Ubuntu 12.04 LTS server and try to connect from a Mac OS X Mavericks with x2goclient 4.0.1.1 and am facing the keyboard issues since I updated the server from 4.0.1.8~741.

Since then I tried many things to come back to a functioning keyboard layout, like changing the keyboard layout options on the x2go client preferences, changing settings of XQuartz 2.7.5 — all without success.

Now I even tried manually applying the patch [1], though that also didn’t help. Since it seems that this is the only change between these two versions linked to that issue, I am unsure how to proceed. 

Hopefully we are able to figure out a solution, since this is unfortunately a showstopper for Mac users.

Kind regards and thank you everybody for your help!
Peter

[1] http://code.x2go.org/gitweb?p=x2goserver.git;a=commitdiff;h=e6f2ea27d78d8db29bf7119979cc3913e42b2e6e

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Wed Sep 23 07:32:51 2020; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.