X2Go Bug report logs - #323
x2go server refuses client with 'Error: Wrong version or invalid session authentication cookie.'

version graph

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: harry mangalam <harry.mangalam@uci.edu>

Date: Mon, 14 Oct 2013 04:48:01 UTC

Severity: normal

Tags: moreinfo

Found in version 4.0.1

Full log


🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#323: 323 bug
Reply-To: Eric Forgeot <eforgeot@gmail.com>, 323@bugs.x2go.org
Resent-From: Eric Forgeot <eforgeot@gmail.com>
Resent-To: x2go-dev@lists.berlios.de
Resent-CC: X2Go Developers <x2go-dev@lists.berlios.de>
X-Loop: owner@bugs.x2go.org
Resent-Date: Fri, 01 Nov 2013 12:48:02 +0000
Resent-Message-ID: <handler.323.B323.138330956015578@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: followup 323
X-X2Go-PR-Package: x2goserver
X-X2Go-PR-Keywords: moreinfo
Received: via spool by 323-submit@bugs.x2go.org id=B323.138330956015578
          (code B ref 323); Fri, 01 Nov 2013 12:48:02 +0000
Received: (at 323) by bugs.x2go.org; 1 Nov 2013 12:39:20 +0000
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=-2.6 required=5.0 tests=BAYES_00,FREEMAIL_FROM,
	RCVD_IN_DNSWL_LOW,T_DKIM_INVALID,URIBL_BLOCKED autolearn=ham version=3.3.2
Received: from mail-wg0-f52.google.com (mail-wg0-f52.google.com [74.125.82.52])
	by ymir (Postfix) with ESMTPS id 42E215DB05
	for <323@bugs.x2go.org>; Fri,  1 Nov 2013 13:39:19 +0100 (CET)
Received: by mail-wg0-f52.google.com with SMTP id k14so3997247wgh.19
        for <323@bugs.x2go.org>; Fri, 01 Nov 2013 05:39:19 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=gmail.com; s=20120113;
        h=message-id:date:from:user-agent:mime-version:to:subject
         :content-type:content-transfer-encoding;
        bh=NLcH7B3th4vNx2vlU261iaZ3PqJS1KfiFSgExu3KsYI=;
        b=VDMoxscdGbT/m00fyF4ze/n050gj5iYs7j3qzu+EgLvzqekox5mTu+b6vCv3ZFdpHP
         K1XCaSi9R67mjYjfGu6SfKeZHtUBmTpQnRNegA9ENPFb09A7T6kskfdXTOqDqYYSCnfA
         LQqr3I2BaQxLRu3mCv0R+pRO7w+3p47OK0WNTUivk7nrGkuvYvkRca+YgQdfbPPOYE0Y
         QQrvU9ulYWp2hEoX93SKFD58IsjUGafiM11wV1omZZv+dB+cXrpwxN55ufy4cz/KoHit
         LGoYf0iatSBrsNaNzN4kj+hq8Btrs9VZE604XhF5iyQBOAzXEYEmzSZKjbmJEpjWYuM3
         q/OQ==
X-Received: by 10.180.72.135 with SMTP id d7mr528426wiv.65.1383309558948;
        Fri, 01 Nov 2013 05:39:18 -0700 (PDT)
Received: from [192.168.0.4] (dispo-82-250-23-135.adsl.proxad.net. [82.250.23.135])
        by mx.google.com with ESMTPSA id fr4sm6075160wib.0.2013.11.01.05.39.18
        for <323@bugs.x2go.org>
        (version=TLSv1 cipher=ECDHE-RSA-RC4-SHA bits=128/128);
        Fri, 01 Nov 2013 05:39:18 -0700 (PDT)
Message-ID: <5273A0F4.3010606@gmail.com>
Date: Fri, 01 Nov 2013 13:39:16 +0100
From: Eric Forgeot <eforgeot@gmail.com>
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.0
MIME-Version: 1.0
To: 323@bugs.x2go.org
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
Hello,

I have this problem as well.

version 4.0.1.1 for the client
version 4.0.1.6 for the server

on linuxmint 15. All packages coming from the ppa:x2go/stable

I tried this:

1/
sudo rm -f /var/lib/x2go/x2go_sessions
sudo x2godbadmin --createdb

2/
creating a new ssh user on the server, and trying to connect with this new one. x2go detected the /home/my_new_user folder was missing,
and when I created it, x2go refused to connect any longer.

3/
editing / renaming ~/.ssh/known_hosts from the client side
(according to http://john.wesorick.com/2011/11/issues-installing-x2go.html I also commented the "HostKey /etc/ssh/ssh_host_ecdsa_key" in my sshd_config on the server)

none of them worked.


I also renamed the ~/.x2go/ ~/.x2goclient/ folders in my home

I can barely copy the output from the error window ( it hides itself too quickly and can't find a way to get it from elsewhere) :

Starting session at 'Fri Nov 1 13:28:55 2013'.

Info: Connecting to remote host 'localhost:31004'.

Info: Connection to remote proxy 'localhost:31004' established.

Error: The remote NX proxy closed the connection.

Error: Failure negotiating the session in stage '7'.

Error: Wrong version or invalid session authentication cookie.

Session: Terminating session at 'Fri Nov 1 13:28:56 2013'.

Session: Session terminated at 'Fri Nov 1 13:28:56 2013'.


(I don't understand why it tries to connect to localhost)

My log in ~/.x2go/S-mylogin-50-1383308923_stDLXDE_dp24/sessions says:

Loop: PANIC! The remote NX proxy closed the connection.
Loop: PANIC! Failure negotiating the session in stage '7'.
Loop: PANIC! Wrong version or invalid session authentication cookie.


x2go worked perfectly before, I can't trace when it stopped working but it's probably after some package updates.

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Tue Sep 17 08:31:11 2019; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.