X2Go Bug report logs - #291
eclipse: Eclipse crash when i try to open a file

Package: nxagent; Maintainer for nxagent is X2Go Developers <x2go-dev@lists.x2go.org>; Source for nxagent is src:nx-libs.

Reported by: Dev <dev@ange7.com>

Date: Wed, 28 Aug 2013 19:48:02 UTC

Severity: important

Full log


đź”— View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#291: libcairo2-dev
Reply-To: Dev <dev@ange7.com>, 291@bugs.x2go.org
Resent-From: Dev <dev@ange7.com>
Resent-To: x2go-dev@lists.berlios.de
Resent-CC: owner@bugs.x2go.org
X-Loop: owner@bugs.x2go.org
Resent-Date: Wed, 04 Sep 2013 20:33:01 +0000
Resent-Message-ID: <handler.291.B291.137832635217079@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: followup 291
X-X2Go-PR-Package: eclipse
X-X2Go-PR-Keywords: 
Received: via spool by 291-submit@bugs.x2go.org id=B291.137832635217079
          (code B ref 291); Wed, 04 Sep 2013 20:33:01 +0000
Received: (at 291) by bugs.x2go.org; 4 Sep 2013 20:25:52 +0000
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=-1.9 required=5.0 tests=BAYES_00,
	RCVD_IN_DNSWL_BLOCKED,SPF_HELO_PASS autolearn=ham version=3.3.2
Received: from mail.ange7.com (padawan.plusdinfo.com [88.190.238.233])
	by ymir (Postfix) with ESMTP id 718DB5DB15
	for <291@bugs.x2go.org>; Wed,  4 Sep 2013 22:25:51 +0200 (CEST)
Received: from webmail.ange7.com (localhost [127.0.0.1])
	by mail.ange7.com (Postfix) with ESMTPA id 2F4C12B902
	for <291@bugs.x2go.org>; Wed,  4 Sep 2013 22:25:50 +0200 (CEST)
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8;
 format=flowed
Content-Transfer-Encoding: 8bit
Date: Wed, 04 Sep 2013 22:25:50 +0200
From: Dev <dev@ange7.com>
To: 291@bugs.x2go.org
Message-ID: <801e9985134256bf2a594ec719c09b05@webmail.ange7.com>
X-Sender: dev@ange7.com
User-Agent: Roundcube Webmail/0.9.2
Ok i find how fix this problem and it's not a problem with eclipse.

If someone have the same problem you can fix :

In debian Wheezy, «libcairo2-dev» package is installed.

But by default you have version 1.12.2. but since version 1.12.10 we can 
see in their bug fix : «Restore support for older versions of XRender. A 
couple of typos and a few forgotten chunks prevented the xlib compositor 
from running correctly with XRender < 0.10. Note that there are still a 
few regressions remaining.»

So you just need upgrade your «libcairo2-dev» package in debian jessie → 
Eclipse Works

i have ask to debian that we need backport.

see : http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=721181

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Sun Sep 20 08:14:56 2020; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.