X2Go Bug report logs - #233
X2goserver 4.0.1.0 Segmenation fault

Package: nx-libs; Maintainer for nx-libs is X2Go Developers <x2go-dev@lists.x2go.org>;

Reported by: Ross Barnes <ross.p.barnes@gmail.com>

Date: Mon, 10 Jun 2013 18:48:01 UTC

Severity: normal

Tags: moreinfo

Done: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.berlios.de, owner@bugs.x2go.org:
Bug#233; Package x2goserver-4.0.1.0. (Mon, 10 Jun 2013 18:48:01 GMT) Full text and rfc822 format available.

Acknowledgement sent to Ross Barnes <ross.p.barnes@gmail.com>:
New Bug report received and forwarded. Copy sent to owner@bugs.x2go.org. (Mon, 10 Jun 2013 18:48:01 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.x2go.org (full text, mbox):

From: Ross Barnes <ross.p.barnes@gmail.com>
To: submit@bugs.x2go.org
Subject: X2goserver 4.0.1.0 Segmenation fault
Date: Mon, 10 Jun 2013 13:36:27 -0500
[Message part 1 (text/plain, inline)]
Package: x2goserver-4.0.1.0

Hello, I use X2go for remote access into my virtual lab server to run GNS3.
This is a python application that allows a user to build networked router
labs.

I have been using X2go 3.1.1.9-0 on Debian Squeeze with no problems. I
updated my server this weekend to Debian Wheezy. The repository updated
X2go to 4.0.1.0-0. I am now having the below issues when I try to run my
application. I also experience this with the baikal 4.0.0.3-0 version.

This occurs with the 3.99.2.1 windows client, the 3.99.3.0-0 linux client,
and the windows 4.0.0.3 windows client. There is no issue with the
application directly on the server. I can launch it on a monitor.

on command line, I issue the following...

user@vlab:~$ /opt/GNS3/gns3
Segementation fault
user@vlab:~$

/var/log/messages file reveals...

Jun 10 13:07:39 vlab kernel: [54264.138060] python[20110]: segfault at 0 ip
00007fe724db5dd0 sp 00007fff49a860b8 error 4 in
libNX_X11.so.6.2[7fe724d50000+f3000]
[Message part 2 (text/html, inline)]

Information forwarded to x2go-dev@lists.berlios.de, owner@bugs.x2go.org:
Bug#233; Package x2goserver-4.0.1.0. (Fri, 14 Jun 2013 10:33:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mike Gabriel <mike.gabriel@das-netzwerkteam.de>:
Extra info received and forwarded to list. Copy sent to owner@bugs.x2go.org. (Fri, 14 Jun 2013 10:33:02 GMT) Full text and rfc822 format available.

Message #10 received at 233@bugs.x2go.org (full text, mbox):

From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
To: Ross Barnes <ross.p.barnes@gmail.com>, 233@bugs.x2go.org
Cc: control@bugs.x2go.org
Subject: Re: Bug#233: X2goserver 4.0.1.0 Segmenation fault
Date: Fri, 14 Jun 2013 12:30:09 +0200
[Message part 1 (text/plain, inline)]
reassign #233 nx-libs
thanks

Hi Ross,

On Mo 10 Jun 2013 20:36:27 CEST Ross Barnes wrote:

> Package: x2goserver-4.0.1.0
>
> Hello, I use X2go for remote access into my virtual lab server to run GNS3.
> This is a python application that allows a user to build networked router
> labs.
>
> I have been using X2go 3.1.1.9-0 on Debian Squeeze with no problems. I
> updated my server this weekend to Debian Wheezy. The repository updated
> X2go to 4.0.1.0-0. I am now having the below issues when I try to run my
> application. I also experience this with the baikal 4.0.0.3-0 version.
>
> This occurs with the 3.99.2.1 windows client, the 3.99.3.0-0 linux client,
> and the windows 4.0.0.3 windows client. There is no issue with the
> application directly on the server. I can launch it on a monitor.
>
> on command line, I issue the following...
>
> user@vlab:~$ /opt/GNS3/gns3
> Segementation fault
> user@vlab:~$
>
> /var/log/messages file reveals...

What is the version of nx-libs (x2goagent, nxagent) that you are using  
on the server?

Can you play with the options in /etc/x2go/x2goagent.options? Is the  
GLX extension enabled/disabled? Is XFIXES enabled/disabled?

The issue is very likely to by an nx-libs issue, so reassigning this bug.

Mike


-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb
[Message part 2 (application/pgp-signature, inline)]

Bug reassigned from package 'x2goserver-4.0.1.0' to 'nx-libs'. Request was from Mike Gabriel <mike.gabriel@das-netzwerkteam.de> to control@bugs.x2go.org. (Fri, 14 Jun 2013 10:33:03 GMT) Full text and rfc822 format available.

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#233; Package nx-libs. (Mon, 30 Jun 2014 13:15:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mike Gabriel <mike.gabriel@das-netzwerkteam.de>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Mon, 30 Jun 2014 13:15:02 GMT) Full text and rfc822 format available.

Message #17 received at 233@bugs.x2go.org (full text, mbox):

From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
To: Ross Barnes <ross.p.barnes@gmail.com>
Cc: 233@bugs.x2go.org
Subject: X2Go (agent) crashes related to Xinerama?
Date: Mon, 30 Jun 2014 13:14:26 +0000
[Message part 1 (text/plain, inline)]
Control: tag -1 moreinfo

Hi Ross,

a year ago you reported an issue you have with X2Go [1] to the X2Go BTS.

I hope this was not a show stopper for you and you still use X2Go for  
other tasks...

May I ask:

Does the problem still exist?
Does the observed issue occur when Xinerama support in X2Go Client is enabled?
Can you provide any more debugging information?

Thanks,
Mike

[1] http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=233
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb
[Message part 2 (application/pgp-signature, inline)]

Added tag(s) moreinfo. Request was from Mike Gabriel <mike.gabriel@das-netzwerkteam.de> to 233-submit@bugs.x2go.org. (Mon, 30 Jun 2014 13:15:02 GMT) Full text and rfc822 format available.

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#233; Package nx-libs. (Wed, 02 Jul 2014 19:15:01 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mike Gabriel <mike.gabriel@das-netzwerkteam.de>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Wed, 02 Jul 2014 19:15:02 GMT) Full text and rfc822 format available.

Message #24 received at 233@bugs.x2go.org (full text, mbox):

From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
To: Ross Barnes <ross.p.barnes@gmail.com>
Cc: 233@bugs.x2go.org
Subject: Re: X2Go (agent) crashes related to Xinerama?
Date: Wed, 02 Jul 2014 19:10:00 +0000
[Message part 1 (text/plain, inline)]
Control: close -1

Hi Ross,

On  Mi 02 Jul 2014 18:51:59 CEST, Ross Barnes wrote:

> On Mon, Jun 30, 2014 at 8:14 AM, Mike Gabriel <
> mike.gabriel@das-netzwerkteam.de> wrote:
>
>> Control: tag -1 moreinfo
>>
>> Hi Ross,
>>
>> a year ago you reported an issue you have with X2Go [1] to the X2Go BTS.
>>
>> I hope this was not a show stopper for you and you still use X2Go for
>> other tasks...
>>
>> May I ask:
>>
>> Does the problem still exist?
>> Does the observed issue occur when Xinerama support in X2Go Client is
>> enabled?
>> Can you provide any more debugging information?
>>
>> Thanks,
>> Mike
>>
>> [1] http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=233

> I do not know if the problem still exists. I currently have x2go installed
> on Arch linux with no problems.

Ok, then... I will close this bug as we may have found the reason for  
such crashes on some Linux distribution (cf. #410).

If you this issue reoccurs, feel free to reopen bug #233 or report as  
a new issue.

Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb
[Message part 2 (application/pgp-signature, inline)]

Marked Bug as done Request was from Mike Gabriel <mike.gabriel@das-netzwerkteam.de> to 233-submit@bugs.x2go.org. (Wed, 02 Jul 2014 19:15:02 GMT) Full text and rfc822 format available.

Notification sent to Ross Barnes <ross.p.barnes@gmail.com>:
Bug acknowledged by developer. (Wed, 02 Jul 2014 19:15:02 GMT) Full text and rfc822 format available.

Bug archived. Request was from Debbugs Internal Request <owner@bugs.x2go.org> to internal_control@bugs.x2go.org. (Thu, 31 Jul 2014 05:24:01 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Fri Apr 19 04:32:03 2019; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.