X2Go Bug report logs - #1533
Mac client: connection timeout 30 seconds after session start

version graph

Package: unknown; Maintainer for unknown is (unknown);

Reported by: Ricky Charlet <ricky.charlet@icloud.com>

Date: Fri, 19 Mar 2021 16:50:02 UTC

Severity: normal

Found in version 4.1.2.2

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, owner@bugs.x2go.org:
Bug#1533; Package unknown. (Fri, 19 Mar 2021 16:50:02 GMT) (full text, mbox, link).


Acknowledgement sent to Ricky Charlet <ricky.charlet@icloud.com>:
New Bug report received and forwarded. Copy sent to owner@bugs.x2go.org. (Fri, 19 Mar 2021 16:50:02 GMT) (full text, mbox, link).


Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

From: Ricky Charlet <ricky.charlet@icloud.com>
To: submit@bugs.x2go.org
Cc: Ricky Charlet <ricky.charlet@icloud.com>
Subject: Mac client: connection timeout 30 seconds after session start
Date: Fri, 19 Mar 2021 09:47:04 -0700
[Message part 1 (text/plain, inline)]
Package: unknown
Version: 4.1.2.2


Howdy,

	When I connect from Mac client to ubuntu server, I get a “connection timeout” 30 seconds after “connection start.”  Other people can connect to my server.

Error message is:
Loop: WARNING! Overriding auxiliary X11 port with new value '1'.
Warning: Overriding auxiliary X11 port with new value '1'.
Info: Connecting to remote host 'localhost:36652'.
Info: Connected to remote proxy on FD#11.
Info: Connection with remote proxy completed.
Loop: WARNING! Unrecognized session type 'unix-kde-depth_32'. Assuming agent session.
Warning: Unrecognized session type 'unix-kde-depth_32'. Assuming agent session.
Info: Using ADSL link parameters 1408/24/1/0.
Info: Using cache parameters 4/4096KB/8192KB/8192KB.
Info: Using pack method '16m-jpeg-9' with session 'unix-kde-depth_32'.
Info: Using ZLIB data compression 1/1/32.
Info: Using ZLIB stream compression 4/4.
Info: No suitable cache file found.
Info: Forwarding X11 connections to display '/private/tmp/com.apple.launchd.E12k8P0IX6/org.xquartz:0'.
Info: Forwarding auxiliary X11 connections to display '/private/tmp/com.apple.launchd.E12k8P0IX6/org.xquartz:0'.
Session: Session started at 'Fri Mar 19 09:38:16 2021'.
Connection timeout, abortingSession: Terminating session at 'Fri Mar 19 09:38:46 2021'.
Info: Waiting the cleanup timeout to complete.
Session: Session terminated at 'Fri Mar 19 09:38:47 2021'.



On the server, in /var/log/messages, I get what appears to be a success report:
Mar 19 09:38:16 hpnsw4371 /usr/bin/x2gostartagent: successfully started X2Go Agent session with ID charletr-50-1616171893_stDMATE_dp32


I have a tcpdump (is in an ssh tunnel, to a little vague) which shows client sending dup packet not quite, but almost 30 seconds into session attempt.
116	33.763841	15.116.49.166	16.99.147.244	SSHv2	108	Server: [TCP Spurious Retransmission] , Encrypted packet (len=64)
117	33.763941	16.99.147.244	15.116.49.166	TCP	56	[TCP Dup ACK 114#1] 64138 → 22 [ACK] Seq=3239 Ack=5027 Win=262144 Len=0 SLE=4963 SRE=5027


Client = MacOS 10.15.7 (Catalina…and due to corp policy, I cannot upgrade); x2go 4.1.2.2 with qt 4.8.7 with xquartz 2.7.11 with xorg 1.18.4

Server : x2goversion
: 1.0.2.4
: 0.0.1.6
: 4.1.0.3
: 4.1.0.3
: 4.1.0.3
: 4.1.0.3
: 4.1.0.3
: 3.5.99.22
: 4.1.0.3


[Message part 2 (text/html, inline)]

Information forwarded to x2go-dev@lists.x2go.org, owner@bugs.x2go.org:
Bug#1533; Package unknown. (Thu, 01 Apr 2021 11:50:02 GMT) (full text, mbox, link).


Acknowledgement sent to Ulrich Sibiller <uli42@gmx.de>:
Extra info received and forwarded to list. Copy sent to owner@bugs.x2go.org. (Thu, 01 Apr 2021 11:50:02 GMT) (full text, mbox, link).


Message #10 received at 1533@bugs.x2go.org (full text, mbox, reply):

From: Ulrich Sibiller <uli42@gmx.de>
To: Ricky Charlet <ricky.charlet@icloud.com>, 1533@bugs.x2go.org
Cc: submit@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#1533: Mac client: connection timeout 30 seconds after session start
Date: Thu, 1 Apr 2021 13:44:47 +0200
Try to upgrade nxagent on the server to 3.5.99.26 and see it this
helps. See https://github.com/ArcticaProject/nx-libs/blob/3.6.x/README.md
for instructions where to find a current binary package.

Uli

On Fri, Mar 19, 2021 at 5:50 PM Ricky Charlet <ricky.charlet@icloud.com> wrote:
>
> Package: unknown
> Version: 4.1.2.2
>
>
> Howdy,
>
> When I connect from Mac client to ubuntu server, I get a “connection timeout” 30 seconds after “connection start.”  Other people can connect to my server.
>
> Error message is:
> Loop: WARNING! Overriding auxiliary X11 port with new value '1'.
> Warning: Overriding auxiliary X11 port with new value '1'.
> Info: Connecting to remote host 'localhost:36652'.
> Info: Connected to remote proxy on FD#11.
> Info: Connection with remote proxy completed.
> Loop: WARNING! Unrecognized session type 'unix-kde-depth_32'. Assuming agent session.
> Warning: Unrecognized session type 'unix-kde-depth_32'. Assuming agent session.
> Info: Using ADSL link parameters 1408/24/1/0.
> Info: Using cache parameters 4/4096KB/8192KB/8192KB.
> Info: Using pack method '16m-jpeg-9' with session 'unix-kde-depth_32'.
> Info: Using ZLIB data compression 1/1/32.
> Info: Using ZLIB stream compression 4/4.
> Info: No suitable cache file found.
> Info: Forwarding X11 connections to display '/private/tmp/com.apple.launchd.E12k8P0IX6/org.xquartz:0'.
> Info: Forwarding auxiliary X11 connections to display '/private/tmp/com.apple.launchd.E12k8P0IX6/org.xquartz:0'.
> Session: Session started at 'Fri Mar 19 09:38:16 2021'.
> Connection timeout, abortingSession: Terminating session at 'Fri Mar 19 09:38:46 2021'.
> Info: Waiting the cleanup timeout to complete.
> Session: Session terminated at 'Fri Mar 19 09:38:47 2021'.
>
>
>
> On the server, in /var/log/messages, I get what appears to be a success report:
> Mar 19 09:38:16 hpnsw4371 /usr/bin/x2gostartagent: successfully started X2Go Agent session with ID charletr-50-1616171893_stDMATE_dp32
>
>
> I have a tcpdump (is in an ssh tunnel, to a little vague) which shows client sending dup packet not quite, but almost 30 seconds into session attempt.
> 116 33.763841 15.116.49.166 16.99.147.244 SSHv2 108 Server: [TCP Spurious Retransmission] , Encrypted packet (len=64)
> 117 33.763941 16.99.147.244 15.116.49.166 TCP 56 [TCP Dup ACK 114#1] 64138 → 22 [ACK] Seq=3239 Ack=5027 Win=262144 Len=0 SLE=4963 SRE=5027
>
>
> Client = MacOS 10.15.7 (Catalina…and due to corp policy, I cannot upgrade); x2go 4.1.2.2 with qt 4.8.7 with xquartz 2.7.11 with xorg 1.18.4
>
> Server : x2goversion
> : 1.0.2.4
> : 0.0.1.6
> : 4.1.0.3
> : 4.1.0.3
> : 4.1.0.3
> : 4.1.0.3
> : 4.1.0.3
> : 3.5.99.22
> : 4.1.0.3
>
>
> _______________________________________________
> x2go-dev mailing list
> x2go-dev@lists.x2go.org
> https://lists.x2go.org/listinfo/x2go-dev


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Sun Oct 24 09:57:09 2021; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.