X2Go Bug report logs - #1460
Windows client crashes if Jumphost runs NetBSD 6 (probably race)

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: Edgar Fuß <ef@math.uni-bonn.de>

Date: Sun, 19 Apr 2020 18:25:01 UTC

Severity: normal

Found in version 4.1.2.2

Full log


🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#1460: libssh versions
Reply-To: Edgar Fuß <ef@math.uni-bonn.de>, 1460@bugs.x2go.org
Resent-From: Edgar Fuß <ef@math.uni-bonn.de>
Resent-To: x2go-dev@lists.x2go.org
Resent-CC: X2Go Developers <x2go-dev@lists.x2go.org>
X-Loop: owner@bugs.x2go.org
Resent-Date: Tue, 26 May 2020 09:35:02 +0000
Resent-Message-ID: <handler.1460.B1460.15904855822230@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: followup 1460
X-X2Go-PR-Package: x2goclient
X-X2Go-PR-Keywords: 
References: <handler.1460.B.158732059822516.ack@bugs.x2go.org> <20200419182314.GT12762@trav.math.uni-bonn.de> <20200504154819.GC12762@trav.math.uni-bonn.de> <20200525170757.GV12762@trav.math.uni-bonn.de> <CANVnVY+c7xuJejXrALP+eYffW=iL1224eyj=Kd4FsWqD=+5rTg@mail.gmail.com> <20200419182314.GT12762@trav.math.uni-bonn.de>
Received: via spool by 1460-submit@bugs.x2go.org id=B1460.15904855822230
          (code B ref 1460); Tue, 26 May 2020 09:35:02 +0000
Received: (at 1460) by bugs.x2go.org; 26 May 2020 09:33:02 +0000
X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=0.0 required=3.0 tests=BAYES_20,SPF_HELO_NONE
	autolearn=ham autolearn_force=no version=3.4.2
Received: from elbe.math.uni-bonn.de (elbe.math.uni-bonn.de [IPv6:2a00:5ba0:20:67::104])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id 2CF0B5DAF8
	for <1460@bugs.x2go.org>; Tue, 26 May 2020 11:32:59 +0200 (CEST)
Received: from trav.math.uni-bonn.de (p54932c0d.dip0.t-ipconnect.de [84.147.44.13])
	by elbe.math.uni-bonn.de (Postfix) with ESMTPSA id 80736C878A
	for <1460@bugs.x2go.org>; Tue, 26 May 2020 11:32:58 +0200 (CEST)
	(envelope-from ef@math.uni-bonn.de)
Date: Tue, 26 May 2020 11:32:57 +0200
From: Edgar Fuß <ef@math.uni-bonn.de>
To: 1460@bugs.x2go.org
Message-ID: <20200526093256.GB12762@trav.math.uni-bonn.de>
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
In-Reply-To: <CANVnVY+c7xuJejXrALP+eYffW=iL1224eyj=Kd4FsWqD=+5rTg@mail.gmail.com>
User-Agent: Mutt/1.11.4 (2019-03-13)
> I believe the libssh 0.9.3 being the culprit.
[...]
> So from my POV it would help if you could try using an older version
> of x2goclient (with an older libssh) to see if it works with that.
OK, I tried this. X2Go switched (at least for the MS-Win build) from 0.7.4(!) to 0.9.3 on 2020-02-06, and indeed, the build from 2020-01-29 (the last one before the switch) works for me!

Could someone build x2goclient with libssh 0.9.4 so I could test that?

> PS: I suspect this happens when the other side has a quite old openssh
> running, in my case it's OpenSSH 5.8, for you it's 5.9... So If you
> can upgrade the ssh server this might also solve the problem
As stated in the original bug report: No, unfortunately, it's not the OpenSSH version that matters (I went into some lengths updating that, but it didn't help), but the base system version. I cannot easily update the login servers to NetBSD 8.

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Thu Feb 2 20:50:01 2023; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.