X2Go Bug report logs - #1246
Can't start X Server, please check your installation

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: LANNES Pierre-Yves <py.lannes@gmail.com>

Date: Sun, 21 Jan 2018 22:25:01 UTC

Severity: normal

Found in version 4.1.0.0

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1246; Package x2goclient. (Sun, 21 Jan 2018 22:25:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to LANNES Pierre-Yves <py.lannes@gmail.com>:
New Bug report received and forwarded. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Sun, 21 Jan 2018 22:25:02 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.x2go.org (full text, mbox):

From: LANNES Pierre-Yves <py.lannes@gmail.com>
To: submit@bugs.x2go.org
Subject: Can't start X Server, please check your installation
Date: Sun, 21 Jan 2018 23:20:28 +0100
Package: x2goclient
Version: 4.1.0.0

Platform: Windows 7

This message appears when I'm trying to connect to my server, and kills
x2go:
"Can't start X Server, please check your installation"

Never had this issue before, everything was working fine.

Went to the bugs site and only found bug #503.

I uninstalled X2goclient and manually removed the registry leftovers (by
the way, a "clean" uninstall should ALWAYS be available)

Re-downloaded the installer, fresh install, problem still there.

I saw the #109 bug, and checked: useintx is true


---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
https://www.avast.com/antivirus


Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1246; Package x2goclient. (Wed, 24 Jan 2018 15:30:01 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mihai Moldovan <ionic@ionic.de>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Wed, 24 Jan 2018 15:30:02 GMT) Full text and rfc822 format available.

Message #10 received at 1246@bugs.x2go.org (full text, mbox):

From: Mihai Moldovan <ionic@ionic.de>
To: LANNES Pierre-Yves <py.lannes@gmail.com>, 1246@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#1246: Can't start X Server, please check your installation
Date: Wed, 24 Jan 2018 16:25:41 +0100
[Message part 1 (text/plain, inline)]
* On 01/21/2018 11:20 PM, LANNES Pierre-Yves wrote:
> Package: x2goclient
> Version: 4.1.0.0
> 
> Platform: Windows 7
> 
> This message appears when I'm trying to connect to my server, and kills
> x2go:
> "Can't start X Server, please check your installation"
> 
> Never had this issue before, everything was working fine.
> 
> Went to the bugs site and only found bug #503.
> 
> I uninstalled X2goclient and manually removed the registry leftovers (by
> the way, a "clean" uninstall should ALWAYS be available)

Might be useful feature for the NSIS package, if that's possible, agree'd, but
not for this report.


> Re-downloaded the installer, fresh install, problem still there.
> 
> I saw the #109 bug, and checked: useintx is true

Might also be caused by something in your user home directory.

What happens if you try to connect in a new user context?



Mihai

[signature.asc (application/pgp-signature, attachment)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1246; Package x2goclient. (Wed, 24 Jan 2018 19:25:01 GMT) Full text and rfc822 format available.

Acknowledgement sent to LANNES Pierre-Yves <py.lannes@gmail.com>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Wed, 24 Jan 2018 19:25:02 GMT) Full text and rfc822 format available.

Message #15 received at 1246@bugs.x2go.org (full text, mbox):

From: LANNES Pierre-Yves <py.lannes@gmail.com>
To: Mihai Moldovan <ionic@ionic.de>, 1246@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#1246: Can't start X Server, please check your installation
Date: Wed, 24 Jan 2018 20:19:54 +0100
Le 24/01/2018 à 16:25, Mihai Moldovan a écrit :
> * On 01/21/2018 11:20 PM, LANNES Pierre-Yves wrote:
>> Package: x2goclient
>> Version: 4.1.0.0
>>
>> Platform: Windows 7
>>
>> This message appears when I'm trying to connect to my server, and kills
>> x2go:
>> "Can't start X Server, please check your installation"
>>
>> Never had this issue before, everything was working fine.
>>
>> Went to the bugs site and only found bug #503.
>>
>> I uninstalled X2goclient and manually removed the registry leftovers (by
>> the way, a "clean" uninstall should ALWAYS be available)
> Might be useful feature for the NSIS package, if that's possible, agree'd, but
> not for this report.
>
>
>> Re-downloaded the installer, fresh install, problem still there.
>>
>> I saw the #109 bug, and checked: useintx is true
> Might also be caused by something in your user home directory.
>
> What happens if you try to connect in a new user context?

I created a test user, a new x2goclient session and tried to connect.
Same message: "Can't start X.Org server, please check your installation".

It seems like SSH connects (according to the auth.log), but nothing
happens next (at least in the auth log), and the session is closed
almost immediately...


---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
https://www.avast.com/antivirus


Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1246; Package x2goclient. (Sun, 28 Jan 2018 19:20:01 GMT) Full text and rfc822 format available.

Acknowledgement sent to LANNES Pierre-Yves <py.lannes@gmail.com>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Sun, 28 Jan 2018 19:20:02 GMT) Full text and rfc822 format available.

Message #20 received at 1246@bugs.x2go.org (full text, mbox):

From: LANNES Pierre-Yves <py.lannes@gmail.com>
To: 1246@bugs.x2go.org
Subject: Bug#1246: Can't start X Server, please check your installation)
Date: Sun, 28 Jan 2018 20:19:47 +0100
A bit more info...

First, I can now confirm that this bug occurs systematically, regardless
of any connection attempt.
I just had to start X2go client and wait for the error to pop up.

Second, I have tried to use a recent vcxsrv.exe (installed separately),
as the X2go built-in is 1.17.0.0-3". I tried with version 1.19.5.2".
No change noticed.

Hope that helps...

---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
https://www.avast.com/antivirus


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Wed Dec 12 05:42:47 2018; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.