X2Go Bug report logs - #1193
MacOS client does not work when local username has space

version graph

Packages: x2go, macos, client; Maintainer for x2go is (unknown); Maintainer for macos is (unknown); Maintainer for client is (unknown);

Reported by: Adam Tworkowski <adam.tworkowski@sickkids.ca>

Date: Thu, 13 Jul 2017 18:15:02 UTC

Severity: normal

Found in version 4.1.0.0

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, owner@bugs.x2go.org:
Bug#1193; Package x2go client (macos). (Thu, 13 Jul 2017 18:15:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Adam Tworkowski <adam.tworkowski@sickkids.ca>:
New Bug report received and forwarded. Copy sent to owner@bugs.x2go.org. (Thu, 13 Jul 2017 18:15:02 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.x2go.org (full text, mbox):

From: Adam Tworkowski <adam.tworkowski@sickkids.ca>
To: "submit@bugs.x2go.org" <submit@bugs.x2go.org>
Subject: MacOS client does not work when local username has space
Date: Thu, 13 Jul 2017 17:14:30 +0000
[Message part 1 (text/plain, inline)]
Package:  X2Go Client (MacOS)
Version: 4.1.0.0

I am not able to make a complete session with MacOS Sierra.  My (corporate) username is formatted “firstname lastname”, and thus:

/Users/firstname lastname/.x2go/
/Users/firstname lastname/.x2goclient/

I also have a personal account on the computer which is “firstname”, and thus:

/Users/firstname/

The error message I am getting while using the “firstname lastname” account is:

Loop: PANIC! Can’t read options from file ‘/Users/firstname.’  Error is 21 ‘is a directory’.

I have a strong suspicion that the client is having issues with the space in my username.  The reason I mention my personal account which is my first name is that /Users/firstname does exist and is a directory which may skew the error message during replication.  When /Users/firstname/ is temporarily renamed,  the client seems to hang and then closes without an error in ui.

Thank you,

Adam







________________________________

This e-mail may contain confidential, personal and/or health information(information which may be subject to legal restrictions on use, retention and/or disclosure) for the sole use of the intended recipient. Any review or distribution by anyone other than the person for whom it was originally intended is strictly prohibited. If you have received this e-mail in error, please contact the sender and delete all copies.
[Message part 2 (text/html, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Wed Dec 12 02:53:03 2018; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.