X2Go Bug report logs - #1125
Remote printing not working in Debian Jessie

version graph

Package: cups-x2go; Maintainer for cups-x2go is X2Go Developers <x2go-dev@lists.x2go.org>;

Reported by: JR <jrpique@baseinf.com>

Date: Fri, 16 Dec 2016 19:50:02 UTC

Severity: normal

Found in version 3.0.1.3-0x2go1+git20161129.135+8.main.1

Full log


Message #25 received at 1125@bugs.x2go.org (full text, mbox, reply):

Received: (at 1125) by bugs.x2go.org; 21 Dec 2016 11:37:01 +0000
From x2go@hemsing.eu  Wed Dec 21 12:36:59 2016
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=-1.9 required=3.0 tests=BAYES_00,URIBL_BLOCKED
	autolearn=ham version=3.3.2
Received: from localhost (localhost [127.0.0.1])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id 8CAC43CC60
	for <1125@bugs.x2go.org>; Wed, 21 Dec 2016 12:36:59 +0100 (CET)
X-Virus-Scanned: Debian amavisd-new at ymir.das-netzwerkteam.de
Received: from ymir.das-netzwerkteam.de ([127.0.0.1])
	by localhost (ymir.das-netzwerkteam.de [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id WujlOvgoorhB for <1125@bugs.x2go.org>;
	Wed, 21 Dec 2016 12:36:53 +0100 (CET)
X-Greylist: delayed 323 seconds by postgrey-1.34 at ymir.das-netzwerkteam.de; Wed, 21 Dec 2016 12:36:52 CET
Received: from s2.spam-free.eu (s2.spam-free.eu [195.5.121.125])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id EF69E3CC5F
	for <1125@bugs.x2go.org>; Wed, 21 Dec 2016 12:36:52 +0100 (CET)
Received: from [172.16.0.33] (b2b-130-180-2-58.unitymedia.biz [130.180.2.58])
	by s2.spam-free.eu (Postfix) with ESMTPSA id 0FE6524119D;
	Wed, 21 Dec 2016 12:31:15 +0100 (CET)
Subject: Re: [X2Go-Dev] Bug#1125: Bug#1125: Remote printing not working in
 Debian Jessie
To: JR <jrpique@baseinf.com>, 1125@bugs.x2go.org
References: <20161216204146.f1bdcc0b625a16e446cca0f3@baseinf.com>
 <5e9c36bf-680f-7d55-724a-6f3464a11050@baur-itcs.de>
 <20161221120010.0529e0c60bb46f612cf6d87b@baseinf.com>
From: Chris <x2go@hemsing.eu>
Message-ID: <3455d80c-adac-38b0-edc3-037a6a675e1a@hemsing.eu>
Date: Wed, 21 Dec 2016 12:30:56 +0100
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101
 Thunderbird/45.4.0
MIME-Version: 1.0
In-Reply-To: <20161221120010.0529e0c60bb46f612cf6d87b@baseinf.com>
Content-Type: text/plain; charset=utf-8; format=flowed
Content-Transfer-Encoding: 8bit
Hi JR,

have you read:
http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=694

That buf has been there since 2014. Nobody cares.
It might be your problem.

BR
Chris



Am 21.12.2016 um 12:00 schrieb JR:
> Hi Stefan,
>
> I tried the options discussed without success.
> It is strange, perhaps this Windows XP has a problem.
> So I can I will test different scenarios and I will notify the results.
>
> Thank you very much.
>
> Kind Regards,
>
> JR
>
> On Mon, 19 Dec 2016 19:48:37 +0100
> Stefan Baur <X2Go-ML-1@baur-itcs.de> wrote:
>
>> Am 16.12.2016 um 20:41 schrieb JR:
>>> Package: cups-x2go
>>> Version: 3.0.1.3-0x2go1+git20161129.135+8.main.1
>>>
>>> I tried printing on the local PC from the x2goclient without success.
>>> x2goclient gives no message.
>>>
>>> I installed x2goserver-printing,  cups, cups-x2go and I  have installed x2go virtual printer.
>>>
>>> This happens to me only in Q4OS 1.18-Orion (Debian Jessie based). In Q4OS 2.2-Scorpion (Debian Stretch based) it works perfectly.
>>>
>>> For more details, please give a look at:
>>>
>>> http://www.q4os.org/forum/viewtopic.php?id=1261
>> I followed that thread and the reason why you can't print at all is
>> SystemD-related, not X2Go-related.  For various reasons, I don't think
>> too highly of SystemD, and I strongy doubt that we'll add a patch to
>> X2Go to fix something that is actually SystemD's fault.
>>
>> Now, why you still can't print from Windows XP after applying that
>> configuration change, that's another issue, and one that will have to be
>> investigated.
>>
>> Please check that the settings under Options/Settings/Printing match
>> between your Linux client (where remote printing works after applying
>> the fix) and your Windows client for your initial test.
>>
>> After that, please try changing the Windows client setting to "View as
>> PDF" instead of printing directly.  If that doesn't work, either, then
>> you're either missing a default PDF viewing/printing application (you
>> can try SumatraPDF if you don't want something as bloated as Adobe
>> Reader) on the client, or there's something wrong in getting the data
>> processed.
>>
>> For that, I would suggest running the debug version of X2GoClient.exe
>> and logging its output to a file, then attaching that file to the bug
>> report by e-mailing it to: 1125@bugs.x2go.org
>>
>> Kind Regards,
>> Stefan Baur
>>
>> -- 
>> BAUR-ITCS UG (haftungsbeschränkt)
>> Geschäftsführer: Stefan Baur
>> Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
>> Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243
>>
> _______________________________________________
> x2go-dev mailing list
> x2go-dev@lists.x2go.org
> http://lists.x2go.org/listinfo/x2go-dev


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Wed Feb 8 13:00:05 2023; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.