X2Go Bug report logs - #1109
Print all In new window Long delays (i.e. several minutes) waiting for redraw ONLY in seamless window mode

version graph

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Thomas Esposito <tmesposito00@gmail.com>

Date: Thu, 27 Oct 2016 18:40:01 UTC

Severity: critical

Found in version 4.0.1.19-3

Full log


🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#1109: [X2Go-Dev] Bug#1109: Print all In new window Long delays (i.e. several minutes) waiting for redraw ONLY in seamless window mode
Reply-To: akik@iki.fi, 1109@bugs.x2go.org
Resent-From: Aki Ketolainen <akik@mykolab.com>
Resent-To: x2go-dev@lists.x2go.org
Resent-CC: X2Go Developers <x2go-dev@lists.x2go.org>
X-Loop: owner@bugs.x2go.org
Resent-Date: Fri, 18 Nov 2016 09:50:01 +0000
Resent-Message-ID: <handler.1109.B1109.147946236816014@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: followup 1109
X-X2Go-PR-Package: x2goserver
X-X2Go-PR-Keywords: 
Received: via spool by 1109-submit@bugs.x2go.org id=B1109.147946236816014
          (code B ref 1109); Fri, 18 Nov 2016 09:50:01 +0000
Received: (at 1109) by bugs.x2go.org; 18 Nov 2016 09:46:08 +0000
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=-1.9 required=3.0 tests=BAYES_00,FREEMAIL_FROM,
	HTML_MESSAGE autolearn=ham version=3.3.2
Received: from localhost (localhost [127.0.0.1])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id EB03A3CBB6
	for <1109@bugs.x2go.org>; Fri, 18 Nov 2016 10:46:05 +0100 (CET)
X-Virus-Scanned: Debian amavisd-new at ymir.das-netzwerkteam.de
Received: from ymir.das-netzwerkteam.de ([127.0.0.1])
	by localhost (ymir.das-netzwerkteam.de [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id j6gFNXrurvf9 for <1109@bugs.x2go.org>;
	Fri, 18 Nov 2016 10:45:58 +0100 (CET)
X-Greylist: delayed 420 seconds by postgrey-1.34 at ymir.das-netzwerkteam.de; Fri, 18 Nov 2016 10:45:58 CET
Received: from mx-out03.mykolab.com (mx.kolabnow.com [95.128.36.1])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id A310B3CBB5
	for <1109@bugs.x2go.org>; Fri, 18 Nov 2016 10:45:58 +0100 (CET)
X-Virus-Scanned: amavisd-new at kolabnow.com
Received: from mx05.mykolab.com (mx05.mykolab.com [10.20.7.161])
	by mx-out03.mykolab.com (Postfix) with ESMTPS id 8592721EB7;
	Fri, 18 Nov 2016 10:38:56 +0100 (CET)
MIME-Version: 1.0
Content-Type: multipart/alternative;
 boundary="=_67d3b55859e7397e4b2bd536235c15df"
Date: Fri, 18 Nov 2016 11:38:55 +0200
From: Aki Ketolainen <akik@mykolab.com>
To: Thomas Esposito <tmesposito00@gmail.com>, 1109@bugs.x2go.org
Mail-Reply-To: akik@iki.fi
In-Reply-To: <CANUZkSUE0NoDnchG1RXxRyDokt9hpDU5yC27FnpEyr8b0fToxA@mail.gmail.com>
References: <CANUZkSUE0NoDnchG1RXxRyDokt9hpDU5yC27FnpEyr8b0fToxA@mail.gmail.com>
Message-ID: <909cd94234462d1675f2c3d8ab4f2f18@mykolab.com>
X-Sender: akik@mykolab.com
[Message part 1 (text/plain, inline)]
On 2016-10-27 21:37, Thomas Esposito wrote:

 > Package: x2goserver
 > Version: 4.0.1.19-3
 > Severity: critical
> 
>  Server OS: RHEL6.6
>  Client OS: Windows 7 SP1 64-bit
>  Server Packages: x2goserver-4.0.1.19-3.el6.x86_64
>                             x2goagent-3.5.0.32-3.el6.x86_64
>                             nxagent-3.5.0.31-1.el6.x86_64 (not sure if this is a dependency)
>                              nx-libs-3.5.0.31-1.el6.x86_64 (not sure if this is a dependency)
> Client Version: 4.0.5.2
>
> <cut>
>
> Luckily, I was able to find a free application that is similarly unresponsive when starting up in seamless window mode, but that runs fine in virtual desktop mode: xcircuit. This happens to be a free CAD program for drawing circuit schematics. Obviously, I can't be 100% that this X11 application is failing in the same way as my proprietary EDA tools, but it is something the x2go developers can look at regardless.
>
> http://opencircuitdesign.com/xcircuit/
>
>  <cut> 

Hi, 

I'm experiencing the same effect than you, but the software applications
and operating systems are a bit different.
In my case the slow window redraws happen if:

The client operating system is Ubuntu Linux and the local desktop
environment is either Unity,  XFCE or Mate.
If I'm running Ubuntu Linux on the client machine and the local desktop
environment is either KDE or LXDE, I don't experience the slow window
updates.
I'm running the X2Go server on Azure and it's running CentOS 6.8. The
desktop environment on the server is XFCE.

As you also noticed, the slow window updates only happen with the single
application mode/seamless window mode. 

I haven't tested much with Windows on the client side but the same slow
window updates that you can see just by moving terminal windows on top
of each other is not there
(when you first open one terminal with single application mode and then
open another terminal from the first).

I installed xcircuit on the X2Go server and it starts up and works quite
ok, although I don't have any design file to test with.
We are working on the same EDA field so I'm interested in finding a
solution to this problem.

Bug reports talking about the slow window updates:
http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=1010
http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=1081

Best regards, 

Aki 

  
[Message part 2 (text/html, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Wed Apr 24 23:13:12 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.