X2Go Bug report logs - #1089
x2go Ubuntu 16.04 and Fedora 24

version graph

Package: x2server; Maintainer for x2server is (unknown);

Reported by: Robert Dinse <nanook@eskimo.com>

Date: Sun, 18 Sep 2016 16:55:02 UTC

Severity: normal

Fixed in version 3.5.99.1

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, owner@bugs.x2go.org:
Bug#1089; Package x2server. (Sun, 18 Sep 2016 16:55:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Robert Dinse <nanook@eskimo.com>:
New Bug report received and forwarded. Copy sent to owner@bugs.x2go.org.

Your message had a Version: pseudo-header with an invalid package version:

4.0.1.19-11.fc24 and 4.0.1.19-0~ubuntu16.04.1

please either use found or fixed to the control server with a correct version, or reply to this report indicating the correct version so the maintainer (or someone else) can correct it for you.

(Sun, 18 Sep 2016 16:55:02 GMT) Full text and rfc822 format available.


Message #5 received at submit@bugs.x2go.org (full text, mbox):

From: Robert Dinse <nanook@eskimo.com>
To: submit@bugs.x2go.org
Subject: x2go Ubuntu 16.04 and Fedora 24
Date: Sun, 18 Sep 2016 09:47:50 -0700 (PDT)
Package: x2server
Version: 4.0.1.19-11.fc24 and 4.0.1.19-0~ubuntu16.04.1

     The version of xrandr built into the x2go server is 1.2, but both Ubuntu 
16.04.1 and Fedora 24 require 1.3 at least.

     When I connect with full display, this causes me to get a 600x800 window
in the full display instead of the full display because the resize fails on
the server.

     My current work around on both Ubuntu 16.04.1 and Fedora 24 is to bring
up a terminal and type "xrandr -s 1680x1050".  This works as the command line
version is 1.5.

     However using the display settings under Mate also fails.


-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-
 Eskimo North Linux Friendly Internet Access, Shell Accounts, and Hosting.
   Knowledgeable human assistance, not telephone trees or script readers.
 See our web site: http://www.eskimo.com/ (206) 812-0051 or (800) 246-6874.


Information forwarded to x2go-dev@lists.x2go.org, owner@bugs.x2go.org:
Bug#1089; Package x2server. (Sun, 18 Sep 2016 19:15:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mike Gabriel <mike.gabriel@das-netzwerkteam.de>:
Extra info received and forwarded to list. Copy sent to owner@bugs.x2go.org. (Sun, 18 Sep 2016 19:15:02 GMT) Full text and rfc822 format available.

Message #10 received at 1089@bugs.x2go.org (full text, mbox):

From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
To: Robert Dinse <nanook@eskimo.com>, 1089@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#1089: x2go Ubuntu 16.04 and Fedora 24
Date: Sun, 18 Sep 2016 19:13:07 +0000
[Message part 1 (text/plain, inline)]
Hi Robert,

On  So 18 Sep 2016 18:47:50 CEST, Robert Dinse wrote:

> Package: x2server
> Version: 4.0.1.19-11.fc24 and 4.0.1.19-0~ubuntu16.04.1
>
>      The version of xrandr built into the x2go server is 1.2, but  
> both Ubuntu 16.04.1 and Fedora 24 require 1.3 at least.
>
>      When I connect with full display, this causes me to get a 600x800 window
> in the full display instead of the full display because the resize fails on
> the server.
>
>      My current work around on both Ubuntu 16.04.1 and Fedora 24 is to bring
> up a terminal and type "xrandr -s 1680x1050".  This works as the command line
> version is 1.5.
>
>      However using the display settings under Mate also fails.
>

Please try nx-libs 3.5.99.1 [1]. This needs to be installed in  
conjunction with x2goserver-x2goagent (available in x2goserver nightly  
builds).

Please do that on a test server and report back if issues are gone then.

Mike

[1] https://sunweavers.net/blog/node/46
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de

[Message part 2 (application/pgp-signature, inline)]

Information forwarded to x2go-dev@lists.x2go.org, owner@bugs.x2go.org:
Bug#1089; Package x2server. (Sun, 18 Sep 2016 20:05:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Robert Dinse <nanook@eskimo.com>:
Extra info received and forwarded to list. Copy sent to owner@bugs.x2go.org. (Sun, 18 Sep 2016 20:05:02 GMT) Full text and rfc822 format available.

Message #15 received at 1089@bugs.x2go.org (full text, mbox):

From: Robert Dinse <nanook@eskimo.com>
To: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
Cc: 1089@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#1089: x2go Ubuntu 16.04 and Fedora 24
Date: Sun, 18 Sep 2016 12:53:43 -0700 (PDT)
     I do not seem to be able to find that version on the repository for
Ubuntu, I added:

     add-apt-repository ppa:x2go/ppa

     Then did an apt-get update; and then I went into Synaptic and did a
reload there as well, but searching can't find that version of the libs,
only 3.5.0.* no 3.5.99.*

-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-
 Eskimo North Linux Friendly Internet Access, Shell Accounts, and Hosting.
   Knowledgeable human assistance, not telephone trees or script readers.
 See our web site: http://www.eskimo.com/ (206) 812-0051 or (800) 246-6874.

On Sun, 18 Sep 2016, Mike Gabriel wrote:

> Date: Sun, 18 Sep 2016 19:13:07 +0000
> From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
> To: Robert Dinse <nanook@eskimo.com>, 1089@bugs.x2go.org
> Subject: Re: [X2Go-Dev] Bug#1089: x2go Ubuntu 16.04 and Fedora 24
> 
> Hi Robert,
>
> On  So 18 Sep 2016 18:47:50 CEST, Robert Dinse wrote:
>
>> Package: x2server
>> Version: 4.0.1.19-11.fc24 and 4.0.1.19-0~ubuntu16.04.1
>>
>>     The version of xrandr built into the x2go server is 1.2, but both 
>> Ubuntu 16.04.1 and Fedora 24 require 1.3 at least.
>>
>>     When I connect with full display, this causes me to get a 600x800 
>> window
>> in the full display instead of the full display because the resize fails on
>> the server.
>>
>>     My current work around on both Ubuntu 16.04.1 and Fedora 24 is to bring
>> up a terminal and type "xrandr -s 1680x1050".  This works as the command 
>> line
>> version is 1.5.
>>
>>     However using the display settings under Mate also fails.
>> 
>
> Please try nx-libs 3.5.99.1 [1]. This needs to be installed in conjunction 
> with x2goserver-x2goagent (available in x2goserver nightly builds).
>
> Please do that on a test server and report back if issues are gone then.
>
> Mike
>
> [1] https://sunweavers.net/blog/node/46
> -- 
>
> DAS-NETZWERKTEAM
> mike gabriel, herweg 7, 24357 fleckeby
> mobile: +49 (1520) 1976 148
> landline: +49 (4354) 8390 139
>
> GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
> mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de
>


Information forwarded to x2go-dev@lists.x2go.org, owner@bugs.x2go.org:
Bug#1089; Package x2server. (Sun, 18 Sep 2016 21:25:01 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mike Gabriel <mike.gabriel@das-netzwerkteam.de>:
Extra info received and forwarded to list. Copy sent to owner@bugs.x2go.org. (Sun, 18 Sep 2016 21:25:01 GMT) Full text and rfc822 format available.

Message #20 received at 1089@bugs.x2go.org (full text, mbox):

From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
To: Robert Dinse <nanook@eskimo.com>, 1089@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#1089: Bug#1089: x2go Ubuntu 16.04 and Fedora 24
Date: Sun, 18 Sep 2016 21:23:04 +0000
[Message part 1 (text/plain, inline)]
On  So 18 Sep 2016 21:53:43 CEST, Robert Dinse wrote:

> I do not seem to be able to find that version on the repository for
> Ubuntu, I added:
>
>      add-apt-repository ppa:x2go/ppa
>
>      Then did an apt-get update; and then I went into Synaptic and did a
> reload there as well, but searching can't find that version of the libs,
> only 3.5.0.* no 3.5.99.*

Follow the link to my blog (in the previous mail) and read where that  
pkgs are available.

The new nx-libs 3.5.99.x / 3.6.x has not arrived in the X2Go pkg  
archives, yet.

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de

[Message part 2 (application/pgp-signature, inline)]

Information forwarded to x2go-dev@lists.x2go.org, owner@bugs.x2go.org:
Bug#1089; Package x2server. (Sun, 18 Sep 2016 21:30:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Robert Dinse <nanook@eskimo.com>:
Extra info received and forwarded to list. Copy sent to owner@bugs.x2go.org. (Sun, 18 Sep 2016 21:30:02 GMT) Full text and rfc822 format available.

Message #25 received at 1089@bugs.x2go.org (full text, mbox):

From: Robert Dinse <nanook@eskimo.com>
To: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
Cc: 1089@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#1089: Bug#1089: x2go Ubuntu 16.04 and Fedora 24
Date: Sun, 18 Sep 2016 14:28:55 -0700 (PDT)
     Could you resend the URL, sorry I deleted.

-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-
 Eskimo North Linux Friendly Internet Access, Shell Accounts, and Hosting.
   Knowledgeable human assistance, not telephone trees or script readers.
 See our web site: http://www.eskimo.com/ (206) 812-0051 or (800) 246-6874.

On Sun, 18 Sep 2016, Mike Gabriel wrote:

> Date: Sun, 18 Sep 2016 21:23:04 +0000
> From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
> To: Robert Dinse <nanook@eskimo.com>, 1089@bugs.x2go.org
> Subject: Re: [X2Go-Dev] Bug#1089: Bug#1089: x2go Ubuntu 16.04 and Fedora 24
> 
> On  So 18 Sep 2016 21:53:43 CEST, Robert Dinse wrote:
>
>> I do not seem to be able to find that version on the repository for
>> Ubuntu, I added:
>>
>>     add-apt-repository ppa:x2go/ppa
>>
>>     Then did an apt-get update; and then I went into Synaptic and did a
>> reload there as well, but searching can't find that version of the libs,
>> only 3.5.0.* no 3.5.99.*
>
> Follow the link to my blog (in the previous mail) and read where that pkgs 
> are available.
>
> The new nx-libs 3.5.99.x / 3.6.x has not arrived in the X2Go pkg archives, 
> yet.
>
> Mike
> -- 
>
> DAS-NETZWERKTEAM
> mike gabriel, herweg 7, 24357 fleckeby
> mobile: +49 (1520) 1976 148
> landline: +49 (4354) 8390 139
>
> GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
> mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de
>


Information forwarded to x2go-dev@lists.x2go.org, owner@bugs.x2go.org:
Bug#1089; Package x2server. (Sun, 18 Sep 2016 23:45:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mike DePaulo <mikedep333@gmail.com>:
Extra info received and forwarded to list. Copy sent to owner@bugs.x2go.org. (Sun, 18 Sep 2016 23:45:03 GMT) Full text and rfc822 format available.

Message #30 received at 1089@bugs.x2go.org (full text, mbox):

From: Mike DePaulo <mikedep333@gmail.com>
To: Robert Dinse <nanook@eskimo.com>, 1089@bugs.x2go.org
Cc: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
Subject: Re: [X2Go-Dev] Bug#1089: Bug#1089: Bug#1089: x2go Ubuntu 16.04 and Fedora 24
Date: Sun, 18 Sep 2016 19:41:15 -0400
On Sun, Sep 18, 2016 at 5:28 PM, Robert Dinse <nanook@eskimo.com> wrote:
>
>      Could you resend the URL, sorry I deleted.
> [...]
https://sunweavers.net/blog/node/46


Information forwarded to x2go-dev@lists.x2go.org, owner@bugs.x2go.org:
Bug#1089; Package x2server. (Mon, 19 Sep 2016 00:10:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Robert Dinse <nanook@eskimo.com>:
Extra info received and forwarded to list. Copy sent to owner@bugs.x2go.org. (Mon, 19 Sep 2016 00:10:03 GMT) Full text and rfc822 format available.

Message #35 received at 1089@bugs.x2go.org (full text, mbox):

From: Robert Dinse <nanook@eskimo.com>
To: Mike DePaulo <mikedep333@gmail.com>
Cc: 1089@bugs.x2go.org, Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
Subject: Re: [X2Go-Dev] Bug#1089: Bug#1089: Bug#1089: x2go Ubuntu 16.04 and Fedora 24
Date: Sun, 18 Sep 2016 17:06:21 -0700 (PDT)
     I installed it but it broke a whole bunch of stuff.  For now I'm going
to attempt to put the old lib back until I can understand why all of this
broke.

dpkg -i libnx-x11-6_3.5.99.1-0.1+git20160913.1427+16.04.release.1_amd64.deb 
--auto-deconfigure
dpkg: regarding 
libnx-x11-6_3.5.99.1-0.1+git20160913.1427+16.04.release.1_amd64.deb containing 
libnx-x11-6:amd64:
 libnx-x11-6:amd64 breaks libnx-xcomposite1 (<< 2:3.6.0.0)
  libnx-xcomposite1:amd64 (version 2:3.5.0.33-0~687~ubuntu16.04.1) is present 
and installed.

dpkg: error processing archive 
libnx-x11-6_3.5.99.1-0.1+git20160913.1427+16.04.release.1_amd64.deb 
(--install):
 installing libnx-x11-6:amd64 would break libnx-xcomposite1:amd64, and
 deconfiguration is not permitted (--auto-deconfigure might help)
dpkg: error processing archive --auto-deconfigure (--install):
 cannot access archive: No such file or directory
Errors were encountered while processing:
 libnx-x11-6_3.5.99.1-0.1+git20160913.1427+16.04.release.1_amd64.deb
 --auto-deconfigure
# dpkg --auto-deconfigure -i 
libnx-x11-6_3.5.99.1-0.1+git20160913.1427+16.04.release.1_amd64.deb
dpkg: considering deconfiguration of libnx-xcomposite1:amd64, which would be 
broken by installation of libnx-x11-6:amd64 ...
dpkg: yes, will deconfigure libnx-xcomposite1:amd64 (broken by 
libnx-x11-6:amd64)
dpkg: considering deconfiguration of libnx-xdamage1:amd64, which would be 
broken by installation of libnx-x11-6:amd64 ...
dpkg: yes, will deconfigure libnx-xdamage1:amd64 (broken by libnx-x11-6:amd64)
dpkg: considering deconfiguration of libnx-xdmcp6:amd64, which would be broken 
by installation of libnx-x11-6:amd64 ...
dpkg: yes, will deconfigure libnx-xdmcp6:amd64 (broken by libnx-x11-6:amd64)
dpkg: considering deconfiguration of libnx-xext6:amd64, which would be broken 
by installation of libnx-x11-6:amd64 ...
dpkg: yes, will deconfigure libnx-xext6:amd64 (broken by libnx-x11-6:amd64)
dpkg: considering deconfiguration of libnx-xfixes3:amd64, which would be broken 
by installation of libnx-x11-6:amd64 ...
dpkg: yes, will deconfigure libnx-xfixes3:amd64 (broken by libnx-x11-6:amd64)
dpkg: considering deconfiguration of libnx-xinerama1:amd64, which would be 
broken by installation of libnx-x11-6:amd64 ...
dpkg: yes, will deconfigure libnx-xinerama1:amd64 (broken by libnx-x11-6:amd64)
dpkg: considering deconfiguration of libnx-xpm4:amd64, which would be broken by 
installation of libnx-x11-6:amd64 ...
dpkg: yes, will deconfigure libnx-xpm4:amd64 (broken by libnx-x11-6:amd64)
dpkg: considering deconfiguration of libnx-xrandr2:amd64, which would be broken 
by installation of libnx-x11-6:amd64 ...
dpkg: yes, will deconfigure libnx-xrandr2:amd64 (broken by libnx-x11-6:amd64)
dpkg: considering deconfiguration of libnx-xrender1:amd64, which would be 
broken by installation of libnx-x11-6:amd64 ...
dpkg: yes, will deconfigure libnx-xrender1:amd64 (broken by libnx-x11-6:amd64)
dpkg: considering deconfiguration of libnx-xtst6:amd64, which would be broken 
by installation of libnx-x11-6:amd64 ...
dpkg: yes, will deconfigure libnx-xtst6:amd64 (broken by libnx-x11-6:amd64)
(Reading database ... 3536507 files and directories currently installed.)
Preparing to unpack 
libnx-x11-6_3.5.99.1-0.1+git20160913.1427+16.04.release.1_amd64.deb ...
De-configuring libnx-xtst6:amd64 (2:3.5.0.33-0~687~ubuntu16.04.1) ...
De-configuring libnx-xrender1:amd64 (2:3.5.0.33-0~687~ubuntu16.04.1) ...
De-configuring libnx-xrandr2:amd64 (2:3.5.0.33-0~687~ubuntu16.04.1) ...
De-configuring libnx-xpm4:amd64 (2:3.5.0.33-0~687~ubuntu16.04.1) ...
De-configuring libnx-xinerama1:amd64 (2:3.5.0.33-0~687~ubuntu16.04.1) ...
De-configuring libnx-xfixes3:amd64 (2:3.5.0.33-0~687~ubuntu16.04.1) ...
De-configuring libnx-xext6:amd64 (2:3.5.0.33-0~687~ubuntu16.04.1) ...
De-configuring libnx-xdmcp6:amd64 (2:3.5.0.33-0~687~ubuntu16.04.1) ...
De-configuring libnx-xdamage1:amd64 (2:3.5.0.33-0~687~ubuntu16.04.1) ...
De-configuring libnx-xcomposite1:amd64 (2:3.5.0.33-0~687~ubuntu16.04.1) ...
Unpacking libnx-x11-6:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1) 
over (2:3.5.0.33-0~687~ubuntu16.04.1) ...
dpkg: dependency problems prevent configuration of libnx-x11-6:amd64:
 libnx-x11-6:amd64 depends on libxcomp3 (= 
2:3.5.99.1-0.1+git20160913.1427+16.04.release.1); however:
  Version of libxcomp3:amd64 on system is 2:3.5.0.33-0~687~ubuntu16.04.1.
 libnx-x11-6:amd64 depends on nx-x11-common (>= 
2:3.5.99.1-0.1+git20160913.1427+16.04.release.1); however:
  Version of nx-x11-common on system is 2:3.5.0.33-0~687~ubuntu16.04.1.

dpkg: error processing package libnx-x11-6:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnx-xcomposite1:amd64:
 libnx-xcomposite1:amd64 depends on libnx-x11-6 (>= 3.5.0.29); however:
  Package libnx-x11-6:amd64 is not configured yet.
 libnx-x11-6:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1) breaks 
libnx-xcomposite1 (<< 2:3.6.0.0) and is unpacked but not configured.
  Version of libnx-xcomposite1:amd64 to be configured is 
2:3.5.0.33-0~687~ubuntu16.04.1.

dpkg: error processing package libnx-xcomposite1:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnx-xdamage1:amd64:
 libnx-xdamage1:amd64 depends on libnx-x11-6 (>= 3.5.0.29); however:
  Package libnx-x11-6:amd64 is not configured yet.
 libnx-x11-6:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1) breaks 
libnx-xdamage1 (<< 2:3.6.0.0) and is unpacked but not configured.
  Version of libnx-xdamage1:amd64 to be configured is 
2:3.5.0.33-0~687~ubuntu16.04.1.

dpkg: error processing package libnx-xdamage1:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnx-xdmcp6:amd64:
 libnx-x11-6:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1) breaks 
libnx-xdmcp6 (<< 2:3.6.0.0) and is unpacked but not configured.
  Version of libnx-xdmcp6:amd64 to be configured is 
2:3.5.0.33-0~687~ubuntu16.04.1.

dpkg: error processing package libnx-xdmcp6:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnx-xext6:amd64:
 libnx-xext6:amd64 depends on libnx-x11-6 (>= 3.5.0.29); however:
  Package libnx-x11-6:amd64 is not configured yet.
 libnx-x11-6:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1) breaks 
libnx-xext6 (<< 2:3.6.0.0) and is unpacked but not configured.
  Version of libnx-xext6:amd64 to be configured is 
2:3.5.0.33-0~687~ubuntu16.04.1.

dpkg: error processing package libnx-xext6:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnx-xfixes3:amd64:
 libnx-xfixes3:amd64 depends on libnx-x11-6 (>= 3.5.0.29); however:
  Package libnx-x11-6:amd64 is not configured yet.
 libnx-x11-6:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1) breaks 
libnx-xfixes3 (<< 2:3.6.0.0) and is unpacked but not configured.
  Version of libnx-xfixes3:amd64 to be configured is 
2:3.5.0.33-0~687~ubuntu16.04.1.

dpkg: error processing package libnx-xfixes3:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnx-xinerama1:amd64:
 libnx-xinerama1:amd64 depends on libnx-x11-6 (>= 3.5.0.29); however:
  Package libnx-x11-6:amd64 is not configured yet.
 libnx-xinerama1:amd64 depends on libnx-xext6 (>= 3.5.0.29); however:
  Package libnx-xext6:amd64 is not configured yet.
 libnx-x11-6:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1) breaks 
libnx-xinerama1 (<< 2:3.6.0.0) and is unpacked but not configured.
  Version of libnx-xinerama1:amd64 to be configured is 
2:3.5.0.33-0~687~ubuntu16.04.1.

dpkg: error processing package libnx-xinerama1:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnx-xpm4:amd64:
 libnx-xpm4:amd64 depends on libnx-x11-6 (>= 3.5.0.29); however:
  Package libnx-x11-6:amd64 is not configured yet.
 libnx-x11-6:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1) breaks 
libnx-xpm4 (<< 2:3.6.0.0) and is unpacked but not configured.
  Version of libnx-xpm4:amd64 to be configured is 
2:3.5.0.33-0~687~ubuntu16.04.1.

dpkg: error processing package libnx-xpm4:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnx-xrandr2:amd64:
 libnx-xrandr2:amd64 depends on libnx-x11-6 (>= 3.5.0.29); however:
  Package libnx-x11-6:amd64 is not configured yet.
 libnx-xrandr2:amd64 depends on libnx-xext6 (>= 3.5.0.29); however:
  Package libnx-xext6:amd64 is not configured yet.
 libnx-x11-6:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1) breaks 
libnx-xrandr2 (<< 2:3.6.0.0) and is unpacked but not configured.
  Version of libnx-xrandr2:amd64 to be configured is 
2:3.5.0.33-0~687~ubuntu16.04.1.

dpkg: error processing package libnx-xrandr2:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnx-xrender1:amd64:
 libnx-xrender1:amd64 depends on libnx-x11-6 (>= 3.5.0.29); however:
  Package libnx-x11-6:amd64 is not configured yet.
 libnx-x11-6:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1) breaks 
libnx-xrender1 (<< 2:3.6.0.0) and is unpacked but not configured.
  Version of libnx-xrender1:amd64 to be configured is 
2:3.5.0.33-0~687~ubuntu16.04.1.

dpkg: error processing package libnx-xrender1:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnx-xtst6:amd64:
 libnx-xtst6:amd64 depends on libnx-x11-6 (>= 3.5.0.29); however:
  Package libnx-x11-6:amd64 is not configured yet.
 libnx-xtst6:amd64 depends on libnx-xext6 (>= 3.5.0.29); however:
  Package libnx-xext6:amd64 is not configured yet.
 libnx-x11-6:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1) breaks 
libnx-xtst6 (<< 2:3.6.0.0) and is unpacked but not configured.
  Version of libnx-xtst6:amd64 to be configured is 
2:3.5.0.33-0~687~ubuntu16.04.1.

dpkg: error processing package libnx-xtst6:amd64 (--install):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.23-0ubuntu3) ...
Errors were encountered while processing:
 libnx-x11-6:amd64
 libnx-xcomposite1:amd64
 libnx-xdamage1:amd64
 libnx-xdmcp6:amd64
 libnx-xext6:amd64
 libnx-xfixes3:amd64
 libnx-xinerama1:amd64
 libnx-xpm4:amd64
 libnx-xrandr2:amd64
 libnx-xrender1:amd64
 libnx-xtst6:amd64
# dpkg --configure -a
dpkg: dependency problems prevent configuration of libnx-x11-6:amd64:
 libnx-x11-6:amd64 depends on libxcomp3 (= 
2:3.5.99.1-0.1+git20160913.1427+16.04.release.1); however:
  Version of libxcomp3:amd64 on system is 2:3.5.0.33-0~687~ubuntu16.04.1.
 libnx-x11-6:amd64 depends on nx-x11-common (>= 
2:3.5.99.1-0.1+git20160913.1427+16.04.release.1); however:
  Version of nx-x11-common on system is 2:3.5.0.33-0~687~ubuntu16.04.1.

dpkg: error processing package libnx-x11-6:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnx-xdamage1:amd64:
 libnx-xdamage1:amd64 depends on libnx-x11-6 (>= 3.5.0.29); however:
  Package libnx-x11-6:amd64 is not configured yet.
 libnx-x11-6:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1) breaks 
libnx-xdamage1 (<< 2:3.6.0.0) and is unpacked but not configured.
  Version of libnx-xdamage1:amd64 to be configured is 
2:3.5.0.33-0~687~ubuntu16.04.1.

dpkg: error processing package libnx-xdamage1:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnx-xpm4:amd64:
 libnx-xpm4:amd64 depends on libnx-x11-6 (>= 3.5.0.29); however:
  Package libnx-x11-6:amd64 is not configured yet.
 libnx-x11-6:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1) breaks 
libnx-xpm4 (<< 2:3.6.0.0) and is unpacked but not configured.
  Version of libnx-xpm4:amd64 to be configured is 
2:3.5.0.33-0~687~ubuntu16.04.1.

dpkg: error processing package libnx-xpm4:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnx-xcomposite1:amd64:
 libnx-xcomposite1:amd64 depends on libnx-x11-6 (>= 3.5.0.29); however:
  Package libnx-x11-6:amd64 is not configured yet.
 libnx-x11-6:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1) breaks 
libnx-xcomposite1 (<< 2:3.6.0.0) and is unpacked but not configured.
  Version of libnx-xcomposite1:amd64 to be configured is 
2:3.5.0.33-0~687~ubuntu16.04.1.

dpkg: error processing package libnx-xcomposite1:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnx-xfixes3:amd64:
 libnx-xfixes3:amd64 depends on libnx-x11-6 (>= 3.5.0.29); however:
  Package libnx-x11-6:amd64 is not configured yet.
 libnx-x11-6:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1) breaks 
libnx-xfixes3 (<< 2:3.6.0.0) and is unpacked but not configured.
  Version of libnx-xfixes3:amd64 to be configured is 
2:3.5.0.33-0~687~ubuntu16.04.1.

dpkg: error processing package libnx-xfixes3:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnx-xrandr2:amd64:
 libnx-xrandr2:amd64 depends on libnx-x11-6 (>= 3.5.0.29); however:
  Package libnx-x11-6:amd64 is not configured yet.
 libnx-x11-6:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1) breaks 
libnx-xrandr2 (<< 2:3.6.0.0) and is unpacked but not configured.
  Version of libnx-xrandr2:amd64 to be configured is 
2:3.5.0.33-0~687~ubuntu16.04.1.

dpkg: error processing package libnx-xrandr2:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnx-xdmcp6:amd64:
 libnx-x11-6:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1) breaks 
libnx-xdmcp6 (<< 2:3.6.0.0) and is unpacked but not configured.
  Version of libnx-xdmcp6:amd64 to be configured is 
2:3.5.0.33-0~687~ubuntu16.04.1.

dpkg: error processing package libnx-xdmcp6:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnx-xtst6:amd64:
 libnx-xtst6:amd64 depends on libnx-x11-6 (>= 3.5.0.29); however:
  Package libnx-x11-6:amd64 is not configured yet.
 libnx-x11-6:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1) breaks 
libnx-xtst6 (<< 2:3.6.0.0) and is unpacked but not configured.
  Version of libnx-xtst6:amd64 to be configured is 
2:3.5.0.33-0~687~ubuntu16.04.1.

dpkg: error processing package libnx-xtst6:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnx-xext6:amd64:
 libnx-xext6:amd64 depends on libnx-x11-6 (>= 3.5.0.29); however:
  Package libnx-x11-6:amd64 is not configured yet.
 libnx-x11-6:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1) breaks 
libnx-xext6 (<< 2:3.6.0.0) and is unpacked but not configured.
  Version of libnx-xext6:amd64 to be configured is 
2:3.5.0.33-0~687~ubuntu16.04.1.

dpkg: error processing package libnx-xext6:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnx-xinerama1:amd64:
 libnx-xinerama1:amd64 depends on libnx-x11-6 (>= 3.5.0.29); however:
  Package libnx-x11-6:amd64 is not configured yet.
 libnx-xinerama1:amd64 depends on libnx-xext6 (>= 3.5.0.29); however:
  Package libnx-xext6:amd64 is not configured yet.
 libnx-x11-6:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1) breaks 
libnx-xinerama1 (<< 2:3.6.0.0) and is unpacked but not configured.
  Version of libnx-xinerama1:amd64 to be configured is 
2:3.5.0.33-0~687~ubuntu16.04.1.

dpkg: error processing package libnx-xinerama1:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnx-xrender1:amd64:
 libnx-xrender1:amd64 depends on libnx-x11-6 (>= 3.5.0.29); however:
  Package libnx-x11-6:amd64 is not configured yet.
 libnx-x11-6:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1) breaks 
libnx-xrender1 (<< 2:3.6.0.0) and is unpacked but not configured.
  Version of libnx-xrender1:amd64 to be configured is 
2:3.5.0.33-0~687~ubuntu16.04.1.

dpkg: error processing package libnx-xrender1:amd64 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libnx-x11-6:amd64
 libnx-xdamage1:amd64
 libnx-xpm4:amd64
 libnx-xcomposite1:amd64
 libnx-xfixes3:amd64
 libnx-xrandr2:amd64
 libnx-xdmcp6:amd64
 libnx-xtst6:amd64
 libnx-xext6:amd64
 libnx-xinerama1:amd64
 libnx-xrender1:amd64


-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-
 Eskimo North Linux Friendly Internet Access, Shell Accounts, and Hosting.
   Knowledgeable human assistance, not telephone trees or script readers.
 See our web site: http://www.eskimo.com/ (206) 812-0051 or (800) 246-6874.

On Sun, 18 Sep 2016, Mike DePaulo wrote:

> Date: Sun, 18 Sep 2016 19:41:15 -0400
> From: Mike DePaulo <mikedep333@gmail.com>
> To: Robert Dinse <nanook@eskimo.com>, 1089@bugs.x2go.org
> Cc: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
> Subject: Re: [X2Go-Dev] Bug#1089: Bug#1089: Bug#1089: x2go Ubuntu 16.04 and
>     Fedora 24
> 
> On Sun, Sep 18, 2016 at 5:28 PM, Robert Dinse <nanook@eskimo.com> wrote:
>>
>>      Could you resend the URL, sorry I deleted.
>> [...]
> https://sunweavers.net/blog/node/46
>


Information forwarded to x2go-dev@lists.x2go.org, owner@bugs.x2go.org:
Bug#1089; Package x2server. (Mon, 19 Sep 2016 00:55:01 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mike DePaulo <mikedep333@gmail.com>:
Extra info received and forwarded to list. Copy sent to owner@bugs.x2go.org. (Mon, 19 Sep 2016 00:55:02 GMT) Full text and rfc822 format available.

Message #40 received at 1089@bugs.x2go.org (full text, mbox):

From: Mike DePaulo <mikedep333@gmail.com>
To: Robert Dinse <nanook@eskimo.com>
Cc: 1089@bugs.x2go.org, Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
Subject: Re: [X2Go-Dev] Bug#1089: Bug#1089: Bug#1089: x2go Ubuntu 16.04 and Fedora 24
Date: Sun, 18 Sep 2016 20:53:32 -0400
Robert,

Debian: deb http://packages.arctica-project.org/ubuntu {jessie,stretch,sid} main
Ubuntu: deb http://packages.arctica-project.org/ubuntu {trusty,xenial} main

These are apt repos, and they are meant to used that way, not
installed as downloaded .deb files.

I don't mean to be rude, but could you please start a thread on
x2go-user for help with installing them and recovering your system?

-Mike


Information forwarded to x2go-dev@lists.x2go.org, owner@bugs.x2go.org:
Bug#1089; Package x2server. (Mon, 19 Sep 2016 12:50:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mike DePaulo <mikedep333@gmail.com>:
Extra info received and forwarded to list. Copy sent to owner@bugs.x2go.org. (Mon, 19 Sep 2016 12:50:02 GMT) Full text and rfc822 format available.

Message #45 received at 1089@bugs.x2go.org (full text, mbox):

From: Mike DePaulo <mikedep333@gmail.com>
To: 1089@bugs.x2go.org
Subject: It works!
Date: Mon, 19 Sep 2016 08:46:23 -0400
FYI, as reported on x2go-user, the upgrade resolved Robert's issue:
> On Mon, Sep 19, 2016 at 1:50 AM, Robert Dinse <nanook@eskimo.com> wrote:
>>
>>      It mostly worked.  With x2goserver installed I can connect now with my
>> x2goclient and screen resizes properly.  Also in Mate,
>> System->Preferences->Hardware->Displays now works.


Information forwarded to x2go-dev@lists.x2go.org, owner@bugs.x2go.org:
Bug#1089; Package x2server. (Mon, 19 Sep 2016 19:50:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mike Gabriel <mike.gabriel@das-netzwerkteam.de>:
Extra info received and forwarded to list. Copy sent to owner@bugs.x2go.org. (Mon, 19 Sep 2016 19:50:02 GMT) Full text and rfc822 format available.

Message #50 received at 1089@bugs.x2go.org (full text, mbox):

From: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
To: Mike DePaulo <mikedep333@gmail.com>, 1089@bugs.x2go.org
Subject: Re: [X2Go-Dev] Bug#1089: It works!
Date: Mon, 19 Sep 2016 19:48:36 +0000
[Message part 1 (text/plain, inline)]
Control: fixed -1 3.5.99.1

On  Mo 19 Sep 2016 14:46:23 CEST, Mike DePaulo wrote:

> FYI, as reported on x2go-user, the upgrade resolved Robert's issue:
>> On Mon, Sep 19, 2016 at 1:50 AM, Robert Dinse <nanook@eskimo.com> wrote:
>>>
>>>      It mostly worked.  With x2goserver installed I can connect now with my
>>> x2goclient and screen resizes properly.  Also in Mate,
>>> System->Preferences->Hardware->Displays now works.

Marking this issue as fixed with next generation nx-libs.

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: mike.gabriel@das-netzwerkteam.de, http://das-netzwerkteam.de

[Message part 2 (application/pgp-signature, inline)]

Marked as fixed in versions 3.5.99.1. Request was from Mike Gabriel <mike.gabriel@das-netzwerkteam.de> to 1089-submit@bugs.x2go.org. (Mon, 19 Sep 2016 19:50:03 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Tue Dec 11 06:44:44 2018; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.