X2Go Bug report logs - #1006
Slow refresh with Chrome/Chromium

version graph

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Walid MOGHRABI <w.moghrabi@servicemagic.eu>

Date: Tue, 8 Mar 2016 08:55:02 UTC

Severity: normal

Found in version 4.0.5.0

Full log


🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#1006: Slow refresh with Chrome/Chromium
Reply-To: Walid MOGHRABI <w.moghrabi@servicemagic.eu>, 1006@bugs.x2go.org
Resent-From: Walid MOGHRABI <w.moghrabi@servicemagic.eu>
Resent-To: x2go-dev@lists.x2go.org
Resent-CC: X2Go Developers <x2go-dev@lists.x2go.org>
X-Loop: owner@bugs.x2go.org
Resent-Date: Tue, 08 Mar 2016 08:55:02 +0000
Resent-Message-ID: <handler.1006.B.145742707011465@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: report 1006
X-X2Go-PR-Package: x2goserver
X-X2Go-PR-Keywords: 
Received: via spool by submit@bugs.x2go.org id=B.145742707011465
          (code B); Tue, 08 Mar 2016 08:55:02 +0000
Received: (at submit) by bugs.x2go.org; 8 Mar 2016 08:51:10 +0000
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=0.8 required=3.0 tests=BAYES_50 autolearn=ham
	version=3.3.2
Received: from localhost (localhost [127.0.0.1])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id 9C34D5DA98
	for <submit@bugs.x2go.org>; Tue,  8 Mar 2016 09:51:08 +0100 (CET)
X-Virus-Scanned: Debian amavisd-new at ymir.das-netzwerkteam.de
Received: from ymir.das-netzwerkteam.de ([127.0.0.1])
	by localhost (ymir.das-netzwerkteam.de [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id RywrUtAvhKFb for <submit@bugs.x2go.org>;
	Tue,  8 Mar 2016 09:51:02 +0100 (CET)
Received: from zm-01.servicemagic.eu (zm-01.servicemagic.eu [176.31.236.17])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id 65FAA5DA97
	for <submit@bugs.x2go.org>; Tue,  8 Mar 2016 09:51:02 +0100 (CET)
Received: from localhost (localhost.localdomain [127.0.0.1])
	by zm-01.servicemagic.eu (Postfix) with ESMTP id 00E7B8073C54A
	for <submit@bugs.x2go.org>; Tue,  8 Mar 2016 09:51:02 +0100 (CET)
X-Amavis-Modified: Mail body modified (using disclaimer) -
	zm-01.servicemagic.eu
X-Virus-Scanned: amavisd-new at servicemagic.eu
Received: from zm-01.servicemagic.eu ([127.0.0.1])
	by localhost (zm-01.servicemagic.eu [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id woK9y+Z1a+ej for <submit@bugs.x2go.org>;
	Tue,  8 Mar 2016 09:51:01 +0100 (CET)
Received: from zm-01.servicemagic.eu (localhost.localdomain [127.0.0.1])
	by zm-01.servicemagic.eu (Postfix) with ESMTP id 8DE0380733855
	for <submit@bugs.x2go.org>; Tue,  8 Mar 2016 09:51:01 +0100 (CET)
Date: Tue, 8 Mar 2016 09:51:01 +0100 (CET)
From: Walid MOGHRABI <w.moghrabi@servicemagic.eu>
To: submit@bugs.x2go.org
Message-ID: <620416549.12115111.1457427061491.JavaMail.root@servicemagic.eu>
In-Reply-To: <814320414.10937760.1457025537138.JavaMail.root@servicemagic.eu>
MIME-Version: 1.0
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: 7bit
X-Originating-IP: [10.33.100.88]
X-Mailer: Zimbra 7.2.0_GA_2669 (ZimbraWebClient - GC49 (Linux)/7.2.0_GA_2669)
Package: x2goserver
Version: 4.0.5.0 

Context : x2goserver 4.0.5.0 on Ubuntu Mate 14.04 with x2go stable ppa in MATE Desktop mode.

Chrome and Chromium's refresh is painfully slow with x2go while Firefox is a lot smoother.
Most applications, even graphical intensive such as Gimp are working very smoohtly too, only Chrome/Chromium is really really slow.

Is there something that might be done on the x2go side ?
Maybe some custom options to use within Chrome/Chromium ?

With ps, here is the command line used with my chromium instance (default settings, nothing has been tuned) :

ps aux | grep chromium
walid    24977  2.4  8.0 1192724 163960 ?      Sl   09:42   0:01 chromium-browser --enable-pinch                          
walid    24988  1.3  3.3 657324 69196 ?        S    09:42   0:00 chromium-browser --type=zygote                          
walid    24990  0.0  0.6 657324 13360 ?        S    09:42   0:00 chromium-browser --type=zygote                          
walid    25032  2.7  5.8 1413712 118996 ?      Sl   09:42   0:01 /usr/lib/chromium-browser/chro                          
walid    25115  0.0  0.1  15208  2144 pts/0    S+   09:43   0:00 grep --color=auto chromium


Chrome/Chromium enables HW acceleration by default, I tried to disable it in order to see if that helps but it changed nothing.


Best regards,

Walid Moghrabi
	
---
DISCLAIMER: This e-mail is private and confidential and may contain proprietary or legally privileged information. It is for the intended recipient only. If you have received this email in error, please notify the author by replying to it and then destroy it. If you are not the intended recipient you must not use, disclose, distribute, copy, print or rely on this e-mail or any attachment. Thank you

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Mon Apr 22 22:19:51 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.