Subject: x2goclient x server crashes when launching gitk or git-gui

From: k75527552 <[email-masked]>
Date: Mon, 08 Feb 2016 14:34:34 +0100

Package: x2goclient
Version: 4.0.5.0

in windows 7/64 connecting to centos6.5 64
To reproduce: get a git repository, cd into it, launch git-gui

Problem signature:
  Problem Event Name:   APPCRASH
  Application Name:     vcxsrv.exe
  Application Version:  1.17.0.0
  Application Timestamp:        55b5056a
  Fault Module Name:    MSVCR120.dll
  Fault Module Version: 12.0.21005.1
  Fault Module Timestamp:       524f7ce6
  Exception Code:       c0000005
  Exception Offset:     0000f20c
  OS Version:   6.1.7601.2.1.0.256.48
  Locale ID:    1033
  Additional Information 1:     0a9e
  Additional Information 2:     0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:     0a9e
  Additional Information 4:     0a9e372d3b4ad19135b953a78882e789

---

From: Benjamin Shadwick <[email-masked]>
Date: Sat, 7 May 2016 12:09:16 -0700

I can confirm this issue occurs on Windows 10 x64 client with x2goclient
v4.0.5.0 and Ubuntu MATE 14.04 LTS x64 x2goserver host.

I'm currently testing it in "published applications" mode, in which I
started a MATE terminal and then ran 'git gui' from the terminal window.

VcXsrv crashes with a "VcXsrv windows xserver (X2Go/Arctica Builds) has
stopped working" dialog in Windows. All published application windows then
close, while x2goclient continues to run.

Resuming the session appears to restore all windows, including the git gui
window.