Subject: X2Go issue (in src:x2godesktopsharing) has been marked as closed

From: X2Go Release Manager <[email-masked]>
Date: Tue, 7 Jun 2016 03:28:08 +0200 (CEST)

close #993
thanks

Hello,

we are very hopeful that X2Go issue #993 reported by you
has been resolved in the new release (3.1.1.3) of the
X2Go source project »src:x2godesktopsharing«.

You can view the complete changelog entry of src:x2godesktopsharing (3.1.1.3)
below, and you can use the following link to view all the code changes
between this and the last release of src:x2godesktopsharing.

    http://code.x2go.org/gitweb?p=x2godesktopsharing.git;a=commitdiff;h=c1a5867c31f12a44a6dbbf9317ef44272399fa53;hp=3921c42b13af6a2bef5850c53b9baa420ba46351

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:x2godesktopsharing.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:x2godesktopsharing
Version: 3.1.1.3-0x2go1
Status: RELEASE
Date: Tue, 07 Jun 2016 03:12:53 +0200
Fixes: 905 936 993
Changes: 
 x2godesktopsharing (3.1.1.3-0x2go1) RELEASED; urgency=low
 .
   [ Mihai Moldovan ]
   * New upstream version (3.1.1.3):
     - x2godesktopsharing_zh_tw: rename to x2godesktopsharing_zh_tw.ts. Oops.
     - x2godesktopsharing.pro: also rename x2godesktopsharing_zh_tw in project
       file.
     - misc: fix X2GO => X2Go and add "Desktop" where missing. Fixes: #936.
     - sharetray.cpp: fix type issues while calculating time difference. Fixes:
       #993.
     - sharetray.cpp: post-fixup: include stdint.h to get (u)intXX_t types.
       Won't work on Windows, but the desktop sharing application isn't
       supposed to run on Windows anyway...
   * debian/control:
     - Drop libqt4-gui Depends. Already handled by shlibs and misc Depends.
       Fixes: #905.

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Tue, 07 Jun 2016 01:30:09 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2godesktopsharing package:

#993: gcc 6 compile error

It has been closed by X2Go Release Manager <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact X2Go Release Manager <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:x2godesktopsharing) has been marked as closed
From: X2Go Release Manager <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Tue, 7 Jun 2016 03:28:08 +0200 (CEST)

close #993
thanks

Hello,

light+love

---

Subject: gcc 6 compile error
From: Orion Poplawski <[email-masked]>
To: [email-masked]
Date: Sat, 6 Feb 2016 14:01:08 -0700

Package: x2godesktopsharing
Version: 3.1.1.2

x2godesktopsharing fails to compile with gcc 6 with:

sharetray.cpp: In constructor 'ShareTray::ShareTray()':
sharetray.cpp:97:46: error: call of overloaded 'abs(uint)' is ambiguous
       QDateTime::currentDateTime().toTime_t() ) <5 )
                                               ^
In file included from /usr/include/c++/6.0.0/cstdlib:75:0,
                  from /usr/include/c++/6.0.0/bits/stl_algo.h:59,
                  from /usr/include/c++/6.0.0/algorithm:62,
                  from /usr/include/QtCore/qglobal.h:68,
                  from /usr/include/QtCore/qnamespace.h:45,
                  from /usr/include/QtCore/qobjectdefs.h:45,
                  from /usr/include/QtGui/qwindowdefs.h:45,
                  from /usr/include/QtGui/qwidget.h:46,
                  from /usr/include/QtGui/qmainwindow.h:45,
                  from /usr/include/QtGui/QMainWindow:1,
                  from sharetray.h:14,
                  from sharetray.cpp:12:
/usr/include/stdlib.h:774:12: note: candidate: int abs(int)
  extern int abs (int __x) __THROW __attribute__ ((__const__)) __wur;
             ^~~
In file included from /usr/include/c++/6.0.0/bits/stl_algo.h:59:0,
                  from /usr/include/c++/6.0.0/algorithm:62,
                  from /usr/include/QtCore/qglobal.h:68,
                  from /usr/include/QtCore/qnamespace.h:45,
                  from /usr/include/QtCore/qobjectdefs.h:45,
                  from /usr/include/QtGui/qwindowdefs.h:45,
                  from /usr/include/QtGui/qwidget.h:46,
                  from /usr/include/QtGui/qmainwindow.h:45,
                  from /usr/include/QtGui/QMainWindow:1,
                  from sharetray.h:14,
                  from sharetray.cpp:12:
/usr/include/c++/6.0.0/cstdlib:180:3: note: candidate: long long int 
std::abs(long long int)
    abs(long long __x) { return __builtin_llabs (__x); }
    ^~~
/usr/include/c++/6.0.0/cstdlib:172:3: note: candidate: long int 
std::abs(long int)
    abs(long __i) { return __builtin_labs(__i); }
    ^~~

The attached patch casts the result to an int.

-- 
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA, Boulder/CoRA Office             FAX: 303-415-9702
3380 Mitchell Lane                       [email-masked]
Boulder, CO 80301                   http://www.nwra.com
diff -up x2godesktopsharing-3.1.1.2/sharetray.cpp.time x2godesktopsharing-3.1.1.2/sharetray.cpp
--- x2godesktopsharing-3.1.1.2/sharetray.cpp.time	2015-03-05 21:11:16.000000000 -0700
+++ x2godesktopsharing-3.1.1.2/sharetray.cpp	2016-02-06 13:57:28.437811687 -0700
@@ -93,8 +93,8 @@ ShareTray::ShareTray()
 			{
 				QString line = in.readLine();
 				file.close();
-				if ( abs ( line.toUInt() -
-					QDateTime::currentDateTime().toTime_t() ) <5 )
+				if ( abs ( int ( line.toUInt() -
+					QDateTime::currentDateTime().toTime_t() ) ) <5 )
 					{
 
 					QString message=QString (