Subject: x2goclient can't create session file in Chinese-language computer

From: Antonio Gurgel <[email-masked]>
Date: Thu, 21 Jan 2016 15:47:39 -0500

Package: x2goclient
Version: 4.0.5.0
Platform: Win 8.1 x64 (zh_CN langset)

I had a user come in who was unable to connect to our X2Go server. This 
is the output from the client:

Loop: PANIC! Can't create directory '/cygdrive/C/Users/.../S-51. Error is 2 'No such file or directory'.
Error: Can't create directory '/cygdrive/C/Users/.../S-51. Error is 2 'No such file or directory'.
Loop: PANIC! Cannot determine directory of NX session file.
Error: Cannot determine directory of NX session file.
Session: Session terminated at 'Wed Jan 20 14:39:00 2016'.

The user folder consists of four Latin characters followed by several 
Chinese ones, the latter of which were ignored by X2Go -- the path named 
in the error only contained Latin characters.

-- 
Antonio Gurgel
Sysadmin, Computer Science and Engineering
Michigan State University
Room 3358, 428 S. Shaw Lane, 48824
517 355 9318

---

From: 刘少睿 <[email-masked]>
Date: Tue, 18 Dec 2018 12:02:03 +0800 (GMT+08:00)

We got the same error on windows 10.
Then we tried to run x2go as administrator, also got error, “…cannot run translator…”, but not the same error.
So we did this:
Right click  My PC -  Manage – Local Users and Groups – Users – Administrator
Right click – properties – disable “Account is disabled”
At last, changed to Administrator account to run x2goclient, it worked well.
 
It is a windows permission issue!

---

From: Shaorui Liu <[email-masked]>
Date: Tue, 18 Dec 2018 03:51:25 +0000

发送自 Windows 10 版邮件<https://go.microsoft.com/fwlink/?LinkId=550986>应用