Subject: Bug#976: error on login to ubuntu/debian -> stdin: is not a tty

From: ura soul <[email-masked]>
Date: Mon, 21 Dec 2015 21:24:01 +0000

Package: x2goserver
Version: 4.0.1.19-0~1064~ubuntu14.04.1

description: after installing a fresh OS template to a
server that runs OpenVZ and then installing x2goserver
and also a GUI (tested all of these: XFCE/MATE/GNOME) - i

logged in remotely via x2goclient and saw the error in a popup:

stdin: is not a tty

this also occurs for me using some other OSs in the same

environment.

i have searched online and only found reference to this error

in the context of standard console SSH connections, not to

x2go connections.

---

From: Ulrich Sibiller <[email-masked]>
Date: Wed, 6 Jan 2016 20:58:14 +0100

This is probably due to an ssh call not using -t. 

Vom Smartphone gesendet.

----- Ursprüngliche Nachricht -----
Von: "ura soul" <[email-masked]>
Gesendet: ‎06.‎01.‎2016 20:38
An: "[email-masked]" <[email-masked]>
Betreff: [X2Go-Dev] Bug#976: error on login to ubuntu/debian -> stdin: is nota tty

Package: x2goserver Version: 4.0.1.19-0~1064~ubuntu14.04.1description: after installing a fresh OS template to aserver that runs OpenVZ and then installing x2goserver and also a GUI (tested all of these: XFCE/MATE/GNOME) - i logged in remotely via x2goclient and saw the error in a popup:stdin: is not a ttythis also occurs for me using some other OSs in the sameenvironment.i have searched online and only found reference to this errorin the context of standard console SSH connections, not to x2go connections.

---

From: Stefan Baur <[email-masked]>
Date: Wed, 6 Jan 2016 21:08:49 +0100

Am 06.01.2016 um 20:58 schrieb Ulrich Sibiller:
[stdin: is not a tty]
> This is probably due to an ssh call not using -t.

Or maybe something in .bashrc expecting a tty?

- -Stefan

- -- 
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243

---

From: Mihai Moldovan <[email-masked]>
Date: Fri, 3 Nov 2017 17:25:49 +0100

Control: reassign -1 x2goclient 4.1.1.0
Control: tag -1 not-a-bug
Control: close -1

Closing this bugreport as not a bug.

X2Go Client has seen some changes in the past, including spawning login shells,
which means that more shell startup scripts are executed now.

If these don't check for interactivity correctly and happen to run programs that
write to stderr in case of non-interactivity, connections will fail, since
stderr is extensively used for error detection by x2goclient.

Mihai

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Fri, 03 Nov 2017 16:30:03 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goclient package:

#976: error on login to ubuntu/debian -> stdin: is not a tty

It has been closed by Mihai Moldovan <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mihai Moldovan <[email-masked]> by
replying to this email.

-- 
976: http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=976
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: Re: [X2Go-Dev] error on login to ubuntu/debian -> stdin: is not a tty
From: Mihai Moldovan <[email-masked]>
To: ura soul <[email-masked]>, [email-masked]
Date: Fri, 3 Nov 2017 17:25:49 +0100

Mihai

Subject: error on login to ubuntu/debian -> stdin: is not a tty
From: ura soul <[email-masked]>
To: [email-masked]
Date: Mon, 21 Dec 2015 21:24:01 +0000

Package: x2goserver

stdin: is not a tty

environment.

x2go connections.