Subject: Bug#973: X2Go issue (in src:x2goclient) has been marked as pending for release

From: David Laxer <[email-masked]>
Date: Wed, 13 Jan 2016 01:07:46 -0800

David-Laxers-MacBook-Pro:x2goclient davidlaxer$ git pull
remote: Counting objects: 840, done.
remote: Compressing objects: 100% (232/232), done.
remote: Total 828 (delta 678), reused 727 (delta 596)
Receiving objects: 100% (828/828), 105.20 KiB | 151.00 KiB/s, done.
Resolving deltas: 100% (678/678), completed with 10 local objects.
From git://code.x2go.org/x2goclient
   faf5f02..eeab8aa  master     -> origin/master
 + 067ad34...148803d bugfix/osx -> origin/bugfix/osx  (forced update)
Updating faf5f02..eeab8aa
Fast-forward
 debian/changelog     |  10 +++
 src/onmainwindow.cpp | 174 +++++++++++++++++++++++++++++++++++++++++----------
 src/onmainwindow.h   |   1 +
 x2goclient.pro       |   2 +-
 4 files changed, 154 insertions(+), 33 deletions(-)

$ ./macbuild.sh 

***
*** Cleaning...
***

rm -fr /Users/davidlaxer/x2goclient/client_build
rm -fr /Users/davidlaxer/x2goclient/plugin_build
make -f Makefile.man2html clean
rm -Rf .build_man2html
find . -maxdepth 3 -name '*.o' -exec rm -vf {} + -type f
find . -maxdepth 3 -name 'moc_*.cpp' -exec rm -vf {} + -type f
find . -maxdepth 3 -name 'ui_*.h' -exec rm -vf {} + -type f
find . -maxdepth 3 -name 'qrc_*.cpp' -exec rm -vf {} + -type f
rm -f x2goclient
rm -f x2goclient.tag
rm -f res/txt/changelog
rm -f res/txt/git-info
~/x2goclient/client_build ~/x2goclient

***
*** Running lrelease...
***

Project MESSAGE: if you want to build x2goplugin you should export X2GO_CLIENT_TARGET=pluginProject MESSAGE: Configuring with --git-infoProject MESSAGE: Configuring with --changelogProject MESSAGE: building x2goclient x2goplugin with ldap and cupsUpdating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_de.qm'...
    Generated 568 translation(s) (568 finished and 0 unfinished)
Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_da.qm'...
    Generated 568 translation(s) (568 finished and 0 unfinished)
Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_es.qm'...
    Generated 564 translation(s) (564 finished and 0 unfinished)
    Ignored 4 untranslated source text(s)
Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_et.qm'...
    Generated 564 translation(s) (564 finished and 0 unfinished)
    Ignored 4 untranslated source text(s)
Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_fi.qm'...
    Generated 568 translation(s) (568 finished and 0 unfinished)
Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_fr.qm'...
    Generated 252 translation(s) (199 finished and 53 unfinished)
    Ignored 316 untranslated source text(s)
Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_nb_no.qm'...
    Generated 568 translation(s) (568 finished and 0 unfinished)
Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_nl.qm'...
    Generated 568 translation(s) (566 finished and 2 unfinished)
Warning: dropping duplicate messages in '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_pt.qm':

* Context: EditConnectionDialog
* Source: &Session

Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_pt.qm'...
    Generated 0 translation(s) (0 finished and 0 unfinished)
    Ignored 568 untranslated source text(s)
Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_ru.qm'...
    Generated 554 translation(s) (545 finished and 9 unfinished)
    Ignored 14 untranslated source text(s)
Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_sv.qm'...
    Generated 568 translation(s) (568 finished and 0 unfinished)
Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_tr.qm'...
    Generated 566 translation(s) (566 finished and 0 unfinished)
Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_zh_tw.qm'...
    Generated 395 translation(s) (370 finished and 25 unfinished)
    Ignored 173 untranslated source text(s)

***
*** Running qmake...
***

Project MESSAGE: if you want to build x2goplugin you should export X2GO_CLIENT_TARGET=plugin
Project MESSAGE: Configuring with --git-info
Project MESSAGE: Configuring with --changelog
Project MESSAGE: building x2goclient with ldap and cups

***
*** Running make...
***

/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_de.ts
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_da.ts
Updating '../res/i18n/x2goclient_de.qm'...
    Generated 568 translation(s) (568 finished and 0 unfinished)
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_es.ts
Updating '../res/i18n/x2goclient_da.qm'...
    Generated 568 translation(s) (568 finished and 0 unfinished)
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_et.ts
Updating '../res/i18n/x2goclient_es.qm'...
    Generated 564 translation(s) (564 finished and 0 unfinished)
    Ignored 4 untranslated source text(s)
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_fi.ts
Updating '../res/i18n/x2goclient_et.qm'...
    Generated 564 translation(s) (564 finished and 0 unfinished)
    Ignored 4 untranslated source text(s)
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_fr.ts
Updating '../res/i18n/x2goclient_fi.qm'...
Updating '../res/i18n/x2goclient_fr.qm'...
    Generated 568 translation(s) (568 finished and 0 unfinished)
    Generated 252 translation(s) (199 finished and 53 unfinished)
    Ignored 316 untranslated source text(s)
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_nb_no.ts
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_nl.ts
Updating '../res/i18n/x2goclient_nb_no.qm'...
    Generated 568 translation(s) (568 finished and 0 unfinished)
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_pt.ts
Updating '../res/i18n/x2goclient_nl.qm'...
    Generated 568 translation(s) (566 finished and 2 unfinished)
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_ru.ts
Warning: dropping duplicate messages in '../res/i18n/x2goclient_pt.qm':

* Context: EditConnectionDialog
* Source: &Session

Updating '../res/i18n/x2goclient_pt.qm'...
    Generated 0 translation(s) (0 finished and 0 unfinished)
    Ignored 568 untranslated source text(s)
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_sv.ts
Updating '../res/i18n/x2goclient_ru.qm'...
    Generated 554 translation(s) (545 finished and 9 unfinished)
    Ignored 14 untranslated source text(s)
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_tr.ts
Updating '../res/i18n/x2goclient_sv.qm'...
    Generated 568 translation(s) (568 finiUpdating '../res/i18n/x2goclient_tr.qm'...
shed and 0 unfinished)
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_zh_tw.ts
    Generated 566 translation(s) (566 finished and 0 unfinished)
Updating '../res/i18n/x2goclient_zh_tw.qm'...
    Generated 395 translation(s) (370 finished and 25 unfinished)
    Ignored 173 untranslated source text(s)
/Users/davidlaxer/anaconda/bin/uic ../src/ui/cupsprintsettingsdialog.ui -o ui_cupsprintsettingsdialog.h
/Users/davidlaxer/anaconda/bin/uic ../src/ui/cupsprintwidget.ui -o ui_cupsprintwidget.h
/Users/davidlaxer/anaconda/bin/uic ../src/ui/printdialog.ui -o ui_printdialog.h
/Users/davidlaxer/anaconda/bin/uic ../src/ui/printercmddialog.ui -o ui_printercmddialog.h
/Users/davidlaxer/anaconda/bin/uic ../src/ui/printwidget.ui -o ui_printwidget.h
/Users/davidlaxer/anaconda/bin/uic ../src/ui/xsettingsui.ui -o ui_xsettingsui.h
/Users/davidlaxer/anaconda/bin/uic ../src/ui/brokerpassdialog.ui -o ui_brokerpassdialog.h
/Users/davidlaxer/anaconda/bin/uic ../src/ui/contest.ui -o ui_contest.h
/Users/davidlaxer/anaconda/bin/uic ../src/ui/appdialog.ui -o ui_appdialog.h
/Users/davidlaxer/anaconda/bin/uic ../src/ui/helpdialog.ui -o ui_helpdialog.h
/Users/davidlaxer/anaconda/bin/uic ../src/ui/folderexplorer.ui -o ui_folderexplorer.h
g++ -c -pipe -stdlib=libstdc++ -O2 -arch x86_64 -Xarch_x86_64 -mmacosx-version-min=10.5 -arch i386 -Wall -W -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.7.sdk -DCFGCLIENT -DQT_NO_DEBUG -DQT_SVG_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I../../anaconda/mkspecs/macx-g++ -I../../x2goclient -I../../anaconda/include/QtCore -I../../anaconda/include/QtNetwork -I../../anaconda/include/QtGui -I../../anaconda/include/QtSvg -I../../anaconda/include -I../src -I/opt/local/include -I. -I. -I../../x2goclient -I. -o sharewidget.o ../src/sharewidget.cpp
g++ -c -pipe -stdlib=libstdc++ -O2 -arch x86_64 -Xarch_x86_64 -mmacosx-version-min=10.5 -arch i386 -Wall -W -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.7.sdk -DCFGCLIENT -DQT_NO_DEBUG -DQT_SVG_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I../../anaconda/mkspecs/macx-g++ -I../../x2goclient -I../../anaconda/include/QtCore -I../../anaconda/include/QtNetwork -I../../anaconda/include/QtGui -I../../anaconda/include/QtSvg -I../../anaconda/include -I../src -I/opt/local/include -I. -I. -I../../x2goclient -I. -o settingswidget.o ../src/settingswidget.cpp
g++: error: unrecognized command line option '-stdlib=libstdc++'
g++: error: unrecognized command line option '-stdlib=libstdc++'
g++: error: unrecognized command line option '-Xarch_x86_64'
g++: error: unrecognized command line option '-Xarch_x86_64'
make: *** [settingswidget.o] Error 1
make: *** Waiting for unfinished jobs....
make: *** [sharewidget.o] Error 1
David-Laxers-MacBook-Pro:x2goclient davidlaxer$ 

> On Jan 12, 2016, at 11:29 PM, Mihai Moldovan <[email-masked]> wrote:
> 
> tag #973 pending
> fixed #973 4.0.5.1
> thanks
> 
> Hello,
> 
> X2Go issue #973 (src:x2goclient) reported by you has been
> fixed in X2Go Git. You can see the changelog below, and you can
> check the diff of the fix at:
> 
>    http://code.x2go.org/gitweb?p=x2goclient.git;a=commitdiff;h=eeab8aa
> 
> The issue will most likely be fixed in src:x2goclient (4.0.5.1).
> 
> light+love
> X2Go Git Admin (on behalf of the sender of this mail)
> 
> ---
> commit eeab8aa47e9964eb02712cd073acc6199062b3b6
> Author: Mihai Moldovan <[email-masked]>
> Date:   Wed Jan 13 07:06:50 2016 +0100
> 
>    x2goclient.pro: fix typo --stdlib=... -> -stdlib=... Fixes: #973.
> 
> diff --git a/debian/changelog b/debian/changelog
> index 92a3d0e..c788481 100644
> --- a/debian/changelog
> +++ b/debian/changelog
> @@ -16,6 +16,7 @@ x2goclient (4.0.5.1-0x2go1) UNRELEASED; urgency=low
>       unknown and undefined errors.
>     - onmainwindow.{cpp,h}: don't use a hardcoded path to xmodmap on OS X and
>       handle errors more gracefully. Fixes: #487.
> +    - x2goclient.pro: fix typo --stdlib=... -> -stdlib=... Fixes: #973.
> 
>   [ Oleksandr Shneyder ]
>   * New upstream release (4.0.5.1):

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Wed, 13 Jan 2016 09:40:03 +0000

Thank you for the additional information you have supplied regarding
this Bug report.

This is an automatically generated reply to let you know your message
has been received.

Your message has not been forwarded to the package maintainers or
other interested parties; you should ensure that the developers are
aware of the problem you have entered into the system - preferably
quoting the Bug reference number, #973.

If you wish to submit further information on this problem, please
send it to [email-masked].

Please do not send mail to [email-masked] unless you wish
to report a problem with the Bug-tracking system.

-- 
973: http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=973
X2Go Bug Tracking System
Contact [email-masked] with problems

---

From: Mihai Moldovan <[email-masked]>
Date: Wed, 13 Jan 2016 18:43:53 +0100

On 13.01.2016 10:07 AM, David Laxer wrote:
> g++ -c -pipe -stdlib=libstdc++ -O2 -arch x86_64 -Xarch_x86_64 -mmacosx-version-min=10.5 -arch i386 -Wall -W -isysroot
> /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.7.sdk -DCFGCLIENT
> -DQT_NO_DEBUG -DQT_SVG_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I../../anaconda/mkspecs/macx-g++
> -I../../x2goclient -I../../anaconda/include/QtCore -I../../anaconda/include/QtNetwork -I../../anaconda/include/QtGui
> -I../../anaconda/include/QtSvg -I../../anaconda/include -I../src -I/opt/local/include -I. -I. -I../../x2goclient -I. -o
> settingswidget.o ../src/settingswidget.cpp

Like I said, these errors stem from a wrong compiler. Please check what I've written in my previous mail.

Mihai

---

From: Mihai Moldovan <[email-masked]>
Date: Wed, 13 Jan 2016 19:23:12 +0100

On 13.01.2016 06:52 PM, David Laxer wrote:
> Yep.  It’s getting the Macports one first:
> 
> David-Laxers-MacBook-Pro:~ davidlaxer$ whereis g++
> /usr/bin/g++
> David-Laxers-MacBook-Pro:~ davidlaxer$ which g++
> /opt/local/bin/g++

And that's exactly the problem. You'll need to edit PATH to (temporarily) to not prefer the MacPorts prefix.

echo "$PATH"

With this information, re-arrange the values like so:

PATH=/usr/bin:/usr/sbin:...:/opt/local/bin:/opt/local/sbin ./macbuild.sh

Where "..." means anything you have in-between. If you also have /opt/local/libexec/gnubin in there, move it before
/opt/local/bin.

Mihai