Subject: X2Go Client Build Issue(s) on Mac

From: David Laxer <[email-masked]>
Date: Mon, 21 Dec 2015 07:17:20 -0800

Package: X2Go Client
Version:  4.0.5.0

I’m trying to build X2GoClient from source and the ./macbuild.sh has build errors:

g++: error: unrecognized command line option '--stdlib=libstdc++'
g++: error: unrecognized command line option '-Xarch_x86_64'
g++: error: unrecognized command line option '--stdlib=libstdc++'
g++: error: unrecognized command line option '-Xarch_x86_64'

E.g. - macbuild.sh  (w/ set +x)

./macbuild.sh 
+ MATCH_HELP='(^((-h)|(--help))([ 	]|$))|([ 	]+((-h)|(--help))([ 	]|$))'
+ '[' -n '' ']'
+ NAME=x2goclient
++ dirname ./macbuild.sh
+ TOP_DIR=.
+ [[ . == /* ]]
+ TOP_DIR=/Users/davidlaxer/x2goclient/.
+ BUILD_DIR=/Users/davidlaxer/x2goclient/./client_build
+ APPBUNDLE=/Users/davidlaxer/x2goclient/./client_build/x2goclient.app
+ DMGFILE=/Users/davidlaxer/x2goclient/./client_build/x2goclient.dmg
+ PROJECT=/Users/davidlaxer/x2goclient/./x2goclient.pro
+ PKG_DMG=/Users/davidlaxer/x2goclient/./pkg-dmg
++ which nxproxy
+ NXPROXY=/opt/local/bin/nxproxy
+ : /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.7.sdk
+ : 10.7
+ : 0
+ : 1
+ : 1
++ make_boolean 0
++ OPTION=0
++ case "${OPTION}" in
++ OPTION=0
++ printf 0
+ DEBUG=0
++ make_boolean 1
++ OPTION=1
++ case "${OPTION}" in
++ OPTION=1
++ printf 1
+ BUNDLE=1
++ make_boolean 1
++ OPTION=1
++ case "${OPTION}" in
++ OPTION=1
++ printf 1
+ UNIVERSAL=1
+ '[' 0 -eq 0 ']'
+ BUILD_MODE=release
+ BUILD_ARCH=x86_64
+ '[' 1 -eq 1 ']'
+ BUILD_ARCH='x86_64 x86'
++ /usr/bin/perl -pe 's#.*?10\.(\d+).*?\.sdk$#\1#'
+ SDK_MINOR_VERSION=7
+ MATCH_NUMBERS='^[0-9]+$'
+ [[ 7 =~ ^[0-9]+$ ]]
+ '[' 7 -gt 6 ']'
+ STDLIB=libstdc++
+ '[' 7 -gt 8 ']'
+ set -e
+ phase Cleaning
+ echo

+ echo '***'
***
+ echo '*** Cleaning...'
*** Cleaning...
+ echo '***'
***
+ echo

+ make clean
rm -fr /Users/davidlaxer/x2goclient/client_build
rm -fr /Users/davidlaxer/x2goclient/plugin_build
make -f Makefile.man2html clean
rm -Rf .build_man2html
find . -maxdepth 3 -name '*.o' -exec rm -vf {} + -type f
find . -maxdepth 3 -name 'moc_*.cpp' -exec rm -vf {} + -type f
find . -maxdepth 3 -name 'ui_*.h' -exec rm -vf {} + -type f
find . -maxdepth 3 -name 'qrc_*.cpp' -exec rm -vf {} + -type f
rm -f x2goclient
rm -f x2goclient.tag
rm -f res/txt/changelog
rm -f res/txt/git-info
+ git --no-pager log --since '2 years ago' '--format=%ai %aN (%h) %n%n%x09*%w(68,0,10) %s%d%n'
+ mv ChangeLog.gitlog res/txt/git-info
+ cp -a debian/changelog res/txt/
+ '[' -e /Users/davidlaxer/x2goclient/./client_build ']'
+ mkdir /Users/davidlaxer/x2goclient/./client_build
+ pushd /Users/davidlaxer/x2goclient/./client_build
~/x2goclient/client_build ~/x2goclient
+ phase 'Running lrelease'
+ echo

+ echo '***'
***
+ echo '*** Running lrelease...'
*** Running lrelease...
+ echo '***'
***
+ echo

+ lrelease /Users/davidlaxer/x2goclient/./x2goclient.pro
Project MESSAGE: if you want to build x2goplugin you should export X2GO_CLIENT_TARGET=pluginProject MESSAGE: Configuring with --git-infoProject MESSAGE: Configuring with --changelogProject MESSAGE: building x2goclient x2goplugin with ldap and cupsUpdating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_de.qm'...
    Generated 568 translation(s) (568 finished and 0 unfinished)
Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_da.qm'...
    Generated 568 translation(s) (568 finished and 0 unfinished)
Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_es.qm'...
    Generated 564 translation(s) (564 finished and 0 unfinished)
    Ignored 4 untranslated source text(s)
Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_et.qm'...
    Generated 564 translation(s) (564 finished and 0 unfinished)
    Ignored 4 untranslated source text(s)
Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_fi.qm'...
    Generated 568 translation(s) (568 finished and 0 unfinished)
Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_fr.qm'...
    Generated 252 translation(s) (199 finished and 53 unfinished)
    Ignored 316 untranslated source text(s)
Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_nb_no.qm'...
    Generated 568 translation(s) (568 finished and 0 unfinished)
Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_nl.qm'...
    Generated 568 translation(s) (566 finished and 2 unfinished)
Warning: dropping duplicate messages in '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_pt.qm':

* Context: EditConnectionDialog
* Source: &Session

Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_pt.qm'...
    Generated 0 translation(s) (0 finished and 0 unfinished)
    Ignored 568 untranslated source text(s)
Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_ru.qm'...
    Generated 554 translation(s) (545 finished and 9 unfinished)
    Ignored 14 untranslated source text(s)
Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_sv.qm'...
    Generated 568 translation(s) (568 finished and 0 unfinished)
Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_tr.qm'...
    Generated 566 translation(s) (566 finished and 0 unfinished)
Updating '/Users/davidlaxer/x2goclient/res/i18n/x2goclient_zh_tw.qm'...
    Generated 395 translation(s) (370 finished and 25 unfinished)
    Ignored 173 untranslated source text(s)
+ MACPORTS_PREFIX=/opt/local
+ phase 'Running qmake'
+ echo

+ echo '***'
***
+ echo '*** Running qmake...'
*** Running qmake...
+ echo '***'
***
+ echo

+ qmake -config release -spec macx-g++ /Users/davidlaxer/x2goclient/./x2goclient.pro 'CONFIG+=x86_64 x86' QMAKE_MAC_SDK=/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.7.sdk QMAKE_MACOSX_DEPLOYMENT_TARGET=10.7 OSX_STDLIB=libstdc++ MACPORTS_INCLUDE_PATH=/opt/local/include MACPORTS_LIBRARY_PATH=/opt/local/lib
Project MESSAGE: if you want to build x2goplugin you should export X2GO_CLIENT_TARGET=plugin
Project MESSAGE: Configuring with --git-info
Project MESSAGE: Configuring with --changelog
Project MESSAGE: building x2goclient with ldap and cups
+ phase 'Running make'
+ echo

+ echo '***'
***
+ echo '*** Running make...'
*** Running make...
+ echo '***'
***
+ echo

+ make -j2
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_de.ts
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_da.ts
Updating '../res/i18n/x2goclient_de.qm'...
    Generated 568 translation(s) (568 finished and 0 unfinished)
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_es.ts
Updating '../res/i18n/x2goclient_da.qm'...
    Generated 568 translation(s) (568 finished and 0 unfinished)
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_et.ts
Updating '../res/i18n/x2goclient_es.qm'...
    Generated 564 translation(s) (564 finished and 0 unfinished)
    Ignored 4 untranslated source text(s)
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_fi.ts
Updating '../res/i18n/x2goclient_et.qm'...
    Generated 564 translation(s) (564 finished and 0 unfinished)
    Ignored 4 untranslated source text(s)
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_fr.ts
Updating '../res/i18n/x2goclient_fi.qm'...
    Generated 568 translation(s) (568 finished and 0 unfinished)
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_nb_no.ts
Updating '../res/i18n/x2goclient_fr.qm'...
    Generated 252 translation(s) (199 finished and 53 unfinished)
    Ignored 316 untranslated source text(s)
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_nl.ts
Updating '../res/i18n/x2goclient_nb_no.qm'...
    Generated 568 translation(s) (568 finished and 0 unfinished)
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_pt.ts
Updating '../res/i18n/x2goclient_nl.qm'...
    Generated 568 translation(s) (566 finished and 2 unfinished)
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_ru.ts
Warning: dropping duplicate messages in '../res/i18n/x2goclient_pt.qm':

* Context: EditConnectionDialog
* Source: &Session

Updating '../res/i18n/x2goclient_pt.qm'...
    Generated 0 translation(s) (0 finished and 0 unfinished)
    Ignored 568 untranslated source text(s)
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_sv.ts
Updating '../res/i18n/x2goclient_ru.qm'...
Updating '../res/i18n/x2goclient_sv.qm'...
    Generated 554 translation(s) (545 finished and 9 unfinished)
    Ignored 14 untranslated source text(s)
    Generated 568 translation(s) (568 finished and 0 unfinished)
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_tr.ts
/Users/davidlaxer/anaconda/bin/lrelease ../res/i18n/x2goclient_zh_tw.ts
Updating '../res/i18n/x2goclient_tr.qm'...
    Generated 566 translation(s) (566 finished and 0 unfinished)
Updating '../res/i18n/x2goclient_zh_tw.qm'...
    Generated 395 translation(s) (370 finished and 25 unfinished)
    Ignored 173 untranslated source text(s)
/Users/davidlaxer/anaconda/bin/uic ../src/ui/cupsprintsettingsdialog.ui -o ui_cupsprintsettingsdialog.h
/Users/davidlaxer/anaconda/bin/uic ../src/ui/cupsprintwidget.ui -o ui_cupsprintwidget.h
/Users/davidlaxer/anaconda/bin/uic ../src/ui/printdialog.ui -o ui_printdialog.h
/Users/davidlaxer/anaconda/bin/uic ../src/ui/printercmddialog.ui -o ui_printercmddialog.h
/Users/davidlaxer/anaconda/bin/uic ../src/ui/printwidget.ui -o ui_printwidget.h
/Users/davidlaxer/anaconda/bin/uic ../src/ui/xsettingsui.ui -o ui_xsettingsui.h
/Users/davidlaxer/anaconda/bin/uic ../src/ui/brokerpassdialog.ui -o ui_brokerpassdialog.h
/Users/davidlaxer/anaconda/bin/uic ../src/ui/contest.ui -o ui_contest.h
/Users/davidlaxer/anaconda/bin/uic ../src/ui/appdialog.ui -o ui_appdialog.h
/Users/davidlaxer/anaconda/bin/uic ../src/ui/helpdialog.ui -o ui_helpdialog.h
/Users/davidlaxer/anaconda/bin/uic ../src/ui/folderexplorer.ui -o ui_folderexplorer.h
g++ -c -pipe --stdlib=libstdc++ -O2 -arch x86_64 -Xarch_x86_64 -mmacosx-version-min=10.5 -arch i386 -Wall -W -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.7.sdk -DCFGCLIENT -DQT_NO_DEBUG -DQT_SVG_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I../../anaconda/mkspecs/macx-g++ -I../../x2goclient -I../../anaconda/include/QtCore -I../../anaconda/include/QtNetwork -I../../anaconda/include/QtGui -I../../anaconda/include/QtSvg -I../../anaconda/include -I../src -I/opt/local/include -I. -I. -I../../x2goclient -I. -o sharewidget.o ../src/sharewidget.cpp
g++ -c -pipe --stdlib=libstdc++ -O2 -arch x86_64 -Xarch_x86_64 -mmacosx-version-min=10.5 -arch i386 -Wall -W -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.7.sdk -DCFGCLIENT -DQT_NO_DEBUG -DQT_SVG_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I../../anaconda/mkspecs/macx-g++ -I../../x2goclient -I../../anaconda/include/QtCore -I../../anaconda/include/QtNetwork -I../../anaconda/include/QtGui -I../../anaconda/include/QtSvg -I../../anaconda/include -I../src -I/opt/local/include -I. -I. -I../../x2goclient -I. -o settingswidget.o ../src/settingswidget.cpp
g++: error: unrecognized command line option '--stdlib=libstdc++'
g++: error: unrecognized command line option '-Xarch_x86_64'
g++: error: unrecognized command line option '--stdlib=libstdc++'
g++: error: unrecognized command line option '-Xarch_x86_64'
make: *** [settingswidget.o] Error 1
make: *** Waiting for unfinished jobs....
make: *** [sharewidget.o] Error 1
David-Laxers-MacBook-Pro:x2goclient davidlaxer$ ./macbuild.sh

---

From: Mihai Moldovan <[email-masked]>
Date: Wed, 13 Jan 2016 06:58:53 +0100

> g++: error: unrecognized command line option '-Xarch_x86_64'

These errors likely mean that you're trying to use a compiler different from what is in the Command Line Tools as
shipped by Apple.

Try "type g++" in the terminal to determine which location g++ is taken from by your shell. Ideally it should be
/usr/bin/g++, but in your case I bet it's not. You will probably need to edit PATH in order to correct that problem.

(Also, I actually have a typo in the build process. --stdlib=... should be -stdlib. clang does seem to accept both,
though, while GCC likely chokes on it, being a ported clang feature. I'll correct this with the next commit to master.)

Mihai