Subject: APPCRASH of x2goclient under Windows 7 when trying to close application

From: [email-masked]
Date: Sat, 21 Nov 2015 11:14:05 +0100

Package: x2goclient
Version: 4.0.5.0

When trying to close the x2goclient.exe an APPCRASH appears.
Windows Operating System throws error message "x2goclient.exe funktioniert 
nicht mehr" saying application is not working any more. 

I assume  the Appcrash is related to the installed NVIDIA Drivers. 

I further tried the latest binaries of x2goclient.exe (version 
4.0.5.1-2015.10.23-1d9c4ab) but error behavior is still the same as 
decribed above.

My System configuration is as follows:

- Windows7 Professional SP1
- 64-Bit OS
- Intel Core i7
- NVIDIA Driver Version 312.69
- x2go Server runs on Debian 7
- x2go client setting are defaults

Here is the complete Windows Error Message:

Problemsignatur:
  Problemereignisname:  APPCRASH
  Anwendungsname:       x2goclient.exe
  Anwendungsversion:    0.0.0.0
  Anwendungszeitstempel:        055cb1d0
  Fehlermodulname:      nvinit.dll_unloaded
  Fehlermodulversion:   0.0.0.0
  Fehlermodulzeitstempel:       526ed802
  Ausnahmecode: c0000005
  Ausnahmeoffset:       755ace69
  Betriebsystemversion: 6.1.7601.2.1.0.256.48
  Gebietsschema-ID:     1031
  Zusatzinformation 1:  0a9e
  Zusatzinformation 2:  0a9e372d3b4ad19135b953a78882e789
  Zusatzinformation 3:  0a9e
  Zusatzinformation 4:  0a9e372d3b4ad19135b953a78882e789

Lesen Sie unsere Datenschutzbestimmungen online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0407

Wenn die Onlinedatenschutzbestimmungen nicht verfügbar sind, lesen Sie 
unsere Datenschutzbestimmungen offline:
  C:\windows\system32\de-DE\erofflps.txt

Is this a known bug?

Mit freundlichen Grüßen - Best Regards - Distinti Saluti - Sincères 
salutations 
Marcel Köhler 
Marcel Köhler  |   Schneider Electric  |   Industry Business  |   Machine 
Solutions  |   Senior Engineer Servo Drives HW 
Phone: +49 9391 606 3381  |   Fax: +49 9391 606 4000 
Email: [email-masked]  |   Site: 
www.schneider-electric.com  |   Address: Schneider Electric Automation 
GmbH, Schneiderplatz 1, 97828 Marktheidenfeld - Germany 
Additional Info: Sitz der Gesellschaft: Marktheidenfeld | Handelsregister: 
Amtsgericht Würzburg (HRB 10733), USt-IdNr. DE 261529553 | 
Geschäftsführer: Thomas Martis, Ottmar Himmelsbach
                              
**** Please consider the environment before printing this e-mail ****

---

From: Stefan Baur <[email-masked]>
Date: Tue, 24 Nov 2015 12:10:25 +0100

Matthias,

could this be the reason why you are seeing crashes on your machine, too
?

Kind Regards,
Stefan Baur

Am 21.11.2015 um 11:14 schrieb [email-masked]:
> Package: x2goclient Version: 4.0.5.0
> 
> Windows Operating System throws error message "x2goclient.exe 
> funktioniert nicht mehr" saying application is not working any
> more.
> 
> 4.0.5.1-2015.10.23-1d9c4ab) but error behavior is still the same
> as decribed above.
> 
> - Windows7 Professional SP1 - 64-Bit OS - Intel Core i7 - NVIDIA
> Driver Version 312.69 - x2go Server runs on Debian 7 - x2go client
> setting are defaults
> 
> *Problemsignatur:* Problemereignisname:        APPCRASH 
> Anwendungsname:        x2goclient.exe Anwendungsversion:
> 0.0.0.0 Anwendungszeitstempel:        055cb1d0 Fehlermodulname:
> nvinit.dll_unloaded Fehlermodulversion:        0.0.0.0 
> Fehlermodulzeitstempel:        526ed802 Ausnahmecode:
> c0000005 Ausnahmeoffset:        755ace69 Betriebsystemversion:
> 6.1.7601.2.1.0.256.48 Gebietsschema-ID:        1031 
> Zusatzinformation 1:        0a9e Zusatzinformation 2:
> 0a9e372d3b4ad19135b953a78882e789 Zusatzinformation 3:        0a9e 
> *Lesen Sie unsere Datenschutzbestimmungen online:* *
> *_http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0407_
> 
> Wenn die Onlinedatenschutzbestimmungen nicht verfügbar sind, lesen
> Sie unsere Datenschutzbestimmungen offline: 
> _C:\windows\system32\de-DE\erofflps.txt_
> 
> Is this a known bug?
> 
> Mit freundlichen Grüßen - Best Regards - Distinti Saluti -
> Sincères salutations Marcel Köhler 
> ----------------------------------------------------------------------
- --
*Marcel**Köhler* |   *Schneider Electric* |   *Industry Business* |
> *Machine Solutions* |   *Senior Engineer Servo Drives HW** Phone:
> *+49 9391 606 3381 |   *Fax: *+49 9391 606 4000* Email:
> [email-masked] 
> <mailto:[email-masked]> |   *Site: 
> *_www.schneider-electric.com_ <http://www.schneider-electric.com/>
> | *Address: *Schneider Electric Automation GmbH, Schneiderplatz 1,
> 97828 Marktheidenfeld - Germany * Additional Info: *Sitz der
> Gesellschaft: Marktheidenfeld | Handelsregister: Amtsgericht
> Würzburg (HRB 10733), USt-IdNr. DE 261529553 | Geschäftsführer:
> Thomas Martis, Ottmar Himmelsbach_ 
> _<http://www.facebook.com/SchneiderElectric> 
> <http://www.linkedin.com/company/schneider-electric> 
> <http://tv.schneider-electric.com/site/schneidertv/index.cfm?args=ww/e
n>
>  <http://www.twitter.com/SchneiderElec> 
> <http://www.youtube.com/schneidercorporate> 
> <http://blog.schneider-electric.com/> **** Please consider the
> environment before printing this e-mail ****
> 
> 
> _______________________________________________ x2go-dev mailing
> list [email-masked] 
> http://lists.x2go.org/listinfo/x2go-dev
> 

- -- 
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243

---

From: Summer Matthias <[email-masked]>
Date: Tue, 24 Nov 2015 11:37:58 +0000

Hi

Thanks for the informations. This is the reason why my client crashes. I have the same error-message in the windows eventviewer.

Kind Regrads
Matthias

> -----Ursprüngliche Nachricht-----
> Von: Stefan Baur [mailto:[email-masked]]
> Gesendet: Dienstag, 24. November 2015 12:10
> An: [email-masked]; [email-masked]; Summer
> Matthias <[email-masked]>
> Betreff: Re: [X2Go-Dev] Bug#967: APPCRASH of x2goclient under Windows 7
> when trying to close application
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA256
> 
> Matthias,
> 
> could this be the reason why you are seeing crashes on your machine, too ?
> 
> Kind Regards,
> Stefan Baur
> 
> > funktioniert nicht mehr" saying application is not working any more.
> >
> > salutations Marcel Köhler
> > Gesellschaft: Marktheidenfeld | Handelsregister: Amtsgericht Würzburg
> > (HRB 10733), USt-IdNr. DE 261529553 | Geschäftsführer:
> > _______________________________________________ x2go-dev mailing list
> > [email-masked] http://lists.x2go.org/listinfo/x2go-dev
> >
> 
> 
> - --
> Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364 Fon/Fax 0731
> 40 34 66-36/-35 | USt-IdNr.: DE268653243 -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v2
> 
> iQEcBAEBCAAGBQJWVEWhAAoJEG7d9BjNvlEZsz8H/3fgMBgzr2VQfGuHAE1s
> xati
> dlkPANxT52bOQp5bs4bRV9/POMwi6AzGr5eNDok11JxxcCrWzkwNxW+5+oXA2
> 8t9
> 2zwDbsH8AC6OILaRSBjY2ZzzURUSCa2CMrgHn8jyrFWT/mfqX+BD4cvilH/fBySf
> 7jrwSm+neob56LHa4YwpXXcJyvfwsWv6gxdYiJ3xDH7MDajTOcwE74h9T+5AQn
> O1
> cZv4V/a/YrLGvFv4qa7UgZbhTi03gU5R5WM52C1pLFjaH1kCCJoci97QywxFhaEt
> exEv7nosPzo1giNUZh2fwKiguf2MftUpdmaF9Fyib58GZw25wbHiz+edRyXxvBs=
> =Fu69
> -----END PGP SIGNATURE-----