Subject: Bug#956: gnome-terminal closes right after start

From: Summer Matthias <[email-masked]>
Date: Mon, 12 Oct 2015 07:01:15 +0000

Package: x2go-client
Version: 4.0.5.0

When useing gnome-terminal as an application to start a session, gnome-terminal pops up and close right after start.

Logentry in /var/log/messages:

Oct 12 08:53:49 adzh-srlp-en14 /usr/bin/x2gostartagent: successfully started X2Go agent session with ID msummer-53-1444632828_stRgnome-terminal_dp32
Oct 12 08:53:54 adzh-srlp-en14 /usr/bin/x2gomountdirs[12498]: successfully mounted [email-masked]:30014/cygdrive/C/Users/MSummer/X2GO~1/S-MSUM~2/spool to /tmp/.x2go-msummer/spool/C-msummer-53-1444632828_stRgnome-terminal_dp32
Oct 12 08:53:56 adzh-srlp-en14 /usr/bin/x2gosetkeyboard: Setting X keyboard according to /home/msummer/.x2go/C-msummer-53-1444632828_stRgnome-terminal_dp32/keyboard
Oct 12 08:53:57 adzh-srlp-en14 /usr/bin/x2goumount-session[12770]: successfully unmounted "/tmp/.x2go-msummer/spool/C-msummer-53-1444632828_stRgnome-terminal_dp32"

On serverside we run RHEL 7.1, x2goserver-4.0.1.19-1.el7.x86_64 and x2goagent-3.5.0.29-1.el7.x86_64.

Matthias Summer
Senior System Engineer
-------------------------------------------------
Adcubum AG
Zürcherstrasse 464
CH-9015 St. Gallen

Zentrale         +41 58 411 66 66
Direktwahl      +41 58 411 68 13
Mobile           +41 79 101 35 58
[email-masked]<mailto:[email-masked]>
www.adcubum.com<http://www.adcubum.com/>

---

From: Stefan Baur <[email-masked]>
Date: Mon, 12 Oct 2015 13:03:25 +0200

Is this gnome-terminal 3.16, by any chance?

If yes, then this is a duplicate of Bug #878:

http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=878

Kind Regards,
Stefan Baur

- -- 
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243

---

From: Summer Matthias <[email-masked]>
Date: Tue, 13 Oct 2015 06:52:18 +0000

> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA256
> 

We are running gnome 3.8.1.

> http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=878

Look's like the same bug.

> Stefan Baur

Kind Regrads
Matthias Summer

---

From: Stefan Baur <[email-masked]>
Date: Thu, 15 Oct 2015 13:35:31 +0200

> Look's like the same bug.

Merged accordingly.
Note that we are assuming you are only running into this issue when
choosing single-application mode.

Please try the following workaround:
Choose "Published Applications"
- ->Start gnome-terminal from there.

If this fixes the issue for you, you can run gnome-terminal
automatically right after logging in to your PubApp session by using
the --autostart parameter:
- --autostart=<app> 	 launch "app" by session start in "published
applications" mode

Please let us know whether this helps or not.

Kind Regards,
Stefan Baur

- --