Subject: Bug#95: x2gothinclient_create x2go_tce_install.sh: line 60: syntax error near unexpected token `fi'

From: Thomas Guettler <[email-masked]>
Date: Wed, 02 Jan 2013 16:11:48 +0100

Package:x2gothinclientmanagement
Version: 1.0.1.6-0~281~lucid1

running ubuntu 12.04

x2gothinclient_create

...
The following NEW packages will be installed:
   patch
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 122 kB of archives.
After this operation, 250 kB of additional disk space will be used.
Get:1 http://ftp.debian.org/debian/ squeeze/main patch i386 2.6-2 [122 kB]
Fetched 122 kB in 0s (412 kB/s)
Selecting previously deselected package patch.
(Reading database ... 22727 files and directories currently installed.)
Unpacking patch (from .../archives/patch_2.6-2_i386.deb) ...
Processing triggers for man-db ...
Setting up patch (2.6-2) ...
/x2go_tce_install.sh: line 60: syntax error near unexpected token `fi'
/x2go_tce_install.sh: line 60: `[ $? -eq 0 ] && if getent passwd x2gothinclient 1>/dev/null; adduser --system 
--disabled-password --disabled-login --shell /bin/bash --group --home /var/lib/x2gothinclient x2gothinclient; fi'

-- 
Thomas Guettler, http://www.tbz-pariv.de/
Bernsdorfer Str. 210-212, 09126 Chemnitz, Tel.: 0371/5347-917
TBZ-PARIV GmbH  Geschäftsführer: Dr. Reiner Wohlgemuth
Sitz der Gesellschaft: Chemnitz Registergericht: Chemnitz HRB 8543

---

From: Mike Gabriel <[email-masked]>
Date: Thu, 03 Jan 2013 16:09:47 +0100

tag #95 pending
thanks

Hi Thomas,

On Mi 02 Jan 2013 16:11:48 CET Thomas Guettler wrote:

> /x2go_tce_install.sh: line 60: `[ $? -eq 0 ] && if getent passwd  
> x2gothinclient 1>/dev/null; adduser --system --disabled-password  
> --disabled-login --shell /bin/bash --group --home  
> /var/lib/x2gothinclient x2gothinclient; fi'

Thanks for spotting this. Fixed in upstream Vcs-Git:
http://code.x2go.org/gitweb?p=x2gothinclient.git;a=commitdiff;h=719d5615fb68c4a7480364e429687d844578199f

Greets,
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, rothenstein 5, 24214 neudorf-bornstein
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb