Subject: x2goagent: no such file or directory [OpenSuse 13.2]

From: Fabien Feschet <[email-masked]>
Date: Tue, 22 Sep 2015 15:35:59 +0200

Package: x2goserver
Severity: high
because makes x2go failed with opensuse

Detailed information using zypper info

Information for package x2goserver:
-----------------------------------
Repository: x2go
Name: x2goserver
Version: 4.0.1.19-1.1
Arch: x86_64
Vendor: obs://build.opensuse.org/X11
Installed: Yes
Status: up-to-date
Installed Size: 235.7 KiB

+] Recently had an update in OpenSuse in the NX components
+] When starting from a remote client using X2go Client (Windows), an
error occured (NX terminated at stage 7)

All was correctly working before NX upgrade, same machines, same OS
version, same X2Go Client and Server version.

What I have found is an error in the session log:
++++++++++++++++++++++++++++++++
/usr/bin/x2goagent: ligne29: /usr/lib/nx/../x2go/bin/x2goagent: no such
file...

+] My understanding of the problem:
=========================
I use OpenSuse x86_64 and NX libs are in /usr/lib64/nx not in
/usr/lib/nx so the used path is incorrect.

The x2goagent script in (/usr/bin) contains:
=============================
NXAPP=x2goagent
NX_LIBS=/usr/lib/nx
NX_LOCAL_LIBS=/usr/local/lib/nx

test -x $NX_LOCAL_LIBS/../x2go/bin/$NXAPP && export NX_LIBS=$NX_LOCAL_LIBS
test -x $NX_LIBS/../x2go/bin/$NXAPP && export NX_LIBS=$NX_LIBS

exec $NX_LIBS/../x2go/bin/$NXAPP "$@"

+] Correction:
X2GO has files in /usr/lib64/x2go (only perl script) and files in
/usr/lib/x2go
NX has all files in /usr/lib64/nx

So trying to replace NX_LIBS definition by
NX_LIBS=/usr/lib64/nx

is a first step but the path in x2goagent is still invalid since it now
points into /usr/lib64 where no x2go executables reside...

So have to change the complete path...

+] Solution (partial)
=============
# FF (2015) dir modified since in x86_64 lib64 is used instead !
NX_LIBS=/usr/lib64/nx

# FF (2015) problem since part of X2go is in /usr/lib and part in /usr/lib64
test -x /usr/lib/x2go/bin/$NXAPP && export NX_LIBS=$NX_LIBS

exec /usr/lib/x2go/bin/$NXAPP "$@"

+] Status
=======
X2go now works but shared directory does not ! I do not know if it is
related to specific problem on OpenSuse due to the recent update of NX.
This is due to a problem in a perl file (message on the client !) which
is missing, still trying to understand this other problem...
With above correction x2go works again.

Best regards,
Fabien Feschet

---

From: Mihai Moldovan <[email-masked]>
Date: Fri, 25 Sep 2015 18:45:54 +0200

Control: close -1
Control: severity -1 normal

> Information for package x2goserver:
[...]

The OBS stuff is outdated and not maintained by us. Please do not use it.

Closing this bug.

If you can reproduce it with our repository, feel free to reopen it.

Mihai