Subject: x2goagent should create /tmp/.X11-unix directory

From: Mike Gabriel <[email-masked]>
Date: Wed, 19 Dec 2012 09:20:41 +0100

Package: x2goagent
Severity: normal

----- Weitergeleitete Nachricht von [email-masked] -----
      Datum: Wed, 19 Dec 2012 08:57:53 +0100
        Von: [email-masked]
    Betreff: [X2Go-User] RHEL6 package should create /tmp/.X11-unix directory
         An: [email-masked]

Hi all,

After much hunting I found what the problem was runnung x2goserver on  
a freshly installed server.

Apparently X2Go requires the /tmp/.X11-unix directory to exist with  
permissions 1777.

Could you please see to it the creation of this directory and the  
permissions settings are performed by teh x2goserver package.

Thanks,

Burnce
_______________________________________________
X2Go-User mailing list
[email-masked]
https://lists.berlios.de/mailman/listinfo/x2go-user

----- Ende der weitergeleiteten Nachricht -----

-- 

DAS-NETZWERKTEAM
mike gabriel, rothenstein 5, 24214 neudorf-bornstein
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Orion Poplawski <[email-masked]>
Date: Wed, 19 Dec 2012 07:49:53 -0700

On 12/19/2012 01:20 AM, Mike Gabriel wrote:
>
> After much hunting I found what the problem was runnung x2goserver on a
> freshly installed server.
>

I would add that on systems running vncserver, /tmp/.X11-unix may exist 
but owned by another user.  It would be good if x2goserver fixed 
ownership in this case.

-- 
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA/CoRA Division                    FAX: 303-415-9702
3380 Mitchell Lane                  [email-masked]
Boulder, CO 80301              http://www.cora.nwra.com

---

From: Mike Gabriel <[email-masked]>
Date: Wed, 19 Dec 2012 17:07:04 +0100

Hi Orion,

On Mi 19 Dez 2012 15:49:53 CET Orion Poplawski wrote:

> I would add that on systems running vncserver, /tmp/.X11-unix may  
> exist but owned by another user.  It would be good if x2goserver  
> fixed ownership in this case.

What ownership would expect? root:root?

Asks
Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

---

From: Reinhard Tartler <[email-masked]>
Date: Wed, 19 Dec 2012 17:14:31 +0100

> permissions settings are performed by teh x2goserver package.

At least in debian, this directory is created by the init script of
the x11-common package. Maybe x2goserver should explicitly depend on
that package.

I'm not sure what the equivalent package is in RedHat/Fedora, but it
clearly seems to be a packaging issue to me.

-- 
regards,
    Reinhard

---

From: Orion Poplawski <[email-masked]>
Date: Wed, 19 Dec 2012 09:32:50 -0700

> clearly seems to be a packaging issue to me.

On Fedora it is created via systemd's tmpfiles mechanism, and in fact provided 
by the systemd package so it will be on all machines.

I'm using it on a RHEL6 server with no native/local X server.  The X server 
itself will create the directory if it doesn't exist, but will abort if it 
already exists but with the wrong owner or permissions.

-- 
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA, Boulder Office                  FAX: 303-415-9702
3380 Mitchell Lane                       [email-masked]
Boulder, CO 80301                   http://www.nwra.com

---

From: Reinhard Tartler <[email-masked]>
Date: Wed, 19 Dec 2012 20:47:54 +0100

On Wed, Dec 19, 2012 at 5:32 PM, Orion Poplawski <[email-masked]> wrote:
> On Fedora it is created via systemd's tmpfiles mechanism, and in fact
> provided by the systemd package so it will be on all machines.
>

Are you absolutely sure that the X server binary creates this itself?
Or is that some startup script shipped as part of the X server
package?

-- 
regards,
    Reinhard

---

From: Orion Poplawski <[email-masked]>
Date: Wed, 19 Dec 2012 13:14:58 -0700

> Or is that some startup script shipped as part of the X server

While many scripts are there to create it (and make sure it has the proper 
permissions, SELinux labels, etc), running the X server directly will create 
the directory as well.

---

From: Jan Engelhardt <[email-masked]>
Date: Sun, 6 Jan 2013 19:40:13 +0100 (CET)

On Wednesday 2012-12-19 17:07, Mike Gabriel wrote:
>> I would add that on systems running vncserver, /tmp/.X11-unix may exist but
>> owned by another user.  It would be good if x2goserver fixed ownership in this
>> case.
>

Precisely that.