Subject: Final img setup.py fix

From: Orion Poplawski <[email-masked]>
Date: Tue, 12 Feb 2013 13:52:32 -0700

Version: 0.4.0.0
Tags: patch

I've attached a patch to fix the installation of the needed img directory, 
that got messed up copying from the windows part is seems.

It appears to install and run okay with this.

-- 
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA, Boulder Office                  FAX: 303-415-9702
3380 Mitchell Lane                       [email-masked]
Boulder, CO 80301                   http://www.nwra.com
diff --git a/setup.py b/setup.py
index c4d045f..eabb468 100755
--- a/setup.py
+++ b/setup.py
@@ -173,7 +173,7 @@ elif platform.system() == 'Linux':
     )
 
     icon_files = datafilelist('{prefix}/share/icons/PyHoca'.format(prefix=sys.prefix), r'icons_symlinked/PyHoca')
-    img_files = [("{prefix}/share/img".format(prefix=sys.prefix), glob(r'img\\*.*'))]
+    img_files = [("{prefix}/share/pyhoca/img".format(prefix=sys.prefix), glob('img/*.*'))]
     desktop_files = [
         ('{prefix}/share/applications'.format(prefix=sys.prefix), glob('desktop/*')),
         ('{prefix}/share/pixmaps'.format(prefix=sys.prefix), glob('pixmaps/*.svg')),

---

From: Mike Gabriel <[email-masked]>
Date: Tue, 12 Feb 2013 22:17:14 +0100

On Di 12 Feb 2013 21:52:32 CET Orion Poplawski wrote:

> Version: 0.4.0.0
> Tags: patch
>
> I've attached a patch to fix the installation of the needed img  
> directory, that got messed up copying from the windows part is seems.
>

Thanks for spotting. Committed!
http://code.x2go.org/gitweb?p=pyhoca-gui.git;a=commitdiff;h=440c0c8b9587707e85c87f1cd606d2feeba84260

Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, rothenstein 5, 24214 neudorf-bornstein
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Orion Poplawski <[email-masked]>
Date: Tue, 12 Feb 2013 14:23:19 -0700

> http://code.x2go.org/gitweb?p=pyhoca-gui.git;a=commitdiff;h=440c0c8b9587707e85c87f1cd606d2feeba84260

You're not fixing the glob() args.  With your version I end up with an empty 
directory.

---

From: Mike Gabriel <[email-masked]>
Date: Wed, 13 Feb 2013 05:56:12 +0100

Hi Orion

>> http://code.x2go.org/gitweb?p=pyhoca-gui.git;a=commitdiff;h=440c0c8b9587707e85c87f1cd606d2feeba84260

Now, this should do it...
http://code.x2go.org/gitweb?p=pyhoca-gui.git;a=commitdiff;h=f6a4c0af7740b348ea34d2e4d091940c4302c93f

Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

---

From: Orion Poplawski <[email-masked]>
Date: Wed, 13 Feb 2013 09:13:35 -0700

> http://code.x2go.org/gitweb?p=pyhoca-gui.git;a=commitdiff;h=f6a4c0af7740b348ea34d2e4d091940c4302c93f

Looks good.  Feel free to close this bug.