X2Go Bug report logs - #914
X2Go Logout Issue with Mate on Centos7

version graph

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Robert Dinse <nanook@eskimo.com>

Date: Wed, 5 Aug 2015 19:25:02 UTC

Severity: normal

Found in version 4.0.1.19-3.el7

Full log


🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#914: Logout issues, solution [CenOS 7]
Reply-To: Alfi Galfi <gafi127001@gmail.com>, 914@bugs.x2go.org
Resent-From: Alfi Galfi <gafi127001@gmail.com>
Resent-To: x2go-dev@lists.x2go.org
Resent-CC: X2Go Developers <x2go-dev@lists.x2go.org>
X-Loop: owner@bugs.x2go.org
Resent-Date: Thu, 14 Apr 2016 16:30:01 +0000
Resent-Message-ID: <handler.914.B914.14606511847111@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: followup 914
X-X2Go-PR-Package: x2goserver
X-X2Go-PR-Keywords: 
Received: via spool by 914-submit@bugs.x2go.org id=B914.14606511847111
          (code B ref 914); Thu, 14 Apr 2016 16:30:01 +0000
Received: (at 914) by bugs.x2go.org; 14 Apr 2016 16:26:24 +0000
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=0.7 required=3.0 tests=BAYES_50,DKIM_SIGNED,
	DKIM_VALID,DKIM_VALID_AU,FREEMAIL_FROM,HTML_MESSAGE autolearn=ham
	version=3.3.2
Received: from localhost (localhost [127.0.0.1])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id 57AD45DA9D
	for <914@bugs.x2go.org>; Thu, 14 Apr 2016 18:26:22 +0200 (CEST)
X-Virus-Scanned: Debian amavisd-new at ymir.das-netzwerkteam.de
Received: from ymir.das-netzwerkteam.de ([127.0.0.1])
	by localhost (ymir.das-netzwerkteam.de [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id IYlkpm8ldGe4 for <914@bugs.x2go.org>;
	Thu, 14 Apr 2016 18:26:15 +0200 (CEST)
Received: from mail-wm0-f44.google.com (mail-wm0-f44.google.com [74.125.82.44])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id 552575DA97
	for <914@bugs.x2go.org>; Thu, 14 Apr 2016 18:26:15 +0200 (CEST)
Received: by mail-wm0-f44.google.com with SMTP id a140so155092497wma.0
        for <914@bugs.x2go.org>; Thu, 14 Apr 2016 09:26:15 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=gmail.com; s=20120113;
        h=mime-version:date:message-id:subject:from:to;
        bh=nU6gJrR+uZnJ49+STjydUL9S4Bp0wAjw5Wu0tdKR/mg=;
        b=ra7naAdSkLuTC5O3AYR72ql29ZUXPS01t8bmUGf6SJk+l2WpnwASbIv1cvYOhSRL/3
         ptHbVEhGi8M2zhB2LMgLDKYuzn0HoSmK61tk803dTpMIPPvvtDEi2WYj4ObAeW7qzs1C
         byOfli9PxYEp8mGqyywN/mAlQDG5ZpMuuLtlHAOuPvMDN4SEBQofIzRQ87JEv/SHG9Q2
         v8DM9uJHyNDbYlJg/LE0uF3rugTgIfI+A0aorzGF7CYNc1ELa5JScSvu3rWcDRgVbT3K
         B7oIt2LiGIC7t/Xg5/UvRR87J3fkhns7PhFYs13hhHP5GWB/EIFNw5fow4ssUGtMONj/
         Gp0w==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=1e100.net; s=20130820;
        h=x-gm-message-state:mime-version:date:message-id:subject:from:to;
        bh=nU6gJrR+uZnJ49+STjydUL9S4Bp0wAjw5Wu0tdKR/mg=;
        b=RGNewTb/nMNg/3606KuwmKXeYSadauQwS+KJQ2JsLRM+tWA0G1hLptRcUjfeEuo+4C
         9TxqoNhrRDrrNg5ieG/ijQRE9HmApaiRqlnlEXGmOJ5h8QEwlVwZBmo6d1EUbMYCf+8O
         IdimX8Z45zbmtVYv8yxRGqm6NjAIVqYlk+jzT2Sg9nzY03A/7jMx4dYwzH2EO11GheFp
         rSAhsnbGE3GbCcZJJ86EwmHsTkHVzHSMqve/Z/3YJoTLdJDHZgFqjLSVNH8z0Ib7TWL5
         Fl/Ub/SLFZvb6HdTdPv23C1+GXl9RmNnqe3IS+QVkizRGUTVU0C3sXEkGn/C7aPziC+Y
         58YA==
X-Gm-Message-State: AOPr4FVLBIkhO6l4ws+H7SKapzjGNpAKaCNneq9YAj/DK6130z5NWMYvqKl7HWgZm91dHEVl/2IPXUEvoVAoDA==
MIME-Version: 1.0
X-Received: by 10.194.63.8 with SMTP id c8mr17402454wjs.89.1460651174945; Thu,
 14 Apr 2016 09:26:14 -0700 (PDT)
Received: by 10.194.114.138 with HTTP; Thu, 14 Apr 2016 09:26:14 -0700 (PDT)
Date: Thu, 14 Apr 2016 18:26:14 +0200
Message-ID: <CAH=z5in8uKWJS7VJN7CerMsfEjw6uNWW8MAtxaPF3F3mtP-i2Q@mail.gmail.com>
From: Alfi Galfi <gafi127001@gmail.com>
To: 914@bugs.x2go.org
Content-Type: multipart/alternative; boundary=047d7b86cd2a6c703d0530745a19
[Message part 1 (text/plain, inline)]
Hello
Anything new regarding to this issue? I'm using:
x2goserver-4.0.1.19-6.el7.x86_64

list of mate packages:
 rpm -qa|grep mate
mate-menus-libs-1.10.0-1.el7.x86_64
mate-system-log-1.10.3-1.el7.x86_64
mate-calc-1.8.0-1.el7.x86_64
libmateweather-1.10.0-1.el7.x86_64
mate-session-manager-1.10.2-2.el7.x86_64
mate-applets-1.10.3-1.el7.x86_64
mate-screenshot-1.10.3-1.el7.x86_64
libmateweather-data-1.10.0-1.el7.noarch
mate-notification-daemon-1.10.2-1.el7.x86_64
mate-polkit-1.10.2-1.el7.x86_64
mate-control-center-1.10.2-2.el7.x86_64
mate-desktop-1.10.2-1.el7.x86_64
mate-themes-1.12.0-1.el7.noarch
mate-media-1.10.0-2.el7.x86_64
mate-dictionary-1.10.3-1.el7.x86_64
mate-screensaver-1.10.2-4.el7.x86_64
mate-desktop-libs-1.10.2-1.el7.x86_64
mate-menus-1.10.0-1.el7.x86_64
libmatekbd-1.10.0-1.el7.x86_64
mate-panel-1.10.1-1.el7.x86_64
libmatemixer-1.10.0-1.el7.x86_64
mate-terminal-1.10.1-2.el7.x86_64
mate-system-monitor-1.10.1-1.el7.x86_64
mate-search-tool-1.10.3-1.el7.x86_64
mate-backgrounds-1.10.0-1.el7.noarch
mate-control-center-filesystem-1.10.2-2.el7.x86_64
mate-panel-libs-1.10.1-1.el7.x86_64
mate-utils-common-1.10.3-1.el7.noarch
mate-power-manager-1.10.2-3.el7.x86_64
mate-disk-usage-analyzer-1.10.3-1.el7.x86_64
mate-icon-theme-1.10.1-1.el7.noarch
mate-settings-daemon-1.10.2-2.el7.x86_64
mate-menus-preferences-category-menu-1.10.0-1.el7.x86_64

logout works fine when I don't have any application open. But when I try to
logout without closing for example firefox logout process freeze. I don't
see panels and for example file manager, but can still operate inside of
firefox which doesn't have bars, so it's look like not all application are
closed by logout process (I can see firefox process running to). To
completely close the sesion still clicking on terminate in x2go client
window is needed. Logout process directly on server works fine. Problem
only occur during x2go connection.
I wanted to try mentioned workaround but it's not working or I get it wrong
(I moved /usr/bin/mate-session to another file and create new
/usr/bin/mate-session file with rx permissions to everybody containing
short script from Message #94). After that I see only black screen after
login and:
"/usr/bin/mate-session: fork: retry: No child processes
/usr/bin/mate-session: fork: retry: No child processes
/usr/bin/mate-session: fork: retry: No child processes
/usr/bin/mate-session: fork: retry: No child processes
/usr/bin/mate-session: fork: Resource temporarily unavailable"
in log file. Anybody is able to help with this?
[Message part 2 (text/html, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Thu Aug 6 10:58:17 2020; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.