X2Go Bug report logs - #914
X2Go Logout Issue with Mate on Centos7

version graph

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Robert Dinse <nanook@eskimo.com>

Date: Wed, 5 Aug 2015 19:25:02 UTC

Severity: normal

Found in version 4.0.1.19-3.el7

Full log


🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#914: Fwd: Re: [X2Go-User] x2go on RHEL7/CentOS7
Reply-To: Stefan Baur <X2Go-ML-1@baur-itcs.de>, 914@bugs.x2go.org
Resent-From: Stefan Baur <X2Go-ML-1@baur-itcs.de>
Resent-To: x2go-dev@lists.x2go.org
Resent-CC: X2Go Developers <x2go-dev@lists.x2go.org>
X-Loop: owner@bugs.x2go.org
Resent-Date: Wed, 05 Aug 2015 20:45:01 +0000
Resent-Message-ID: <handler.914.B914.143880727814592@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: followup 914
X-X2Go-PR-Package: x2goserver
X-X2Go-PR-Keywords: 
Received: via spool by 914-submit@bugs.x2go.org id=B914.143880727814592
          (code B ref 914); Wed, 05 Aug 2015 20:45:01 +0000
Received: (at 914) by bugs.x2go.org; 5 Aug 2015 20:41:18 +0000
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=-1.9 required=5.0 tests=BAYES_00,URIBL_BLOCKED
	autolearn=ham version=3.3.2
X-Greylist: delayed 300 seconds by postgrey-1.34 at ymir.das-netzwerkteam.de; Wed, 05 Aug 2015 22:41:14 CEST
Received: from mout.kundenserver.de (mout.kundenserver.de [212.227.126.131])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id CC9B03BC49
	for <914@bugs.x2go.org>; Wed,  5 Aug 2015 22:41:14 +0200 (CEST)
Received: from [192.168.0.171] ([134.3.38.213]) by mrelayeu.kundenserver.de
 (mreue005) with ESMTPSA (Nemesis) id 0MYrDT-1ZIHvy0vAZ-00VdOH; Wed, 05 Aug
 2015 22:36:13 +0200
References: <alpine.LRH.2.11.1508051455040.5922@entry.nmr.mgh.harvard.edu>
To: 914@bugs.x2go.org, "x2go-user@lists.x2go.org" <x2go-user@lists.x2go.org>
From: Stefan Baur <X2Go-ML-1@baur-itcs.de>
X-Forwarded-Message-Id: <alpine.LRH.2.11.1508051455040.5922@entry.nmr.mgh.harvard.edu>
Message-ID: <55C273B1.3010707@baur-itcs.de>
Date: Wed, 5 Aug 2015 22:36:01 +0200
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101
 Thunderbird/38.1.0
MIME-Version: 1.0
In-Reply-To: <alpine.LRH.2.11.1508051455040.5922@entry.nmr.mgh.harvard.edu>
Content-Type: multipart/signed; micalg=pgp-sha256;
 protocol="application/pgp-signature";
 boundary="Kq2jVeRIERTfN61RG1Fkwi0I3dIGeCT3N"
X-Provags-ID:  V03:K0:nJN7DDbYoN8qnvwcWwkKdL/P9Wlfs9Nw98qRzEvev4Xm0R3GhEI
 2WPRnMr1+dyFKLshDmExZDD9p9jnHM5Gi5IqBSp3SfJY/C7CHH2zrzYrzWAzu9bvp1I3xOe
 emCb5vBVqSrbd4lvsQMnm54EiX0Sr68J32UwnaLupdXtNkznv4RQyWEONyvnC5DPHsxnlfW
 lF9UAQZ2yVVNvpTHT+c+A==
X-UI-Out-Filterresults: notjunk:1;V01:K0:2BiwG4lhOV4=:SQUa44Hu3JHRXACbaQo7ld
 5mjnXm8Caeq9Q79S4eGMyC9fk7x6N/mI2/cT+tS6y3p/Pgxg6iUUZTuPXHIrpiTfsowA3inpc
 v/j/tX33Uz7SvzhCOyGpMq316nugd86FKHyuv0p4wxLQWvPXdK6H6xnxtxGt1C4QDDayvlDon
 YLZ7G/Y3nGNv01zx4GKgk0YOr+0o/MSX6UxzB8rGCmfNoRuMReHWiZtXuc0e+PJPZR502mXvt
 w5agZywpCXjR1yf1fE/8XKYoh/FUNgJvt4hfQ+WaN55Ur7UUc7vc7fEJw41b5a/TpGKFE1wCI
 4LTsvAW1661nEvMl0hvKv332Syz9e4Yc7uAtaehG0NFSVzE50uzddp5pg/I20SBBiDWi5PBAG
 7Y3S5Nn1BF64NsEwHR5fBhGbNs2NgBdiP7dJBvXcoGIoB02hBAkRnwJXK+z8ukbl47SanSzTn
 Ka/DxdI1gCPOl6bvxAWbXIHojGdD63CWXnxPB/grXHZ7LM4YZrv3878yjmVin7ckXbkj68s9n
 0csHFER4jPXTvLxGXkrOMN7ZeOG6A91t/kYYUfPs1u0QoWOIQKW08KWGR8yxPCBKUDchi+BOh
 13qodSubMOAPKyniBqkme3dlwIoyD3MxKr7Rm2Y7rsAKGkPMsSDKDMZRSJVEjxurKgKt3LEWf
 ktE38hTJUxQZV+g7oG41hxdix
[Message part 1 (text/plain, inline)]
Forwarding this to the bug reported by Robert Dinse, in case it is of
help there.


-------- Weitergeleitete Nachricht --------
Betreff: Re: [X2Go-User] x2go on RHEL7/CentOS7
Datum: Wed, 5 Aug 2015 15:54:30 -0400 (EDT)
Von: Paul Raines <raines@nmr.mgh.harvard.edu>
An: Robert Dinse <nanook@eskimo.com>
Kopie (CC): x2go-user@lists.x2go.org


Doing Ctrl-Alt-T to terminate in the windows client will make the windows
close but doesn't clean up the session on the server.  Reconnecting
still just
connects you to a empty background screen.

Doing a logout on the MATE desktop locally works just fine.

I am testing on pretty freshly installed and updated server and on a new
user
where I first wiped out all settings by removing all dot files/directories

This is what is still running on the server as the user after trying
to logout over X2Go

applet.py€€€{applet.py}

at-spi-bus-laun€ˆ€dbus-daemon
                 „€3*[{at-spi-bus-laun}]

at-spi2-registr€€€{at-spi2-registr}

dbus-daemon

dbus-launch

dconf-service€€€2*[{dconf-service}]

goa-daemon€€€3*[{goa-daemon}]

goa-identity-se€€€2*[{goa-identity-se}]

gvfs-afc-volume€€€2*[{gvfs-afc-volume}]

gvfs-goa-volume€€€{gvfs-goa-volume}

gvfs-gphoto2-vo€€€{gvfs-gphoto2-vo}

gvfs-mtp-volume€€€{gvfs-mtp-volume}

gvfs-udisks2-vo€€€2*[{gvfs-udisks2-vo}]

gvfsd€€€{gvfsd}

gvfsd-fuse€€€4*[{gvfsd-fuse}]

gvfsd-metadata€€€{gvfsd-metadata}

gvfsd-trash€€€3*[{gvfsd-trash}]

mate-screensave€€€3*[{mate-screensave}]

mate-volume-con€€€{mate-volume-con}

nm-applet€€€2*[{nm-applet}]

polkit-mate-aut€€€{polkit-mate-aut}

pulseaudio€€€{pulseaudio}

x2goagent

x2goruncommand


-- Paul Raines (http://help.nmr.mgh.harvard.edu)



On Wed, 5 Aug 2015 2:35pm, Robert Dinse wrote:

>
> On Wed, 5 Aug 2015, Paul Raines wrote:
>>
>>  We have been using x2go fairly successful on CentOS6 machines now
>>  for a while.  We are investigating upgrading to CentOS7 and I
>>  am now looking at the x2go situation
>>
>>  We get our x2go RPMS from EPEL
>>
>>  x2goagent-3.5.0.31-1.el7.x86_64
>>  x2goclient-4.0.3.1-1.el7.x86_64
>>  x2goserver-4.0.1.19-3.el7.x86_64
>>  x2godesktopsharing-3.1.1.1-1.el7.x86_64
>>
>>  So far we have not discovered
>>
>>   1) doesn't work at all with GNOME desktop giving the "Oops" screen.
>>   Web search seems to imply this is a known issue with GNOME3
>>   with no real solution though I am suprised this is not
>>   mentioned in the X2Go wiki FAQ.  I hate GNOME3 anyway so
>>   can live without it for X2Go
>>
>>   2) works partially with the KDE desktop. There is the kscreen
>>   issue that is mentioned in the FAQ.  Really unusable unless
>>   one does disable kscreen.  Need to investigate further what
>>   consequences that has on normal logins.
>>
>>   3) installed MATE from EPEL.  On first login it looks and works great
>>   but when you "Logout ..." to terminate the session it just hangs
>>   on a blank background.  If you "suspend" the session via force
>>   closing the window and then try to reconnect it fails or just
>>   takes you right back to the blank background.  One can force
>>   terminate the session with x2goterminate-session to clear it out
>>   and then get a clean login again, but I don't really want my
>>   users having to go though this.
>>
>>  So my question is really about the MATE issue which I would prefer to use.
>>  Anyone have any clues as to what might be going on or a fix?
>
>     I'm not sure if it's Mate or X2Go but when I first installed both X2Go 
> and
> Mate on CentOS7 and tested, all was good.
>
>     Now it's broken for me also but somewhat differently.  When I logout it
> just hangs with the background image that I used on my desktop.  So I use
> control-alt-M to and then click on the white seal or whatever that animal is,
> and then when I get the start-up screen back, I select terminate to terminate
> the session.
>
>     Now I tried the same thing on Scientific Linux 7, which like Centos7 is
> derived from Enterprise Linux 7, and it still works correctly, so whatever is
> broken isn't X2Go or Mate, but rather something specific to CentOS 7.
>
>
>
>
>


The information in this e-mail is intended only for the person to whom it is
addressed. If you believe this e-mail was sent to you in error and the
e-mail
contains patient information, please contact the Partners Compliance
HelpLine at
http://www.partners.org/complianceline . If the e-mail was sent to you
in error
but does not contain patient information, please contact the sender and
properly
dispose of the e-mail.


[Nachrichtenteil als Anhang (text/plain, attachment)]
[signature.asc (application/pgp-signature, attachment)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Fri Feb 21 17:43:32 2020; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.