Subject: Bug#914: X2Go Logout Issue with Mate on Centos7

From: Stefan Baur <[email-masked]>
Date: Mon, 3 Apr 2017 14:51:10 +0200

Hi everyone,

please confirm you have package x2goserver-xsession installed:

yum list installed x2goserver-xsession

If it isn't installed, please install it:

yum install x2goserver-xsession

After that, you should be able to remove your workaround's scripts.

Please let us know if this fixes the issue for you.

Kind Regards,
Stefan Baur

-- 
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243

---

From: Maarten Boekhold <[email-masked]>
Date: Sun, 09 Apr 2017 09:35:34 +0400

Stefan,

is there any upgrade of client/server packages required to test this?

I currently have x2goserver-xsession 4.0.1.20-0~1125~ubuntu16.04.1 
installed, plus client 4.1.0.0 on Windows 10.

Maarten

---

From: Stefan Baur <[email-masked]>
Date: Mon, 10 Apr 2017 21:50:07 +0200

> installed, plus client 4.1.0.0 on Windows 10.

Hmm, something's odd here.  You're listing an Ubuntu package, while this
bug report is about CentOS7 ...?

Kind Regards,
Stefan Baur

---

From: Stefan Baur <[email-masked]>
Date: Mon, 10 Apr 2017 22:19:37 +0200

Am 10.04.2017 um 22:17 schrieb Maarten Boekhold:
> Hi, I commented on the issue because I have the same issue on Linux mint
> with xfce. I'm the one who discovered that by redirecting stdout of the
> session launcher you could avoid the issue.

I see.  Sorry I don't have any better news for you then - for
Fedora/RHEL/CentOS, our installation instructions were missing that
package, and once I installed it, the issue went away.

-Stefan

---

From: Maarten Boekhold <[email-masked]>
Date: Mon, 10 Apr 2017 23:17:58 +0300

Maarten

On April 10, 2017 11:00:27 PM Stefan Baur <[email-masked]> wrote:

> ----------
> _______________________________________________
> x2go-dev mailing list
> [email-masked]
> http://lists.x2go.org/listinfo/x2go-dev

---

From: Mike Gabriel <[email-masked]>
Date: Wed, 12 Apr 2017 11:15:16 +0000

Hi,

> Hi, I commented on the issue because I have the same issue on Linux  
> mint with xfce. I'm the one who discovered that by redirecting  
> stdout of the session launcher you could avoid the issue.
>
> Maarten
>

Same applies for MATE 1.16 with Debian 9.

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: [email-masked], http://das-netzwerkteam.de