Subject: Bug#913: Inaccurate scaling of dialog boxes and fonts for large DPI screen in Windows 10

From: "Alves-Foss, James ([email-masked])" <[email-masked]>
Date: Tue, 4 Aug 2015 15:19:24 +0000

Package: x2goclient for  windows
Version:  4.0.5.0

Downloaded new version of x2goclient for a new Dell Laptop.   Screen resolution 3200x1800. OS Windows 10 (just checked, same problem on similar machine in Windows 8.1)
When I open the main program, the fonts and windows do not scale well in the session selection boxes
When I create a new session and try to open it, I can not see the list of open sessions to connect to.

This appears to be a scaling issue for high DPI systems.

I tried Windows 7, Windows 8 compatibility modes. I tries to disable display scaling on high DPI systems (see attached images)

---

From: Matt G <[email-masked]>
Date: Tue, 20 Jul 2021 12:53:21 +0000

It appears to be DPI unaware.  

My fix for Gnome 3 at 200% on Debian Bullseye:

1. Create a copy of the .desktop to home directory
# $ cp /usr/share/applications/x2goclient.desktop ~/.local/share/applications/

2. Change exec= in ~/.local/share/applications/x2goclient.desktop
Exec=env QT_AUTO_SCREEN_SCALE_FACTOR=1 x2goclient

I found this recommendation in https://doc.qt.io/qt-5/highdpi.html
"To get an application designed for low DPI values running on high resolution monitors quickly, consider one of the following:"
"set the QT_AUTO_SCREEN_SCALE_FACTOR environment variable to 1."

Thanks to akik in the #x2go IRC channel for pointing me in the right direction.

---

From: Mike Gabriel <[email-masked]>
Date: Mon, 02 Aug 2021 06:15:01 +0000

Hi Matt,

On  Di 20 Jul 2021 14:53:21 CEST, Matt G wrote:

> "To get an application designed for low DPI values running on high  
> resolution monitors quickly, consider one of the following:"

thanks for providing this bit of info. I just tested this from an i3  
desktop locally and it fails on a 4k display by whatever reason.

What works for me, though, is:

```
env QT_SCALE_FACTOR=2 x2goclient
```

However, the overall fix will be making X2Go Client HiDPI aware.

Mike
-- 

DAS-NETZWERKTEAM
c\o Technik- und Ökologiezentrum Eckernförde
Mike Gabriel, Marienthaler Str. 17, 24340 Eckernförde
mobile: +49 (1520) 1976 148
landline: +49 (4351) 850 8940

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: [email-masked], http://das-netzwerkteam.de