Subject: X2Go session doesnt resume session after openvpn connection

From: Sergey Savko <[email-masked]>
Date: Fri, 31 Jul 2015 18:13:55 +0400 (MSK)

Package: nx-libs
Version: 3.5.0.32
Severity: normal

X2Go session doesnt resume session after openvpn connection.

nxagent 2:3.5.0.32-0x2go1+git20150704.734+jessie.main.1
nxproxy 2:3.5.0.32-0x2go1+git20150704.734+jessie.main.1
x2goserver 4.1.0.0-0x2go1.1~git20150403.1278+wheezy.heuler.1 amd64
x2goclient 4.0.5.0-0x2go1+git20150728.1112+jessie.main.1

Our LAN is based on OpenVPN Net-Net

server's ip is 192.168.100.1
the 1st client is 192.168.200.100
the 2nd is 192.168.100.100

The 1st client is connected to server with Windows X2Goclient, then the session goes into suspend mode.
The 2nd client tries to connect into this session with Windows X2Goclient or Linux X2Goclient but it fails with message^
«Failed to restore all the required visuals. Can't resume the NX session on this display».

The server's log has^
nxagentInitAndCheckVisuals: New visuals don't match with old visuals.

If we start nxclient with debug option^
x2go-DEBUG-../src/onmainwindow.cpp:10382> "Searching proxy window: X2GO-savko-151-1438348399_stDKDE_dp32"
x2go-DEBUG-../src/onmainwindow.cpp:12088> "Searching window with title: X2GO-savko-151-1438348399_stDKDE_dp32"
x2go-DEBUG-../src/onmainwindow.cpp:10382> "Searching proxy window: X2GO-savko-151-1438348399_stDKDE_dp32"
x2go-DEBUG-../src/onmainwindow.cpp:12088> "Searching window with title: X2GO-savko-151-1438348399_stDKDE_dp32"
x2go-DEBUG-../src/onmainwindow.cpp:10382> "Searching proxy window: X2GO-savko-151-1438348399_stDKDE_dp32"
x2go-DEBUG-../src/onmainwindow.cpp:12088> "Searching window with title: X2GO-savko-151-1438348399_stDKDE_dp32"
x2go-DEBUG-../src/onmainwindow.cpp:10382> "Searching proxy window: X2GO-savko-151-1438348399_stDKDE_dp32"
x2go-DEBUG-../src/onmainwindow.cpp:12088> "Searching window with title: X2GO-savko-151-1438348399_stDKDE_dp32"

The 1st client can resume the session without any problem

---

From: Stefan Baur <[email-masked]>
Date: Fri, 31 Jul 2015 16:29:24 +0200

Am 31.07.2015 um 16:13 schrieb Sergey Savko:

> nxagent 2:3.5.0.32-0x2go1+git20150704.734+jessie.main.1 nxproxy
> 2:3.5.0.32-0x2go1+git20150704.734+jessie.main.1 x2goserver
> 4.1.0.0-0x2go1.1~git20150403.1278+wheezy.heuler.1 amd64 x2goclient
> 4.0.5.0-0x2go1+git20150728.1112+jessie.main.1
> 
> server's ip is 192.168.100.1 the 1st client is 192.168.200.100 the
> 2nd is 192.168.100.100
> 
> The 1st client is connected to server with Windows X2Goclient, then
> the session goes into suspend mode. The 2nd client tries to connect
> into this session with Windows X2Goclient or Linux X2Goclient but
> it fails with message^ «Failed to restore all the required visuals.
> Can't resume the NX session on this display».
> 
> The server's log has^ nxagentInitAndCheckVisuals: New visuals don't
> match with old visuals.
> 
> x2go-DEBUG-../src/onmainwindow.cpp:12088> "Searching window with
> title: X2GO-savko-151-1438348399_stDKDE_dp32" 
> x2go-DEBUG-../src/onmainwindow.cpp:12088> "Searching window with
> title: X2GO-savko-151-1438348399_stDKDE_dp32" 
> x2go-DEBUG-../src/onmainwindow.cpp:12088> "Searching window with
> title: X2GO-savko-151-1438348399_stDKDE_dp32" 
> x2go-DEBUG-../src/onmainwindow.cpp:12088> "Searching window with
> title: X2GO-savko-151-1438348399_stDKDE_dp32"
> 

Are you sure that
a) both clients are on 4.0.5.0?
b) the session wasn't started with an older version of X2GoClient (for
   Windows, maybe?) and Client#1 is resuming that session?

What you're seeing would make sense if Client#1 is older than version
4.0.5.0 (especially if it is a Windows client, but I believe there may
be similar issues with Linux as well), see the release notes for
4.0.5.0, Section "Important notes on resuming sessions started from
4.0.4.0 or earlier":
http://wiki.x2go.org/doku.php/doc:release-notes-mswin:x2goclient-4.0.5.0

I guess it would further aid debugging if you could run a test where
you make sure to create new sessions on each client, suspend them,
then try to reconnect from the other side.  The results would be
interesting.
Also, please double-check the X2GoClient versions on both clients and
report back what you found, especially if they weren't the same on both.

Kind Regards,
Stefan

- -- 
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243