Subject: Bug#912 closed by Mihai Moldovan <[email-masked]> ()

From: Mihai Moldovan <[email-masked]>
Date: Fri, 31 Jul 2015 18:28:37 +0200

reassign 912 x2goclient 4.0.4.0
tag 912 not-a-bug
close 912

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Fri, 31 Jul 2015 16:30:01 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goclient package:

#912: X2Go session doesnt resume session after openvpn connection

It has been closed by Mihai Moldovan <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mihai Moldovan <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

From: Mihai Moldovan <[email-masked]>
To: [email-masked]
Date: Fri, 31 Jul 2015 18:28:37 +0200

Subject: X2Go session doesnt resume session after openvpn connection
From: Sergey Savko <[email-masked]>
To: [email-masked]
Date: Fri, 31 Jul 2015 18:13:55 +0400 (MSK)

Package: nx-libs
Version: 3.5.0.32
Severity: normal

X2Go session doesnt resume session after openvpn connection.

nxagent 2:3.5.0.32-0x2go1+git20150704.734+jessie.main.1
nxproxy 2:3.5.0.32-0x2go1+git20150704.734+jessie.main.1
x2goserver 4.1.0.0-0x2go1.1~git20150403.1278+wheezy.heuler.1 amd64
x2goclient 4.0.5.0-0x2go1+git20150728.1112+jessie.main.1

Our LAN is based on OpenVPN Net-Net

server's ip is 192.168.100.1
the 1st client is 192.168.200.100
the 2nd is 192.168.100.100

The 1st client is connected to server with Windows X2Goclient, then the session goes into suspend mode.
The 2nd client tries to connect into this session with Windows X2Goclient or Linux X2Goclient but it fails with message^
«Failed to restore all the required visuals. Can't resume the NX session on this display».

The server's log has^
nxagentInitAndCheckVisuals: New visuals don't match with old visuals.

If we start nxclient with debug option^
x2go-DEBUG-../src/onmainwindow.cpp:10382> "Searching proxy window: X2GO-savko-151-1438348399_stDKDE_dp32"
x2go-DEBUG-../src/onmainwindow.cpp:12088> "Searching window with title: X2GO-savko-151-1438348399_stDKDE_dp32"
x2go-DEBUG-../src/onmainwindow.cpp:10382> "Searching proxy window: X2GO-savko-151-1438348399_stDKDE_dp32"
x2go-DEBUG-../src/onmainwindow.cpp:12088> "Searching window with title: X2GO-savko-151-1438348399_stDKDE_dp32"
x2go-DEBUG-../src/onmainwindow.cpp:10382> "Searching proxy window: X2GO-savko-151-1438348399_stDKDE_dp32"
x2go-DEBUG-../src/onmainwindow.cpp:12088> "Searching window with title: X2GO-savko-151-1438348399_stDKDE_dp32"
x2go-DEBUG-../src/onmainwindow.cpp:10382> "Searching proxy window: X2GO-savko-151-1438348399_stDKDE_dp32"
x2go-DEBUG-../src/onmainwindow.cpp:12088> "Searching window with title: X2GO-savko-151-1438348399_stDKDE_dp32"

The 1st client can resume the session without any problem