Subject: nxagent segfault, causes session loss

From: Rob Izzard <[email-masked]>
Date: Wed, 22 Jul 2015 17:15:20 +0100

Package: nxagent
Version: 3.5.0.32-0~668~ubuntu14.04.1
Severity: important

Dear nxagent coders,

Over the last couple of weeks I have lost a few x2go sessions which
is, you can imagine, annoying. I thought it was just a rare bug and I
was unlucky, but today it happened again so I have collected what I
can.

It seems that when I try to connect to a running session there is
*sometimes* a crash of nxagent. Not always, but when it happens x2go
terminates the session. I do not know why x2go terminates the session
- surely it should allow me to retry the connect? Anyway, everything
in that session is lost, so this problem is fatal as well as annoying.

The connection is to localhost, so there's no network failure (despite
the suggestion of the error message).  I hope this isn't a problem
with the latest nx 3.5.0.32 ... :-/

please let me know how I can help any further.

many thanks!
Rob

-----------

x2goclient:

NXPROXY - Version 3.5.0

Copyright (C) 2001, 2010 NoMachine.
See http://www.nomachine.com/ for more information.

Info: Proxy running in client mode with pid '9703'.
Session: Starting session at 'Wed Jul 22 16:46:43 2015'.
Info: Using abstract X11 socket in kernel namespace for accessing DISPLAY=:0.
Info: Connecting to remote host 'localhost:31001'.
Info: Connection to remote proxy 'localhost:31001' established.
Info: Connection with remote proxy completed.
Warning: Unrecognized session type 'unix-kde-depth_24'. Assuming agent session.
Info: Using LAN link parameters 1536/24/1/0.
Info: Using pack method '16m-jpeg-9' with session 'unix-kde-depth_24'.
Info: Not using NX delta compression.
Info: Not using ZLIB data compression.
Info: Not using ZLIB stream compression.
Info: Not using a persistent cache.
Info: Forwarding X11 connections to display ':0'.
Session: Session started at 'Wed Jul 22 16:46:43 2015'.
Info: Established X server connection.
Info: Using shared memory parameters 0/0K.
Error: Failure reading from the peer proxy.
Error: Connection with remote peer broken.
Error: Please check the state of your network and retry.
Session: Terminating session at 'Wed Jul 22 16:46:44 2015'.
Session: Session terminated at 'Wed Jul 22 16:46:44 2015'.

-----------

syslog (note the first 16:46:44 entry which contains the segfault)

Jul 22 16:46:43 capc85 /usr/bin/x2goresume-session: client 127.0.0.1
has successfully resumed session with ID rgi-50-1437563485_stDKDE_dp24
Jul 22 16:46:44 capc85 kernel: [20606.521201] x2goagent[31916]:
segfault at e0 ip 00000000004a658e sp 00007ffcbf2cf170 error 4 in
nxagent[400000+555000]
Jul 22 16:46:44 capc85 /usr/bin/x2gomountdirs[9804]: successfully
mounted [email-masked]:30003/home/rgi/.x2go/S-rgi-50-1437563485_stDKDE_dp24/spool
to /tmp/.x2go-rgi/spool/C-rgi-50-1437563485_stDKDE_dp24
Jul 22 16:46:44 capc85 /usr/bin/x2gosetkeyboard: Setting X keyboard
according to /home/rgi/.x2go/C-rgi-50-1437563485_stDKDE_dp24/keyboard
Jul 22 16:46:44 capc85 /usr/bin/x2goumount-session[10024]:
successfully unmounted
"/tmp/.x2go-rgi/spool/C-rgi-50-1437563485_stDKDE_dp24"
Jul 22 16:46:46 capc85 /usr/sbin/x2gocleansessions[1734]:
rgi-50-1437563485_stDKDE_dp24, pid 31916 cleaning up stale X11 socket
file: /tmp/.X11-unix/X50
Jul 22 16:46:46 capc85 /usr/sbin/x2gocleansessions[1734]:
rgi-50-1437563485_stDKDE_dp24, pid 31916 cleaning up stale X11 lock
file: /tmp/.X50-lock

-------------

~/.x2goclient/sessions:

[20150414145525991]
speed=4
pack=16m-jpeg
quality=9
fstunnel=true
export=
iconvto=UTF-8
iconvfrom=ISO8859-1
useiconv=false
fullscreen=false
multidisp=false
display=1
maxdim=false
rdpclient=rdesktop
directrdpsettings=
width=800
height=600
dpi=96
setdpi=true
xinerama=false
usekbd=true
layout=us
type=auto
sound=false
soundsystem=pulse
startsoundsystem=true
soundtunnel=true
defsndport=true
sndport=4713
print=true
name=local desktop
icon=:icons/128x128/x2gosession.png
host=localhost
user=rgi
key=
rdpport=3389
sshport=22
autologin=true
krblogin=false
directrdp=false
rootless=false
published=false
applications=WWWBROWSER, MAILCLIENT, OFFICE, TERMINAL
command=KDE
rdpoptions=
rdpserver=
xdmcpserver=localhost
usesshproxy=false
sshproxytype=SSH
sshproxyuser=
sshproxykeyfile=
sshproxyhost=
sshproxyport=22
sshproxysamepass=false
sshproxysameuser=false
sshproxyautologin=false
clipboard=both
krbdelegation=false
sshproxykrblogin=false

--------------

System information:

Linux Kubuntu 14.04, 16 core Intel i7-5960X, kernel
4.1.3-040103-generic #201507220129, libc 2.19-0ubuntu6.6

packages installed (from "dpkg -l" and grepped)

i  x2goagent
2:3.5.0.32-0~668~ubuntu14.04.1
all          X2Go agent
ii  x2goclient
4.0.4.0-0~1044~ubuntu14.04.1
amd64        X2Go Client application (Qt4)
ii  x2goserver
4.0.1.19-0~1064~ubuntu14.04.1
amd64        X2Go server daemon scripts
ii  x2goserver-extensions
4.0.1.19-0~1064~ubuntu14.04.1
all          X2Go server daemon scripts (extensions)
ii  x2goserver-fmbindings
4.0.1.19-0~1064~ubuntu14.04.1
all          Generic (freedesktop-based) file manager bindings for
X2Go
ii  x2goserver-xsession
4.0.1.19-0~1064~ubuntu14.04.1
all          X2Go server daemon scripts (Xsession runner)
ii  libnx-x11-6:amd64
2:3.5.0.32-0~668~ubuntu14.04.1
amd64        nx-X11 client-side library
ii  libnx-xcomposite1:amd64
2:3.5.0.32-0~668~ubuntu14.04.1
amd64        nx-X11 Composite extension library
ii  libnx-xdamage1:amd64
2:3.5.0.32-0~668~ubuntu14.04.1
amd64        nx-X11 damaged region extension library
ii  libnx-xdmcp6:amd64
2:3.5.0.32-0~668~ubuntu14.04.1
amd64        nx-X11 Display Manager Control Protocol library
ii  libnx-xext6:amd64
2:3.5.0.32-0~668~ubuntu14.04.1
amd64        nx-X11 miscellaneous extension library
ii  libnx-xfixes3:amd64
2:3.5.0.32-0~668~ubuntu14.04.1
amd64        nx-X11 miscellaneous 'fixes' extension library
ii  libnx-xinerama1:amd64
2:3.5.0.32-0~668~ubuntu14.04.1
amd64        nx-X11 Xinerama extension library
ii  libnx-xpm4:amd64
2:3.5.0.32-0~668~ubuntu14.04.1
amd64        nx-X11 pixmap library
ii  libnx-xrandr2:amd64
2:3.5.0.32-0~668~ubuntu14.04.1
amd64        nx-X11 RandR extension library
ii  libnx-xrender1:amd64
2:3.5.0.32-0~668~ubuntu14.04.1
amd64        nx-X11 Rendering Extension client library
ii  libnx-xtst6:amd64
2:3.5.0.32-0~668~ubuntu14.04.1
amd64        nx-X11 Testing -- Record extension library
ii  nx-x11-common
2:3.5.0.32-0~668~ubuntu14.04.1
all          nx-X11 (common files)
ii  nxagent
2:3.5.0.32-0~668~ubuntu14.04.1
amd64        NX agent
ii  nxproxy
2:3.5.0.32-0~668~ubuntu14.04.1
amd64        NX proxy

---

From: Mike Gabriel <[email-masked]>
Date: Mon, 13 Jun 2016 21:42:30 +0000

Control: forwarded -1 https://github.com/ArcticaProject/nx-libs/issues/118

Hi Rob,

> please let me know how I can help any further.

Sorry for the late reply. Just want to let you know that your problem  
is probably tracked by #118 at [1].

Greets,
Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/mailxchange/kronolith/fb.php?u=m.gabriel%40das-netzwerkteam.de