Subject: -noprimaryclipboard option not working with vcxsrv 1.17

From: Walid MOGHRABI <[email-masked]>
Date: Thu, 16 Jul 2015 11:51:16 +0200 (CEST)

Package: vcxsrv 
Version: 1.17 

With the latest x2go Windows client (4.0.4.0), the embedded X server (vcxsrv 1.17) does not support the -noprimaryclipboard option that is available through the preferences in the x2go client gui. 
The primaryclipboard behaviour is very annoying with Windows so disabling it is a good idea except that it can't be done with latest release, when running, I get a debug windows stating clearly that this parameter is not supported. 

Regards, 

	Walid MOGHRABI 
	Exploitation / Operation 
	Id SKYPE : walid_smagic 

---
DISCLAIMER: This e-mail is private and confidential and may contain proprietary or legally privileged information. It is for the intended recipient only. If you have received this email in error, please notify the author by replying to it and then destroy it. If you are not the intended recipient you must not use, disclose, distribute, copy, print or rely on this e-mail or any attachment. Thank you

---

From: Mike DePaulo <[email-masked]>
Date: Fri, 11 Dec 2015 08:35:14 -0500

On Thu, Jul 16, 2015 at 5:51 AM, Walid MOGHRABI <[email-masked]>
wrote:

> Package: vcxsrv
> Version: 1.17
>
> With the latest x2go Windows client (4.0.4.0), the embedded X server
> (vcxsrv 1.17) does not support the -noprimaryclipboard option that is
> available through the preferences in the x2go client gui.
> The primaryclipboard behaviour is very annoying with Windows so disabling
> it is a good idea except that it can't be done with latest release, when
> running, I get a debug windows stating clearly that this parameter is not
> supported.
>

As the primary maintainer of X2Go Client for Windows and of X2Go's custom
builds of VcXsrv, I have taken note of this issue and #927 .

Investigating and fixing them are on my (busy) agenda. I cannot guarantee
an ETA though.