Subject: Bug#905: X2Go issue (in src:x2godesktopsharing) has been marked as closed

From: X2Go Release Manager <[email-masked]>
Date: Tue, 7 Jun 2016 03:28:08 +0200 (CEST)

close #905
thanks

Hello,

we are very hopeful that X2Go issue #905 reported by you
has been resolved in the new release (3.1.1.3) of the
X2Go source project »src:x2godesktopsharing«.

You can view the complete changelog entry of src:x2godesktopsharing (3.1.1.3)
below, and you can use the following link to view all the code changes
between this and the last release of src:x2godesktopsharing.

    http://code.x2go.org/gitweb?p=x2godesktopsharing.git;a=commitdiff;h=c1a5867c31f12a44a6dbbf9317ef44272399fa53;hp=3921c42b13af6a2bef5850c53b9baa420ba46351

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:x2godesktopsharing.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:x2godesktopsharing
Version: 3.1.1.3-0x2go1
Status: RELEASE
Date: Tue, 07 Jun 2016 03:12:53 +0200
Fixes: 905 936 993
Changes: 
 x2godesktopsharing (3.1.1.3-0x2go1) RELEASED; urgency=low
 .
   [ Mihai Moldovan ]
   * New upstream version (3.1.1.3):
     - x2godesktopsharing_zh_tw: rename to x2godesktopsharing_zh_tw.ts. Oops.
     - x2godesktopsharing.pro: also rename x2godesktopsharing_zh_tw in project
       file.
     - misc: fix X2GO => X2Go and add "Desktop" where missing. Fixes: #936.
     - sharetray.cpp: fix type issues while calculating time difference. Fixes:
       #993.
     - sharetray.cpp: post-fixup: include stdint.h to get (u)intXX_t types.
       Won't work on Windows, but the desktop sharing application isn't
       supposed to run on Windows anyway...
   * debian/control:
     - Drop libqt4-gui Depends. Already handled by shlibs and misc Depends.
       Fixes: #905.

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Tue, 07 Jun 2016 01:30:11 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2godesktopsharing package:

#905: package in official X2Go Debian repository depends on deprecated libqt4-gui

It has been closed by X2Go Release Manager <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact X2Go Release Manager <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:x2godesktopsharing) has been marked as closed
From: X2Go Release Manager <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Tue, 7 Jun 2016 03:28:08 +0200 (CEST)

close #905
thanks

Hello,

light+love

---

Subject: package in official X2Go Debian repository depends on deprecated libqt4-gui
From: Simon Frei <[email-masked]>
To: [email-masked]
Date: Sat, 11 Jul 2015 14:21:11 +0200

Package:x2godesktopsharing
Version: 3.1.1.2

I tried to install x2godesktopsharing via the official repository for 
debian on stretch which fails due to the dependency libqt4-gui. This 
package name is deprecated, the correct one is libqtgui4. Please replace 
this dependence accordingly - thanks.

Output of command "sudo apt-get install x2godesktopsharing":

Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  x2godesktopsharing : Depends: libqt4-gui but it is not installable
E: Unable to correct problems, you have held broken packages.