Subject: Bug#899 closed by Mihai Moldovan <[email-masked]> ()

From: Mihai Moldovan <[email-masked]>
Date: Fri, 17 Jul 2015 21:20:53 +0200

close 899

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Fri, 17 Jul 2015 19:25:01 +0000

This is an automatic notification regarding your Bug report
which was filed against the nx-libs package:

#899: EPEL 6 8 Jul 2015 release has dependency error

It has been closed by Mihai Moldovan <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mihai Moldovan <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

From: Mihai Moldovan <[email-masked]>
To: [email-masked]
Date: Fri, 17 Jul 2015 21:20:53 +0200

close 899

Subject: EPEL 6 8 Jul 2015 release has dependency error
From: "Harris, Peter A" <[email-masked]>
To: "[email-masked]" <[email-masked]>
Date: Tue, 30 Jun 2015 20:23:12 +0000

Package: X2Go BTS
Version: 4.0.1.19

When I try to yum install x2goserver on RHEL 6.6 from epel/6/x86_64, I get a dependency error for libXcompshad.so.3 required by nxagent.  Downloading the package directly from http://packages.x2go.org/epel/6/main/x86_64/rpms/nx-libs/libXcompshad3-3.5.0.31-0.0x2go1.1.git20150608.671.main.el6.x86_64.rpm and using yum to install just the one RPM returns the error "Nothing to do".

I have a clean RHEL6.6 system.

See attachments for:
	x2go.repo
	Output of "yum install x2goserver"

Abridged yum output:

[PAH-TEST-134-62-62]
tmp>  yum install x2goserver 2>&1 | tee /login/peteh/logs/yum_install_x2goserver.log     
Loaded plugins: aliases, changelog, downloadonly, kabi, presto, product-id,
              : refresh-packagekit, security, subscription-manager, tmprepo,
              : verify, versionlock
Loading support for Red Hat kernel ABI
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package x2goserver.x86_64 0:4.0.1.19-0.0x2go2.1.git20150608.1064.main.el6 will be installed
...
---> Package nxagent.x86_64 0:3.5.0.31-0.0x2go1.1.git20150608.671.main.el6 will be installed
...
--> Processing Dependency: libXcompshad.so.3()(64bit) for package: nxagent-3.5.0.31-0.0x2go1.1.git20150608.671.main.el6.x86_64
...
--> Processing Dependency: libXcompshad.so.3()(64bit) for package: nxagent-3.5.0.31-0.0x2go1.1.git20150608.671.main.el6.x86_64
--> Running transaction check
---> Package nx-libs.x86_64 0:3.5.0.31-0.0x2go1.1.git20150608.671.main.el6 will be installed
---> Package nxagent.x86_64 0:3.5.0.31-0.0x2go1.1.git20150608.671.main.el6 will be installed
--> Processing Dependency: libXcompshad.so.3()(64bit) for package: nxagent-3.5.0.31-0.0x2go1.1.git20150608.671.main.el6.x86_64
--> Finished Dependency Resolution
Error: Package: nxagent-3.5.0.31-0.0x2go1.1.git20150608.671.main.el6.x86_64 (x2go-release-epel)
           Requires: libXcompshad.so.3()(64bit)

Direct investigation of the repo showed a non-zero length libXcompshad3-3.5.0.31-0.0x2go1.1.git20150608.671.main.el6.x86_64.rpm, which I downloaded and tried to pre-install using yum:

[PAH-TEST-134-62-62]
tmp>  ll libXcompshad3-3.5.0.31-0.0x2go1.1.git20150608.671.main.el6.x86_64.rpm 
-rw-rw-r-- 1 root root 31940 Jun  7 19:35 libXcompshad3-3.5.0.31-0.0x2go1.1.git20150608.671.main.el6.x86_64.rpm

[PAH-TEST-134-62-62]
tmp>  yum install ./libXcompshad3-3.5.0.31-0.0x2go1.1.git20150608.671.main.el6.x86_64.rpm 
Loaded plugins: aliases, changelog, downloadonly, kabi, presto, product-id, refresh-packagekit, security, subscription-manager, tmprepo, verify, versionlock
Loading support for Red Hat kernel ABI
Setting up Install Process
Examining ./libXcompshad3-3.5.0.31-0.0x2go1.1.git20150608.671.main.el6.x86_64.rpm: libXcompshad3-3.5.0.31-0.0x2go1.1.git20150608.671.main.el6.x86_64
Error: Nothing to do

Regards,
Pete Harris
Danaher / Tektronix
Danaher T&M / Global IT Infrastructure / UNIX Servers & Storage
MS 50-555 / PO BOX 500 / BEAVERTON OR 97077-0500
Phone:	+1.503.627.3989
Fax:	+1.503.627.4005 
-- Any opinions expressed are those of the author and may not be those of Danaher / Tektronix --