Subject: Bug#884: nxagent aborts session with 'Could not open default font 'fixed''

From: devsk <[email-masked]>
Date: Tue, 2 Jun 2015 15:49:24 +0000 (UTC)

Hi,

As per suggestion I built the code from https://github.com/ArcticaProject/nx-libs. And I still run into the same issue.

Does anybody here know that part of the code (snippet in the report)?

-devsk

---

From: Mike Gabriel <[email-masked]>
Date: Tue, 02 Jun 2015 16:13:21 +0000

On  Di 02 Jun 2015 17:49:24 CEST, devsk wrote:

> Hi,
>
> As per suggestion I built the code from  
> https://github.com/ArcticaProject/nx-libs. And I still run into the  
> same issue.
>

Please take a look at [1] and make sure either of those paths exists  
on your system.

You need the fixed fonts in the misc/ fontdir.

Is everything in place there?

Mike

[1]  
https://github.com/ArcticaProject/nx-libs/blob/3.6.x/nx-X11/programs/Xserver/hw/nxagent/Font.c#L64
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: devsk <[email-masked]>
Date: Tue, 2 Jun 2015 16:21:49 +0000 (UTC)

The folder /usr/X11R6 hasn't existed on Gentoo for years now (since move to Xorg). Does the folder /usr/X11R6/lib/X11/fonts exist on other distros?

Also, the code seems to be making an attempt to look for "ALTERNATE" font paths and many of those paths are there:

$ ls -al /usr/share/fonts/*/fonts.{alias,dir}

-rw-r--r-- 1 root root  3154 Apr 11 08:16 /usr/share/fonts/100dpi/fonts.alias
-rw-r--r-- 1 root root 17828 Jun  2 07:14 /usr/share/fonts/100dpi/fonts.dir
-rw-r--r-- 1 root root  3066 Apr 11 08:16 /usr/share/fonts/75dpi/fonts.alias
-rw-r--r-- 1 root root 17280 Jun  2 07:15 /usr/share/fonts/75dpi/fonts.dir
-rw-r--r-- 1 root root  2000 Jun  2 07:12 /usr/share/fonts/OTF/fonts.dir
-rw-r--r-- 1 root root  1689 Jun  2 07:14 /usr/share/fonts/Speedo/fonts.dir
-rw-r--r-- 1 root root 10298 Jun  2 07:10 /usr/share/fonts/TTF/fonts.dir
-rw-r--r-- 1 root root 13319 Jun  2 07:15 /usr/share/fonts/Type1/fonts.dir
-rw-r--r-- 1 root root 44001 Apr 11 08:07 /usr/share/fonts/corefonts/fonts.dir
-rw-r--r-- 1 root root 21736 Apr 10 17:51 /usr/share/fonts/croscorefonts/fonts.dir
-rw-r--r-- 1 root root  3234 Apr 11 08:16 /usr/share/fonts/cyrillic/fonts.alias
-rw-r--r-- 1 root root  6005 Jun  2 07:15 /usr/share/fonts/cyrillic/fonts.dir
-rw-r--r-- 1 root root 43905 Apr 10 17:51 /usr/share/fonts/dejavu/fonts.dir
-rw-r--r-- 1 root root 26289 Apr 11 08:07 /usr/share/fonts/liberation-fonts/fonts.dir
-rw-r--r-- 1 root root 16664 Apr 11 08:08 /usr/share/fonts/libertine/fonts.dir
-rw-r--r-- 1 root root  6209 Apr 11 08:16 /usr/share/fonts/misc/fonts.alias
-rw-r--r-- 1 root root  6721 Jun  2 07:15 /usr/share/fonts/misc/fonts.dir
-rw-r--r-- 1 root root 31892 Apr 11 08:07 /usr/share/fonts/roboto/fonts.dir
-rw-r--r-- 1 root root  5053 Apr 11 08:08 /usr/share/fonts/ttf-bitstream-vera/fonts.dir
-rw-r--r-- 1 root root 43334 Apr 10 17:51 /usr/share/fonts/urw-fonts/fonts.dir

-devsk

On Tuesday, June 2, 2015 9:13 AM, Mike Gabriel <[email-masked]> wrote:

Mike

[1]  

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

---

From: Michael DePaulo <[email-masked]>
Date: Tue, 2 Jun 2015 17:41:33 -0400

A quick look at some distros where nxagent works.

Out of the 5 dirs listed:

Ubuntu 14.04 contains:
/usr/share/fonts/ (no "misc" under it)
/usr/share/fonts/X11/misc/

RHEL 7.1 contains:
/usr/share/fonts/ (no "misc" under it)
/usr/share/X11/fonts/misc/

On Tue, Jun 2, 2015 at 12:21 PM, devsk <[email-masked]> wrote:
> _______________________________________________
> x2go-dev mailing list
> [email-masked]
> http://lists.x2go.org/listinfo/x2go-dev

---

From: devsk <[email-masked]>
Date: Wed, 3 Jun 2015 01:48:17 +0000 (UTC)

I don't think its a font path problem. The font paths can be specified at the command line with -fp /<path1>/,/<path2/,... and it loads all fonts fine, including the "fixed" ones from /usr/share/fonts/misc/ folder specified on the command line and the ALTERNATE paths specified in the code.

If I change the font with -fn to "9x15" to be the default font, it still fails to open the default font "9x15". I know for a fact that 9x15 font exists in the custom paths I have specified using -fp.

So, its not a font path issue. Its what happens when it wants to set the default font and calls those 2 functions. Most likely, the second function is the one which is failing because the fist function has failure cases only for allocation failures.
 
-devsk

---

From: Ulrich Sibiller <[email-masked]>
Date: Wed, 3 Jun 2015 10:16:35 +0200

> /usr/share/X11/fonts/misc/

You can us the -fp option of nxagent/x2goagent to pass an arbitrary
font path. Furthermore you could set up an heuristic that determines
valid font paths. For our company internal script we use this (ugly)
code:

           fontpath=""
           while read fp ; do
               [ -r ${fp%:unscaled}/fonts.dir ] || continue
               [[ ",$fontpath," == *,$fp,* ]] ||
fontpath=${fontpath:+$fontpath,}${fp}
           done < <(
               for xlog in /var/log/Xorg.0.log /var/log/XFree86.0.log ; do
                   sed -n -e "1,/FontPath set to:/d" -e "s/,$//" -e
"s/^        //p" $xlog 2> /dev/null # TAB!
                   grep "FontPath set to " $xlog 2> /dev/null | cut
-d\" -f2 | tr , "\012"
               done
               for xconf in /etc/X11/xorg.conf /etc/X11/xorg.conf.d/*
/etc/X11/XF86Config ; do
                   grep FontPath $xconf 2> /dev/null | grep \" | cut -d\" -f2
               done
               grep /fonts/ /etc/X11/fs/config 2> /dev/null | sed -e
"s/^[catalogue =   ]*//" -e "s/,$//"
               (
                   ls /etc/X11/fontpath.d/*/fonts.dir
/usr/share/fonts/*/fonts.dir /usr/share/X11/fonts/*/fonts.dir
/usr/share/fonts/X11/*/fonts.dir /usr/X11R6/lib/X11/fonts/*/fonts.dir
/usr/lib/X11/fonts/*/fonts.dir
                   locate /fonts.dir | grep "^/usr"
               ) 2> /dev/null | sed -n "s|/fonts.dir$||p"
               strings ${NXPATH}/*/nxagent* 2> /dev/null | grep
/fonts/ | tr , "\012"
           ) 2> /dev/null

           [ -z "$fontpath" ] && read count fontpath < <( strings
/usr/bin/X* /usr/X11R6/bin/X* 2>&1 | grep "/fonts/.*," | sed
"s,^[^/]*,," | sort | uniq -c | sort -nr | head -1 )
         echo remote_fontpath=\"$fontpath\"

Uli

---

From: devsk <[email-masked]>
Date: Wed, 3 Jun 2015 13:57:59 +0000 (UTC)

I thought I mentioned it. I tried both -fp and -fn arguments to influence the behavior of nxagent but it still failed with the message saying "could not open default font '<whatever font used with -fn>'"

The font specified with -fn exists in font path specified with -fp.

-devsk

---

From: Mike Gabriel <[email-masked]>
Date: Thu, 04 Jun 2015 08:18:40 +0000

Hi Devsk,

On  Mi 03 Jun 2015 15:57:59 CEST, devsk wrote:

> I thought I mentioned it. I tried both -fp and -fn arguments to  
> influence the behavior of nxagent but it still failed with the  
> message saying "could not open default font '<whatever font used  
> with -fn>'"
>

this is so weird... Hmmm... I don't have the time to spin up a Gentoo  
right now. Please try to reach the other Gentoo people on IRC (there  
are several users on IRC from time to time using Gentoo), maybe any of  
them has a clue. I definitely know (i.e., have heard) that X2Go with  
nx-libs is working on Gentoo for others.

Mike
-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

---

From: Mihai Moldovan <[email-masked]>
Date: Thu, 04 Jun 2015 14:48:09 +0200

> nx-libs is working on Gentoo for others.

Definitely working for me and others.

I think the fonts message is a red herring and not the real cause of trouble. I
have checked Debian and Fedora systems, too, and they likewise don't have a
"fixed" fonts directory.

Given that I cannot reproduce it, it's likely a problem with his specific
system, so reproducing and debugging is difficult on my end.

Mihai

---

From: devsk <[email-masked]>
Date: Fri, 5 Jun 2015 01:22:17 +0000 (UTC)

> Definitely working for me and others.

One of the strange things about my setup is that its /usr is read-only (like on a livecd). That's the only thing I know is different from a regular gentoo system. Do you think that's something that might cause issues?

Technically, nothing should be writing to /usr.

The setup is basically booting a squashfs image (same image boots on 10 different desktops and laptops I have) just like a Gentoo livecd and has writable folders in / (tmpfs) for everything except /usr, /bin, /sbin, /lib64, /lib32. Their /home is on a local disk on ZFS (mostly) or ext4. This is done mostly to avoid maintaining 10 different systems. I create a new image once in a while, these systems pull it and it gets picked up on their next reboot. Many of these systems haven't booted in quite some time. As long as I don't need an update (a new package I can't live without or fixes for known exploits), they keep going.

Does this ring any bells with respect to this issue?

I think I agree with the conclusion that 'fixed' font thingy is a red-herring.

-devsk

---

From: Mihai Moldovan <[email-masked]>
Date: Fri, 05 Jun 2015 03:33:07 +0200

> One of the strange things about my setup is that its /usr is read-only (like on a livecd). That's the only thing I know is different from a regular gentoo system. Do you think that's something that…

That's differing from my setup for sure, but I wouldn't know nx-libs writing
anything to /usr, so I don't think that's the problem.

Have you actually looked at *all* output by nxagent?

Please check /tmp/.x2go-user/C-[...]/session.log

Mihai

---

From: devsk <[email-masked]>
Date: Fri, 5 Jun 2015 02:24:54 +0000 (UTC)

Yes, I have looked at all of session.log. I am cutting and pasting it here, in case I missed something:

$ cat session.log 

NXAGENT - Version 3.5.99.0

Copyright (C) 2001, 2011 NoMachine.
See http://www.nomachine.com/ for more information.

Info: Agent running with pid '14374'.
Session: Starting session at 'Thu Jun  4 19:23:08 2015'.
Info: Proxy running in server mode with pid '14374'.
Info: Waiting for connection from 'localhost' on port '30022'.
Info: Accepted connection from '127.0.0.1'.
Info: Connection with remote proxy completed.
Info: Using LAN link parameters 1536/24/1/0.
Info: Using agent parameters 5000/0/50/0/0.
Info: Using pack method '16m-jpeg-9' with session 'unix-kde-depth_24'.
Info: Not using NX delta compression.
Info: Not using ZLIB data compression.
Info: Not using ZLIB stream compression.
Info: Not using a persistent cache.
Info: Listening to X11 connections on display ':57'.
Info: Established X client connection.
Info: Using shared memory parameters 1/1/0/0K.
Info: Using alpha channel in render extension.
Info: Not using local device configuration changes.
keyboard file created
Error: Aborting session with 'Could not open default font 'fixed''.
Session: Aborting session at 'Thu Jun  4 19:23:11 2015'.
Session: Session aborted at 'Thu Jun  4 19:23:11 2015'.
Warning: Signals were not blocked in process with pid '14374'.
Info: Waiting the cleanup timeout to complete.

-devsk

---

From: Mihai Moldovan <[email-masked]>
Date: Sat, 06 Jun 2015 16:12:23 +0200

On 05.06.2015 04:24 AM, devsk wrote:
> [...]

I find something odd about this error message.

It doesn't seem to be coming from nx-libs.

Note how the code in nx-libs spells "could" in lowercase, but the message spells
it with a capital letter.

I'm using nx-libs without any problems on a system having =x11-libs/libXfont-1.5.1.

Please try to make sure that the following packages are all installed (and
correctly installed! If in doubt, reinstall):

media-fonts/font-alias
media-fonts/font-arabic-misc
media-fonts/font-cursor-misc
media-fonts/font-daewoo-misc
media-fonts/font-dec-misc
media-fonts/font-isas-misc
media-fonts/font-jis-misc
media-fonts/font-micro-misc
media-fonts/font-misc-misc
media-fonts/font-mutt-misc
media-fonts/font-schumacher-misc
media-fonts/font-sony-misc
media-fonts/font-sun-misc

Next thing to consider is your DPI. Do you use any "weird" DPI value? I don't
think that's it either, but try setting it to 75 or 95 for testing purposes.

How proficient are you with debugging? Or is there any way to allow access to
one affected machine? I'd like to get a gdb backtrace of the moment the
FatalError() function triggers, to see which library or part *really* is
responsible for that message. This will also involve building nx-libs with debug
symbols, of course.

Mihai

---

From: Mihai Moldovan <[email-masked]>
Date: Sat, 06 Jun 2015 16:18:39 +0200

One more thing Mike#2 just mentioned on IRC and I have confirmed not to be the
case in Gentoo: fontconfig is not a dependency of x2goserver, though it should be.

Actually, it probably should be a dependency of net-misc/nx in general and not
x2goserver, but let's ignore that "issue" for now.

Is media-libs/fontconfig installed on your system? If not, do that, rinse,
repeat... and try the other stuff in my former eMail.

Mihai

---

From: devsk <[email-masked]>
Date: Mon, 8 Jun 2015 03:52:01 +0000 (UTC)

> Note how the code in nx-libs spells "could" in lowercase, but
> the message spells it with a capital letter.

I was thrown off by that for a while. It took me a while to search that message because I was searching for exact message and it wouldn't find it. When I did find the message and then looked at the wrapper function that was being called with that message, I knew what was going on. The wrapper pretty prints the enclosed message by capitalizing the first letter....one of those genius ideas. Wasting developer time since the dawn of the times.

Anyway, the fontconfig is definitely installed (KDE wouldn't function without it).

The DPI was being enforced by the client to be 96 and I unchecked that and tried as well. But the issue appears when I just run 'nxagent :50" without any args. I expect it should throw open an empty window with a logo, but instead it comes out with that dreadful message.

I am handy with debugging and code. But my time is very limited because our company is running against some hard deadlines in 1.5 weeks... Working during weekends sucks...:(

-devsk

---

From: devsk <[email-masked]>
Date: Mon, 8 Jun 2015 03:55:33 +0000 (UTC)

All font packages are installed. I just emerged xorg-x11 to be sure.

# for i in $(cat /tmp/tmper);do q size $i;done
media-fonts/font-alias-1.0.3-r1: 4 files, 7 non-files, 15.295 KiB
media-fonts/font-arabic-misc-1.0.3: 1 files, 4 non-files, 14.344 KiB
media-fonts/font-cursor-misc-1.0.3: 1 files, 4 non-files, 5.102 KiB
media-fonts/font-daewoo-misc-1.0.3: 3 files, 4 non-files, 811.122 KiB
media-fonts/font-dec-misc-1.0.3: 2 files, 4 non-files, 3.218 KiB
media-fonts/font-isas-misc-1.0.3: 3 files, 4 non-files, 922.971 KiB
media-fonts/font-jis-misc-1.0.3: 2 files, 4 non-files, 604.336 KiB
media-fonts/font-micro-misc-1.0.3: 1 files, 4 non-files, 1.772 KiB
media-fonts/font-misc-misc-1.1.2: 27 files, 4 non-files, 2769.30 KiB
media-fonts/font-mutt-misc-1.0.3: 8 files, 4 non-files, 234.657 KiB
media-fonts/font-schumacher-misc-1.1.2: 31 files, 4 non-files, 97.912 KiB
media-fonts/font-sony-misc-1.0.3: 4 files, 4 non-files, 19.706 KiB
media-fonts/font-sun-misc-1.0.3: 5 files, 4 non-files, 25.35 KiB

-devsk

---

From: devsk <[email-masked]>
Date: Mon, 8 Jun 2015 04:28:09 +0000 (UTC)

I did a quick gdb session. You can see it below. The culprit is exactly the function that I pointed out earlier in 1st post for this bug.

(gdb) b SetDefaultFont
Breakpoint 1 at 0x4210b0: file NXdixfonts.c, line 221.
(gdb) r :50
Starting program: /tmp/nxagent :50
warning: File "/mnt/livecd/lib64/libthread_db-1.0.so" auto-loading has been declined by your `auto-load safe-path' set to "$debugdir:$datadir/auto-load".
warning: Unable to find libthread_db matching inferior's thread library, thread debugging will not be available.

Info: Agent running with pid '10502'.
Session: Starting session at 'Sun Jun  7 21:19:22 2015'.
Info: Using alpha channel in render extension.
Info: Not using local device configuration changes.
error opening security policy file /usr/local/lib/nx/X11/xserver/SecurityPolicy
SessionPath not defined

Breakpoint 1, SetDefaultFont (defaultfontname=0x703f11 "fixed") at NXdixfonts.c:221
221     NXdixfonts.c: No such file or directory.
(gdb) bt
#0  SetDefaultFont (defaultfontname=0x703f11 "fixed") at NXdixfonts.c:221
#1  0x000000000040dd05 in main ()
(gdb) s
226     in NXdixfonts.c
(gdb) 
221     in NXdixfonts.c
(gdb) 
226     in NXdixfonts.c
(gdb) 
FakeClientID (client=client@entry=0) at NXresource.c:441
441     NXresource.c: No such file or directory.
(gdb) 
444     in NXresource.c
(gdb) 
441     in NXresource.c
(gdb) 
444     in NXresource.c
(gdb) 
441     in NXresource.c
(gdb) 
444     in NXresource.c
(gdb) fini
Run till exit from #0  FakeClientID (client=client@entry=0) at NXresource.c:444
SetDefaultFont (defaultfontname=0x703f11 "fixed") at NXdixfonts.c:228
228     NXdixfonts.c: No such file or directory.
Value returned is $1 = 127
(gdb) p fid
$2 = <optimized out>
(gdb) p err
$3 = <optimized out>
(gdb) s
226     in NXdixfonts.c
(gdb) 
228     in NXdixfonts.c
(gdb) 
227     in NXdixfonts.c
(gdb) 
OpenFont (pfontname=<optimized out>, lenfname=<optimized out>, flags=31, fid=<optimized out>, client=<optimized out>) at NXdixfonts.c:526
526     in NXdixfonts.c
(gdb) fini
Run till exit from #0  OpenFont (pfontname=<optimized out>, lenfname=<optimized out>, flags=31, fid=<optimized out>, client=<optimized out>) at NXdixfonts.c:526
227     in NXdixfonts.c
(gdb) p err
$4 = <optimized out>
(gdb) s
OpenFont (pfontname=0x703f11 "fixed", lenfname=5, flags=31, fid=127, client=0xa53ab0) at NXdixfonts.c:526
526     in NXdixfonts.c
(gdb) 
OpenFont (client=0xa53ab0, fid=fid@entry=127, flags=flags@entry=31, lenfname=5, pfontname=pfontname@entry=0x703f11 "fixed") at NXdixfonts.c:512
512     in NXdixfonts.c
(gdb) 
528     in NXdixfonts.c
(gdb) 
512     in NXdixfonts.c
(gdb) 
528     in NXdixfonts.c
(gdb) fini
Run till exit from #0  OpenFont (client=0xa53ab0, fid=fid@entry=127, flags=flags@entry=31, lenfname=5, pfontname=pfontname@entry=0x703f11 "fixed") at NXdixfonts.c:528
SetDefaultFont (defaultfontname=0x703f11 "fixed") at NXdixfonts.c:229
229     in NXdixfonts.c
Value returned is $5 = 0
(gdb) p Success
No symbol "Success" in current context.
(gdb) s
231     in NXdixfonts.c
(gdb) 
LookupIDByType (id=127, rtype=4) at NXresource.c:1192
1192    NXresource.c: No such file or directory.
(gdb) 
1193    in NXresource.c
(gdb) 
SecurityLookupIDByType (client=0x0, id=127, rtype=4, mode=0) at NXresource.c:1140
1140    in NXresource.c
(gdb) 
1131    in NXresource.c
(gdb) 
1140    in NXresource.c
(gdb) 
1131    in NXresource.c
(gdb) 
1140    in NXresource.c
(gdb) fini
Run till exit from #0  SecurityLookupIDByType (client=0x0, id=127, rtype=4, mode=0) at NXresource.c:1140
SetDefaultFont (defaultfontname=0x703f11 "fixed") at NXdixfonts.c:232
232     NXdixfonts.c: No such file or directory.
Value returned is $6 = (void *) 0x0
(gdb) s
236     in NXdixfonts.c
(gdb) 
230     in NXdixfonts.c
(gdb) p defaultFont
$7 = (FontPtr) 0x0
(gdb) p pf
$8 = <optimized out>
(gdb) s
236     in NXdixfonts.c

LookupIDByType() returns a null ptr.

-devsk

---

From: devsk <[email-masked]>
Date: Mon, 8 Jun 2015 04:50:48 +0000 (UTC)

So, here is why SecurityLookupIDByType() fails. Basically, looks like the Hash() in NXresource.c is returning an index for "id" which is referencing 0x0.

Anybody got any clues? What does XCSECURITY have to do with default font? What kind of madness is this?

Breakpoint 1, SetDefaultFont (defaultfontname=0x703f11 "fixed") at NXdixfonts.c:221
221     NXdixfonts.c: No such file or directory.
(gdb) b Hash
Breakpoint 3 at 0x43b1a0: file NXresource.c, line 321.
(gdb) c
Continuing.

Breakpoint 3, Hash (client=client@entry=0, id=id@entry=127) at NXresource.c:321
321     NXresource.c: No such file or directory.
(gdb) bt
#0  Hash (client=client@entry=0, id=id@entry=127) at NXresource.c:321
#1  0x000000000043c3e7 in SecurityLookupIDByType (client=0x0, id=127, rtype=4, mode=0) at NXresource.c:1143
#2  0x000000000043c62e in LookupIDByType (id=<optimized out>, rtype=<optimized out>) at NXresource.c:1193
#3  0x0000000000421109 in SetDefaultFont (defaultfontname=0x703f11 "fixed") at NXdixfonts.c:231
#4  0x000000000040dd05 in main ()
(gdb) s
320     in NXresource.c
(gdb) 
336     in NXresource.c
(gdb) p res
No symbol "res" in current context.
(gdb) p id
$22 = 127
(gdb) p ((int)(0x3F&(id^(id>>6)^(id>>12))))
$24 = 62
(gdb) fini
Run till exit from #0  Hash (client=client@entry=0, id=id@entry=127) at NXresource.c:336
0x000000000043c3e7 in SecurityLookupIDByType (client=0x0, id=127, rtype=4, mode=0) at NXresource.c:1143
1143    in NXresource.c
Value returned is $25 = 62
(gdb) bt
#0  0x000000000043c3e7 in SecurityLookupIDByType (client=0x0, id=127, rtype=4, mode=0) at NXresource.c:1143
#1  0x000000000043c62e in LookupIDByType (id=<optimized out>, rtype=<optimized out>) at NXresource.c:1193
#2  0x0000000000421109 in SetDefaultFont (defaultfontname=0x703f11 "fixed") at NXdixfonts.c:231
#3  0x000000000040dd05 in main ()
(gdb) p clientTable[cid].resources[62]
$26 = (ResourcePtr) 0x0

-devsk

---

From: devsk <[email-masked]>
Date: Mon, 8 Jun 2015 05:02:06 +0000 (UTC)

Is there a quick way to build nx-libs without XCSECURITY? I am curious about the #else case (i.e. the code that's not using the XCSECURITY).

Does anybody have any ideas what about my setup is upsetting this?

-devsk

---

From: devsk <[email-masked]>
Date: Wed, 2 Sep 2015 01:32:56 +0000 (UTC)

I finally decoded this issue. I can't believe it. The reason why its not able to load the default font and default cursor was that language specific fonts were missing from the /usr/share/fonts/misc folder. Those are missing because I have '-nls' in my global USE flags.

I had to spin up an Ubuntu 14.04 VM to figure this out...:) This is a packaging bug. nx package on Gentoo should force the 'nls' USE flag on media-fonts/font-misc-misc because without that nxagent is completely broken. I wonder how Xorg and Xvnc are fine without those! May be there is legacy code in nxagent which needs removal...:)

Thanks for all the help everyone! It was a pleasure dealing with you all. I hope the x2go community flourishes more and more everyday!
-devsk

---

From: Mike Gabriel <[email-masked]>
Date: Wed, 02 Sep 2015 09:00:19 +0000

HI Devsk,

On  Mi 02 Sep 2015 03:32:56 CEST, devsk wrote:

> I finally decoded this issue. I can't believe it. The reason why its  
> not able to load the default font and default cursor was that  
> language specific fonts were missing from the /usr/share/fonts/misc  
> folder. Those are missing because I have '-nls' in my global USE  
> flags.
>
> I had to spin up an Ubuntu 14.04 VM to figure this out...:) This is  
> a packaging bug. nx package on Gentoo should force the 'nls' USE  
> flag on media-fonts/font-misc-misc because without that nxagent is  
> completely broken. I wonder how Xorg and Xvnc are fine without  
> those! May be there is legacy code in nxagent which needs removal...:)
>
> Thanks for all the help everyone! It was a pleasure dealing with you  
> all. I hope the x2go community flourishes more and more everyday!
> -devsk

Please can you be more precise? Where do you set the -nls flag and how  
can we get this fixed upstream in nx-libs?

Mike
-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

---

From: Mihai Moldovan <[email-masked]>
Date: Wed, 2 Sep 2015 20:25:37 +0200

> can we get this fixed upstream in nx-libs?

He's talking about the Gentoo-specific USE flag feature, which lets you disable
or enable features.

No, we cannot do anything about this.

However, there is another "bug report" pending for OpenSuSE, reproducing this
issue. (-> "x2go on openSUSE")

This might be a related packaging issue, so it would be very interesting to know
what missing file exactly caused this issue.

Mihai

---

From: devsk <[email-masked]>
Date: Fri, 4 Sep 2015 02:06:55 +0000 (UTC)

Yes, I am talking about Gentoo specific packaging issue. I have filed 

https://bugs.gentoo.org/show_bug.cgi?id=559370

to track it down. As I mentioned, the specific files being talked about are the font files in /usr/share/fonts/misc (/usr/share/fonts/X11/misc on Ubuntu) which are character encodings specific e.g. 9x15-ISO8859-*.pcf.gz. nxagent can not load a fixed size font '9x15' without the presence of these files. It looks like these are abandoned by modern X code because both Xorg and Xvnc work fine without these files.

-devsk

On Wednesday, September 2, 2015 11:25 AM, Mihai Moldovan <[email-masked]> wrote:

Mihai

---

From: Mike Gabriel <[email-masked]>
Date: Sat, 05 Sep 2015 12:05:39 +0000

Hi Devsk,

On  Fr 04 Sep 2015 04:06:55 CEST, devsk wrote:

> to track it down. As I mentioned, the specific files being talked  
> about are the font files in /usr/share/fonts/misc  
> (/usr/share/fonts/X11/misc on Ubuntu) which are character encodings  
> specific e.g. 9x15-ISO8859-*.pcf.gz. nxagent can not load a fixed  
> size font '9x15' without the presence of these files. It looks like  
> these are abandoned by modern X code because both Xorg and Xvnc work  
> fine without these files.
>
> -devsk

Thanks for explaining the above. However, I think that we should get  
this issue also solved upstream as most systems work on UTF-8 basis  
and the more local encodings are rather historical than  
current-state-of-the-art.

Let's leave this bug open and address it for 3.6.x of nx-libs instead  
of dealing with it as a Gentoo specific bug.

Mike
-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

---

From: Mike Gabriel <[email-masked]>
Date: Wed, 24 Feb 2016 14:03:18 +0000

Control: forwarded -1 https://github.com/ArcticaProject/nx-libs/issues/84

On  Sa 05 Sep 2015 14:05:39 CEST, Mike Gabriel wrote:

>> these are abandoned by modern X code because both Xorg and Xvnc  
>> work fine without these files.
>>
>> -devsk
>
> Let's leave this bug open and address it for 3.6.x of nx-libs  
> instead of dealing with it as a Gentoo specific bug.
>
> Mike

This issue has been forwarded to the new upstream location of nx-libs:
https://github.com/ArcticaProject/nx-libs/issues/84

Greets,
Mike
-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:
https://mail.das-netzwerkteam.de/mailxchange/kronolith/fb.php?u=m.gabriel%40das-netzwerkteam.de