Subject: Re: [X2Go-Dev] Bug#882: X2Go issue (in src:x2goclient) has been marked as pending for release

From: Florian Wicke - Hetzner Online AG <[email-masked]>
Date: Tue, 09 Jun 2015 18:51:32 +0200

Unfortunately the fix made it worse in regards of behaviour:

With the latest nightly x2goclient i get the error message "scdaemon
started but crashed" all the time with no smartcard present.

Manually invoking scdaemon with "--multi-server" works just fine

Looks like you handle the "soft-error" below of scdaemon as critical error:
"scdaemon[10084]: PC/SC OPEN failed: no service (0x8010001d)

And thus, exiting the x2goclient if no smartcard is present

Expected behaviour: as before - let the client wait for smartcards to be
plugged in/become available without terminating the client.

Kind regards

 Florian Wicke

Hetzner Online AG
Industriestr. 25
91710 Gunzenhausen / Germany
Tel: +49 9831 505-187
Fax: +49 9831 505-387
[email-masked]
www.hetzner.com

Register Court: Registergericht Ansbach, HRB 3204
Management Board: Dipl. Ing. (FH) Martin Hetzner
Chairwoman of the Supervisory Board: Diana Rothhan

Am 03.06.2015 um 03:11 schrieb Mihai Moldovan:
> tag #882 pending
> fixed #882 4.0.4.1
> thanks
> 
> Hello,
> 
> X2Go issue #882 (src:x2goclient) reported by you has been
> fixed in X2Go Git. You can see the changelog below, and you can
> check the diff of the fix at:
> 
>     http://code.x2go.org/gitweb?p=x2goclient.git;a=commitdiff;h=90d6b8b
> 
> The issue will most likely be fixed in src:x2goclient (4.0.4.1).
> 
> light+love
> X2Go Git Admin (on behalf of the sender of this mail)
> 
> ---
> commit 90d6b8b7cecec02b2a0e0f81ed650ca1bf39862f
> Author: Mihai Moldovan <[email-masked]>
> Date:   Wed Jun 3 01:36:32 2015 +0200
> 
>     onmainwindow.cpp: manipulate PATH and append /usr/lib/gnupg2/ to it when starting scdaemon. Fixes: #882.
> 
> diff --git a/debian/changelog b/debian/changelog
> index 2399c15..bb4045a 100644
> --- a/debian/changelog
> +++ b/debian/changelog
> @@ -16,6 +16,8 @@ x2goclient (4.0.4.1-0x2go1) UNRELEASED; urgency=low
>        for show_RichText_Generic_MsgBox() with a critical icon.
>      - onmainwindow.{cpp,h}: properly handle scdaemon errors with a message box
>        and close the client.
> +    - onmainwindow.cpp: manipulate PATH and append /usr/lib/gnupg2/ to it when
> +      starting scdaemon. Fixes: #882.
>  
>   -- X2Go Release Manager <[email-masked]>  Tue, 26 May 2015 21:42:09 +0200
>  
> _______________________________________________
> x2go-dev mailing list
> [email-masked]
> http://lists.x2go.org/listinfo/x2go-dev
>

---

From: Mihai Moldovan <[email-masked]>
Date: Wed, 10 Jun 2015 15:14:02 +0200

> plugged in/become available without terminating the client.

The latest commit (binary builds running and will be published in a few hours)
should fix this new issue.

Mihai