Subject: Solved with release nx-libs 3.5.0.17

From: Mike Gabriel <[email-masked]>
Date: Wed, 09 Jan 2013 12:40:29 +0100

close #87
thanks

This issue has been solved with nx-libs 3.5.0.17.

light+love
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, rothenstein 5, 24214 neudorf-bornstein
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Wed, 09 Jan 2013 11:45:59 +0000

This is an automatic notification regarding your Bug report
which was filed against the nx-libs package:

#87: parallel build issues

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: Solved with release nx-libs 3.5.0.17
From: Mike Gabriel <[email-masked]>
To: [email-masked]
Cc: [email-masked]
Date: Wed, 09 Jan 2013 12:40:29 +0100

close #87
thanks

light+love
Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

Subject: parallel build issues
From: Orion Poplawski <[email-masked]>
To: [email-masked]
Date: Fri, 14 Dec 2012 11:18:37 -0700

Package: nx-libs
Version: 3.5.0.16
Tags: patch

I've been seeing the parallel build issues in nx-libs mentioned recently. 
Tracking the build closer, it looks like a lot is getting built during the 
"make depend" stage:

depending in lib/X11...
make[5]: Entering directory `/builddir/build/BUILD/nx-libs-HEAD/nx-X11/lib/X11'
cd ../../../nxcomp &&   /builddir/build/BUILD/nx-libs-HEAD/my_configure

(I've set CONFIGURE to point to my_configure following the opensuse 
buildserver rpm specfile)

Now, why is this happening?

In nx-X11/lib/X11/Makefile there are deps like:

depend:: $(NX_XCOMPLIBTARGET)

Which triggers a build of nxcomp.  These come from nx-X11/lib/X11/Imakefile 
and are complete nonsense - why are we building things during the depend 
stage?  Removing those exposes the lack of proper build dependencies between 
NX_X11, Xcomp, and Xcompext (and what the previous depend hack was trying to 
work around).

The attached patch I believe fixes both of these issues, and hopefully fixes 
the parallel make issue as well.  It's been building fine for me now.

-- 
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA, Boulder Office                  FAX: 303-415-9702
3380 Mitchell Lane                       [email-masked]
Boulder, CO 80301                   http://www.nwra.com

--- nx-libs-HEAD/nx-X11/lib/X11/Imakefile.depend	2012-12-13 08:43:53.000000000 -0700
+++ nx-libs-HEAD/nx-X11/lib/X11/Imakefile	2012-12-14 10:57:45.413053462 -0700
@@ -1159,32 +1159,18 @@
 	cd ../../../nxcompext && \
 	${CONFIGURE}
 
-#ifdef SunArchitecture
 $(NX_XCOMPLIBTARGET): $(NX_XCOMPCONFIGTARGET)
 	${MAKE} -C $(NX_XCOMPLIBDIR)
 
-$(NX_XCOMPEXTLIBTARGET): $(NX_XCOMPEXTCONFIGTARGET)
+$(NX_XCOMPEXTLIBTARGET): $(NX_XCOMPEXTCONFIGTARGET) $(NX_XCOMPLIBTARGET) lib$(LIBNAME).so.$(SOXLIBREV)
 	${MAKE} -C ../../../nxcompext
 
-#else
-$(NX_XCOMPLIBTARGET): $(NX_XCOMPCONFIGTARGET)
-	${MAKE} -C $(NX_XCOMPLIBDIR)
-
-$(NX_XCOMPEXTLIBTARGET): $(NX_XCOMPEXTCONFIGTARGET)
-	${MAKE} -C ../../../nxcompext
-
-#endif
-
-depend:: $(NX_XCOMPLIBTARGET)
-
-all:: $(NX_XCOMPLIBTARGET)
+lib$(LIBNAME).so.$(SOXLIBREV): $(NX_XCOMPLIBTARGET)
 
 $(NX_XCOMPDEPTARGET):
 	ln -s $(NX_XCOMPLIBDIR)/$(NX_XCOMPLIBNAME) $(BUILDLIBDIR)/$(NX_XCOMPLIBNAME)
 	ln -s $(NX_XCOMPLIBDIR)/$(NX_XCOMPLIBNAME).1 $(BUILDLIBDIR)/$(NX_XCOMPLIBNAME).1
 
-depend:: $(NX_XCOMPLIBTARGET)
-
 all:: $(NX_XCOMPDEPTARGET) $(NX_XCOMPEXTLIBTARGET) 
 
 clean::