Subject: Bug#866: Info received and FILED only (Closing/Archiving)

From: "X2Go Bug Tracking System" <[email-masked]>
Date: Tue, 30 Jan 2024 22:00:06 +0000

Thank you for the additional information you have supplied regarding
this Bug report.

This is an automatically generated reply to let you know your message
has been received.

Your message has not been forwarded to the package maintainers or
other interested parties; you should ensure that the developers are
aware of the problem you have entered into the system - preferably
quoting the Bug reference number, #866.

If you wish to submit further information on this problem, please
send it to [email-masked].

Please do not send mail to [email-masked] unless you wish
to report a problem with the Bug-tracking system.

-- 
866: https://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=866
X2Go Bug Tracking System
Contact [email-masked] with problems

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Tue, 30 Jan 2024 22:00:06 +0000

This is an automatic notification regarding your Bug report
which was filed against the nx-libs package:

#866: Fix compilation errors in nxcomp (nx-libs) when macros TEST/DEBUG/... are defined (developer support)

It has been closed by Stefan Baur <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Stefan Baur <[email-masked]> by
replying to this email.

Subject: Closing/Archiving
From: Stefan Baur <[email-masked]>
To: [email-masked]
Date: Tue, 30 Jan 2024 22:57:42 +0100

Control: close -1
Control: archive -1

This bug has long since been moved to the Arctica Project Github issue 
tracker.

Kind Regards,
Stefan Baur
-- 
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243

Subject: Fix compilation errors in nxcomp (nx-libs) when macros TEST/DEBUG/... are defined (developer support)
From: Nito Martinez <[email-masked]>
To: [email-masked]
Date: Fri, 08 May 2015 00:35:09 +0200

Package: nx-libs
Version: 3.5.0.28

Description:

The attached patch fixes some compilation errors when the following 
macros are enabled: (TEST/DEBUG/DUMP). See the lines:

#undef TEST
#undef DEBUG
...

and the conditinal ifdefs

#ifdef TEST
#ifdef DEBUG
...

which are normally not compiled.

During debugging and testing when these macros gets activated, there are 
some compilation errors, which need to be manually fixed each time the 
Macros are enabled. This patch tries to leverage that error.

The patch does not affect code outside of those ifdef, and only provides 
developer support.

Regards,

Nito

diff --git a/nxcomp/Agent.h b/nxcomp/Agent.h
index fac5acd..1a59412 100644
--- a/nxcomp/Agent.h
+++ b/nxcomp/Agent.h
@@ -205,7 +205,7 @@ class Agent
   {
     #if defined(TEST) || defined(INFO)
     *logofs << "Agent: proxyCanRead() is "
-            << ((int) FD_ISSET(proxy -> getFd(), readSet)
+            << ((int) FD_ISSET(proxy -> getFd(), readSet))
             << ".\n" << logofs_flush;
     #endif
 
diff --git a/nxcomp/ClearArea.cpp b/nxcomp/ClearArea.cpp
index 7b693c7..81beb1e 100644
--- a/nxcomp/ClearArea.cpp
+++ b/nxcomp/ClearArea.cpp
@@ -92,7 +92,7 @@ void ClearAreaStore::dumpIdentity(const Message *message) const
 
   ClearAreaMessage *clearArea = (ClearAreaMessage *) message;
 
-  *logofs << name() << ": Identity exposures " << clearArea -> (unsigned int) exposures 
+  *logofs << name() << ": Identity exposures " << (unsigned int) clearArea -> exposures
           << ", window " << clearArea -> window  << ", x " << clearArea -> x
           << ", y " << clearArea -> y << ", width  " << clearArea -> width
           << ", height " << clearArea -> height << ", size " << clearArea -> size_
diff --git a/nxcomp/Proxy.cpp b/nxcomp/Proxy.cpp
index 7258fcf..b4b23a9 100644
--- a/nxcomp/Proxy.cpp
+++ b/nxcomp/Proxy.cpp
@@ -5169,7 +5169,7 @@ char *Proxy::handleSaveAllStores(const char *savePath) const
 
   *(cacheDumpName + DEFAULT_STRING_LENGTH - 1) = '\0';
 
-  mode_t fileMode = umask(0077);
+  fileMode = umask(0077);
 
   cacheDump = new ofstream(cacheDumpName, ios::out);
 
diff --git a/nxcomp/ServerChannel.cpp b/nxcomp/ServerChannel.cpp
index 52551e7..7f3ef07 100644
--- a/nxcomp/ServerChannel.cpp
+++ b/nxcomp/ServerChannel.cpp
@@ -5475,7 +5475,7 @@ int ServerChannel::handleColormap(unsigned char &opcode, unsigned char *&buffer,
     *logofs << "handleColormap: Dumping colormap entries:\n"
             << logofs_flush;
 
-    const unsigned char *p = unpackState_[resource] -> colormap -> data;
+    const unsigned int *p = unpackState_[resource] -> colormap -> data;
 
     for (unsigned int i = 0; i < unpackState_[resource] ->
              colormap -> entries; i++)