Subject: The reported issue has been fixed in X2Go Server 4.0.0.1

From: Mike Gabriel <[email-masked]>
Date: Sat, 23 Mar 2013 01:51:12 +0100

close #83
close #86
close #105
close #121
thanks

The reported issue has been solved in release 4.0.0.1 of X2Go Server.

light+love,
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, rothenstein 5, 24214 neudorf-bornstein
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Sat, 23 Mar 2013 01:03:04 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goserver package:

#86: Use x2gopath in Server/DB perl modules

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: The reported issue has been fixed in X2Go Server 4.0.0.1
From: Mike Gabriel <[email-masked]>
To: [email-masked], [email-masked], [email-masked], [email-masked]
Cc: [email-masked]
Date: Sat, 23 Mar 2013 01:51:12 +0100

close #83
close #86
close #105
close #121
thanks

light+love,
Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

Subject: Use x2gopath in Server/DB perl modules
From: Orion Poplawski <[email-masked]>
To: [email-masked]
Date: Fri, 14 Dec 2012 08:59:17 -0700

Package: x2goserver
Version: 3.2.0.0
Tags: patch

-- 
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA, Boulder Office                  FAX: 303-415-9702
3380 Mitchell Lane                       [email-masked]
Boulder, CO 80301                   http://www.nwra.com

>From d2f4aadfe93f46ba95aead73ddfc9e61f3b6807e Mon Sep 17 00:00:00 2001
From: Orion Poplawski <[email-masked]>
Date: Thu, 13 Dec 2012 11:05:02 -0700
Subject: [PATCH] Use x2gopath in Server/DB perl modules

---
 X2Go/Server/DB.pm            | 2 +-
 X2Go/Server/DB/PostgreSQL.pm | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/X2Go/Server/DB.pm b/X2Go/Server/DB.pm
index 45f1ec9..c9a83a1 100644
--- a/X2Go/Server/DB.pm
+++ b/X2Go/Server/DB.pm
@@ -44,7 +44,7 @@ setlogmask( LOG_UPTO(loglevel()) );
 my ($uname, $pass, $uid, $pgid, $quota, $comment, $gcos, $homedir, $shell, $expire) = getpwuid(getuid());
 
 my $Config = new Config::Simple(syntax=>'ini');
-my $x2go_lib_path=`echo -n \$(x2gobasepath)/lib/x2go`;
+my $x2go_lib_path=`x2gopath libexec`;
 
 $Config->read('/etc/x2go/x2gosql/sql' ) or die "Can't read config file /etc/x2go/x2gosql/sql";
 my $backend=$Config->param("backend");
diff --git a/X2Go/Server/DB/PostgreSQL.pm b/X2Go/Server/DB/PostgreSQL.pm
index 2400f60..72ba833 100644
--- a/X2Go/Server/DB/PostgreSQL.pm
+++ b/X2Go/Server/DB/PostgreSQL.pm
@@ -61,7 +61,7 @@ sub init_db
 	if ( ! ( $dbuser and $dbpass ) )
 	{
 		my $Config = new Config::Simple(syntax=>'ini');
-		my $x2go_lib_path=`echo -n \$(x2gobasepath)/lib/x2go`;
+		my $x2go_lib_path=`x2gopath libexec`;
 
 		$Config->read('/etc/x2go/x2gosql/sql' ) or die "Can't read config file /etc/x2go/x2gosql/sql";
 		my $backend=$Config->param("backend");
-- 
1.8.0.2