Subject: Copy-paste limitations not working

From: Thibaut Pouzet <[email-masked]>
Date: Mon, 27 Apr 2015 15:16:13 +0200

Package: x2goserver
Version: 4.0.1.18-5.el6.x86_64

Hi,

I use x2go to connect to a remote machine for almost a year now. When I
configured it last year, I put inside the file
/etc/x2go/x2goagent.options the option :

X2GO_NXAGENT_DEFAULT_OPTIONS="$ uname -a
Linux rob.lbg.office.lyra 3.10.0-123.20.1.el7.x86_64 #1 SMP Thu Jan 29
18:05:33 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux"

I'm certain that at that time, I could not extract information from the
remote server via copy-paste. (Which is the goal I'm aiming)

Lately, I realized that I could extract data via copy-paste, even though
the configuration line was still there. No error logs, this looks like a
regression to me.

Procedure :
* Put the option inside the configuration file on the server
* Open a session from any client to this server
* Inside x2go, copy something
* Outside x2go on the client host, paste it

This should not work with the option "-clipboard client".

My setup :
* Server side (CentOS 6.6) :
$ uname -a
Linux xx 2.6.32-431.29.2.el6.x86_64 #1 SMP Tue Sep 9 21:36:05 UTC 2014
x86_64 x86_64 x86_64 GNU/Linux
$ rpm -qa | fgrep x2go
x2goserver-4.0.1.18-5.el6.x86_64
x2goagent-3.5.0.27-1.el6.x86_64
x2goclient-4.0.1.4-1.el6.x86_64

* Client side (CentOS 7.1) :
$ uname -a
Linux xx 3.10.0-123.20.1.el7.x86_64 #1 SMP Thu Jan 29 18:05:33 UTC 2015
x86_64 x86_64 x86_64 GNU/Linux
$ rpm -qa | fgrep x2go
x2goclient-4.0.3.1-1.el7.x86_64

Cheers,

-- 
Thibaut Pouzet
Lyra Network
Ingénieur Systèmes et Réseaux
(+33) 5 31 22 40 08
www.lyra-network.com

---

From: Mihai Moldovan <[email-masked]>
Date: Thu, 30 Apr 2015 19:21:17 +0200

> 18:05:33 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux"

Heh. Speaking of paste failures...

That's probably not the real string.

Mihai

---

From: Thibaut Pouzet <[email-masked]>
Date: Mon, 11 May 2015 16:30:28 +0200

> That's probably not the real string.

Well... Sorry, I meant the following :

X2GO_NXAGENT_DEFAULT_OPTIONS="-clipboard client"

Cheers,