Subject: With patch attached

From: Bernard Cafarelli <[email-masked]>
Date: Fri, 24 Apr 2015 15:59:11 +0200

Tested with gold linker from binutils 2.25 and current nx-libs/x2go 
packages

--- nx-X11/lib/X11/Imakefile.orig	2015-04-24 15:24:36.171666957 +0200
+++ nx-X11/lib/X11/Imakefile	2015-04-24 15:25:17.516179627 +0200
@@ -107,7 +107,7 @@
 EXCLUDE_SYMBOL = -Wl,--exclude-symbol,XdmcpWrap:_XdmcpWrapperToOddParity
 #endif
 
-REQUIREDLIBS=$(REQUIREDX11LIBS) $(REQUIREDI18NLIBS) $(EXCLUDE_SYMBOL) $(NX_REQUIREDLIBS)
+REQUIREDLIBS=$(REQUIREDX11LIBS) $(REQUIREDI18NLIBS) $(EXCLUDE_SYMBOL) $(NX_REQUIREDLIBS) -ldl
 
 #if defined(MacIIArchitecture) || defined(SequentArchitecture) || defined(i386ScoArchitecture)
 XBSDLIB = /**/

---

From: Mihai Moldovan <[email-masked]>
Date: Fri, 24 Apr 2015 17:04:23 +0200

> Tested with gold linker from binutils 2.25 and current nx-libs/x2go 

Thanks, will be merging that in as discussed on IRC.

Mihai

---

From: Mike Gabriel <[email-masked]>
Date: Sun, 26 Apr 2015 13:44:47 +0000

Hi Mihai, hi Bernard,

> Thanks, will be merging that in as discussed on IRC.

Fixed on 3.6.x branch of nx-libs:
https://github.com/ArcticaProject/nx-libs/commit/f46b43261c5b2e979d6ec2d9da7b00c6ee1c69e2

The patch provided by Bernhard was not quite appropriate, I moved the  
-ldl option into nx-X11/config/cf/lnxLib.tmpl.

Please backport this patch to the 3.5.0.x branch on git.x2go.org.

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Mihai Moldovan <[email-masked]>
Date: Sun, 26 Apr 2015 17:39:24 +0200

> Please backport this patch to the 3.5.0.x branch on git.x2go.org.

I haven't applied this patch yet on the 3.6.x branch because I didn't want you to have to rebase your PRs.

I.e., I was going to apply it after PR #17 was merged.

It's too late for that now, though...

Mihai