Subject: Bug#845: Intentional forced language?

From: Jaakko Haavisto <[email-masked]>
Date: Thu, 30 Apr 2015 10:53:59 +0000 (UTC)

I don't mean to offend you and the x2go team. The point what I was trying to make is that location and language are complete different things. For example when I set my windows location to England, then my programs/widgets are telling me what's the weather in England and telling what's happening in England (information that I don't need). The point is that in windows control panel there aren't any good setting for changing the language of the programs.
I like this MSDN way of developing localization of windows applications:
(https://msdn.microsoft.com/en-us/library/windows/desktop/dd317790(v=vs.85).aspx)User Interface Language Settings
When planning your MUI application, you must first decide on the languages for the user interface and the way to present them to the user. The application can support languages in one of these ways:   
   - Follow system language settings. Assume that the user preferred UI languages and the system preferred UI languages, taken together, represent the languages available to the user. Use the fallback mechanism of the resource loader for language selection.
   - Make application-specific language settings. Support specific languages and present a selection mechanism to the user.

ps. I don't wan't to exploit bug to change the language, because I can handle Finnish and English languages, but I have colleagues that aren't from Finland and their x2go user experience would be much better if they could use whatever language they choose without changing windows location. So I started this conversion with you so I could propose that adding language selection menu to x2go settings could benefit a lot of people.

---

From: Mihai Moldovan <[email-masked]>
Date: Thu, 30 Apr 2015 13:06:48 +0200

On 30.04.2015 12:53 PM, Jaakko Haavisto wrote:
> I don't mean to offend you and the x2go team. The point what I was trying to
> make is that location and language are complete different things.

Yes, they are.

> The point is that in windows control panel
> there aren't any good setting for changing the language of the programs.

That's not true. You can set your preferred/enforced language in there.

> When planning your MUI application, you must first decide on the languages for
> the user interface and the way to present them to the user. The application can
> support languages in one of these ways:
> 
>   * Follow system language settings. Assume that the user preferred UI languages
>     and the system preferred UI languages, taken together, represent the
>     languages available to the user. Use the fallback mechanism of the resource
>     loader for language selection.

Which is exactly what X2Go Client does, or isn't it?

>   * Make application-specific language settings. Support specific languages and
>     present a selection mechanism to the user.

Not doing this optional suggestion, though.

> ps. I don't wan't to exploit bug to change the language, because I can handle
> Finnish and English languages, but I have colleagues that aren't from Finland
> and their x2go user experience would be much better if they could use whatever
> language they choose without changing windows location. So I started this
> conversion with you so I could propose that adding language selection menu to
> x2go settings could benefit a lot of people.

Sorry, but I don't understand your problem.

In the Windows system settings, language and location settings are two different
things, as you already mentioned.
I generally set my location to Germany and the language to US English. That's
working like a charm for every application I have met so far, including X2Go Client.

Mihai

---

From: Mihai Moldovan <[email-masked]>
Date: Thu, 30 Apr 2015 13:34:56 +0200

On 30.04.2015 01:22 PM, Jaakko Haavisto wrote:
> Hi,
> 
> Quick question. Where do you change the language?
> I have this kind of "region and language" options:
> Inline image
> 
> My "display language" is "English(English)" and still X2go is in Finnish.

You probably need to install the English language pack to be able to select it.

https://ionic.de/tmp/Windows_7_language_selector.png

This is on Windows 7. I don't know about other versions.

Mihai

---

From: Mihai Moldovan <[email-masked]>
Date: Thu, 30 Apr 2015 13:49:59 +0200

On 30.04.2015 01:43 PM, Jaakko Haavisto wrote:
> When I click that install/uninstall languages and choose uninstall languages I
> can see there is English which is "language is the system language (default
> language of the user interface)".
> 
> The choose isn't there if only one language is installed I guess because it
> works so in every English windows 7 computers here.
> 
> I thinks it is then bug in x2go, because it's using Finnish and not English
> which is system language.

Can you please go to the "Administrative" tab and click "Copy settings..."?

A dialog like this should pop up:
https://www.ionic.de/tmp/Windows_7_language_selector2.png

What's its full content?

(Naturally, you can click "Cancel" to not copy any settings!)

Mihai

---

From: Mihai Moldovan <[email-masked]>
Date: Thu, 30 Apr 2015 13:52:27 +0200

> (Naturally, you can click "Cancel" to not copy any settings!)

Additionally, what is listed as the "Language for non-Unicode programs" in the
Administrative tab?

Mihai

---

From: Jaakko Haavisto <[email-masked]>
Date: Mon, 4 May 2015 05:23:58 +0000 (UTC)

Hi,
Sorry that this took so long, but it was labour day here in Finland. Here's the screenshot of the settings:http://imgur.com/qQ0dejc
 
And language for non-Unicode programs is English (United States).

     On Thursday, April 30, 2015 2:57 PM, Mihai Moldovan <[email-masked]> wrote:

What's its full content?

Mihai

---

From: Mihai Moldovan <[email-masked]>
Date: Mon, 04 May 2015 19:11:55 +0200

Control: reopen -1 =
Control: tags -1 - not-a-bug wontfix

On 04.05.2015 07:23 AM, Jaakko Haavisto wrote:
> Sorry that this took so long, but it was labour day here in Finland.

s/Finland/everywhere/

> Here's the screenshot of the settings: http://imgur.com/qQ0dejc
> 

Hmm, OK, that looks alright. It's a bug indeed. Triggered by Qt 4.8.x, but still.

Thanks for going down that road with me!

Mihai

---

From: Mihai Moldovan <[email-masked]>
Date: Mon, 04 May 2015 23:43:36 +0200

> Thanks for going down that road with me!

Please fetch
http://code.x2go.org/releases/binary-win32/x2goclient/heuler/mingw32-4.8/qt-4.8/x2goclient-4.0.4.0-2015.04.27-e7f48c2-setup.exe

And tell me, how that works for you. It's our nightly X2Go Client build for
Windows, right after my change.

Mihai

---

From: Jaakko Haavisto <[email-masked]>
Date: Tue, 5 May 2015 08:52:36 +0000 (UTC)

Tested that nightly build by uninstalling the old x2go client and then installing that nightly build.It seems that the fix doesn't work because x2go is still in Finnish language.

---

From: Mihai Moldovan <[email-masked]>
Date: Tue, 12 May 2015 06:21:09 +0200

On 05.05.2015 10:52 AM, Jaakko Haavisto wrote:
> Tested that nightly build by uninstalling the old x2go client and then
> installing that nightly build.
> It seems that the fix doesn't work because x2go is still in Finnish language.

That was Qt fighting back.

I believe I finally beat it into submission.

Please try
http://code.x2go.org/releases/binary-win32/x2goclient/heuler/mingw32-4.8/qt-4.8/x2goclient-4.0.4.0-2015.05.12-181fc10-setup.exe

Mihai

---

From: Jaakko Haavisto <[email-masked]>
Date: Tue, 12 May 2015 09:18:06 +0000 (UTC)

Tested that new release and it's working. Language is in English as it should be. Thanks! :)