Subject: Screen resize triggers session suspension

From: Florian Wicke - Hetzner Online AG <[email-masked]>
Date: Thu, 26 Mar 2015 11:21:27 +0100

Package: nx-x11-common
Version: 3.5.0.32-0x2go1~git20150317.672+jessie.heuler.1

Reproducable with every client and server so far from stable and heuler.
Only affects full sessions - users are not affected if running directly
an APPLICATION.

Pressing CTRL+ALT+R triggers error message in session.log of user,
resizes the screen but also triggers suspension of the session (note the
the Proxy-Warning does not occur every time):
Session: Resuming session at 'Thu Mar 26 11:11:56 2015'.
Info: Proxy running in server mode with pid '18054'.
Info: Waiting for connection from 'localhost' on port '30076'.
Info: Accepted connection from '127.0.0.1'.
Info: Connection with remote proxy completed.
Info: Using LAN link parameters 1536/24/1/0.
Info: Using agent parameters 5000/0/50/0/0.
Info: Using pack method '16m-jpeg-9' with session 'unix-kde-depth_24'.
Info: Not using NX delta compression.
Info: Not using ZLIB data compression.
Info: Not using ZLIB stream compression.
Info: Not using a persistent cache.
Info: Listening to X11 connections on display ':75'.
Info: Established X client connection.
Info: Using shared memory parameters 1/1/0/0K.
Info: Using local device configuration changes.
keyboard file created
Session: Session resumed at 'Thu Mar 26 11:12:03 2015'.
Info: Screen [0] resized to geometry [3840x1080] fullscreen [1].
<<-------- note from me: pressing ctrl+alt+r --------->>
Info: Disabled desktop resize mode in agent.
Session: Suspending session at 'Thu Mar 26 11:12:14 2015'.
Proxy: WARNING! Handling data for finishing FD#5 channel ID#1.
 suspended at 'Thu Mar 26 11:12:14 2015'.

Unfortunately we think this leads to another problem. Sometimes users
get suspended right after resuming their session:

Session: Session resumed at 'Wed Mar 25 21:30:37 2015'.
Info: Screen [0] resized to geometry [1680x1050] fullscreen [1].
Session: Suspending session at 'Wed Mar 25 21:30:39 2015'.

And last but not least this results in another problem - the screen does
not get resized correctly sometimes and is just shown as viewport.

Kind regards

 Florian Wicke

Hetzner Online AG
Industriestr. 25
91710 Gunzenhausen / Germany
Tel: +49 9831 505-0
Fax: +49 9831 505-3
[email-masked]
www.hetzner.com

Register Court: Registergericht Ansbach, HRB 3204
Management Board: Dipl. Ing. (FH) Martin Hetzner
Chairwoman of the Supervisory Board: Diana Rothhan

---

From: Mike Gabriel <[email-masked]>
Date: Wed, 24 Feb 2016 14:41:39 +0000

Control: forwarded -1 https://github.com/ArcticaProject/nx-libs/issues/91

> not get resized correctly sometimes and is just shown as viewport.

This issue is now being tracked on Github:
https://github.com/ArcticaProject/nx-libs/issues/91

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/mailxchange/kronolith/fb.php?u=m.gabriel%40das-netzwerkteam.de