Subject: Bug#829: Info received and FILED only (Closing/Archiving)

From: "X2Go Bug Tracking System" <[email-masked]>
Date: Tue, 30 Jan 2024 22:00:01 +0000

Thank you for the additional information you have supplied regarding
this Bug report.

This is an automatically generated reply to let you know your message
has been received.

Your message has not been forwarded to the package maintainers or
other interested parties; you should ensure that the developers are
aware of the problem you have entered into the system - preferably
quoting the Bug reference number, #829.

If you wish to submit further information on this problem, please
send it to [email-masked].

Please do not send mail to [email-masked] unless you wish
to report a problem with the Bug-tracking system.

-- 
829: https://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=829
X2Go Bug Tracking System
Contact [email-masked] with problems

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Tue, 30 Jan 2024 22:00:03 +0000

This is an automatic notification regarding your Bug report
which was filed against the nx-libs package:

#829: Screen resize triggers session suspension

It has been closed by Stefan Baur <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Stefan Baur <[email-masked]> by
replying to this email.

Subject: Closing/Archiving
From: Stefan Baur <[email-masked]>
To: [email-masked]
Date: Tue, 30 Jan 2024 22:55:35 +0100

Control: close -1
Control: archive -1

This bug has long since been moved to the Arctica Project Github issue 
tracker.

Kind Regards,
Stefan Baur
-- 
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243

Subject: Screen resize triggers session suspension
From: Florian Wicke - Hetzner Online AG <[email-masked]>
To: [email-masked]
Date: Thu, 26 Mar 2015 11:21:27 +0100

Package: nx-x11-common
Version: 3.5.0.32-0x2go1~git20150317.672+jessie.heuler.1

Reproducable with every client and server so far from stable and heuler.
Only affects full sessions - users are not affected if running directly
an APPLICATION.

Pressing CTRL+ALT+R triggers error message in session.log of user,
resizes the screen but also triggers suspension of the session (note the
the Proxy-Warning does not occur every time):
Session: Resuming session at 'Thu Mar 26 11:11:56 2015'.
Info: Proxy running in server mode with pid '18054'.
Info: Waiting for connection from 'localhost' on port '30076'.
Info: Accepted connection from '127.0.0.1'.
Info: Connection with remote proxy completed.
Info: Using LAN link parameters 1536/24/1/0.
Info: Using agent parameters 5000/0/50/0/0.
Info: Using pack method '16m-jpeg-9' with session 'unix-kde-depth_24'.
Info: Not using NX delta compression.
Info: Not using ZLIB data compression.
Info: Not using ZLIB stream compression.
Info: Not using a persistent cache.
Info: Listening to X11 connections on display ':75'.
Info: Established X client connection.
Info: Using shared memory parameters 1/1/0/0K.
Info: Using local device configuration changes.
keyboard file created
Session: Session resumed at 'Thu Mar 26 11:12:03 2015'.
Info: Screen [0] resized to geometry [3840x1080] fullscreen [1].
<<-------- note from me: pressing ctrl+alt+r --------->>
Info: Disabled desktop resize mode in agent.
Session: Suspending session at 'Thu Mar 26 11:12:14 2015'.
Proxy: WARNING! Handling data for finishing FD#5 channel ID#1.
 suspended at 'Thu Mar 26 11:12:14 2015'.

Unfortunately we think this leads to another problem. Sometimes users
get suspended right after resuming their session:

Session: Session resumed at 'Wed Mar 25 21:30:37 2015'.
Info: Screen [0] resized to geometry [1680x1050] fullscreen [1].
Session: Suspending session at 'Wed Mar 25 21:30:39 2015'.

And last but not least this results in another problem - the screen does
not get resized correctly sometimes and is just shown as viewport.

Kind regards

 Florian Wicke

Hetzner Online AG
Industriestr. 25
91710 Gunzenhausen / Germany
Tel: +49 9831 505-0
Fax: +49 9831 505-3
[email-masked]
www.hetzner.com

Register Court: Registergericht Ansbach, HRB 3204
Management Board: Dipl. Ing. (FH) Martin Hetzner
Chairwoman of the Supervisory Board: Diana Rothhan